USB smart card reader: improvement since RC2, but still unusable

Discussion in 'Parallels Desktop for Mac' started by patches, Jun 15, 2006.

  1. patches

    patches

    Messages:
    18
    In RC2, when I connected my GemPlus PC433 smart card reader, I got the 5-10 sec error message.

    Since installing the release version, I now see the smart card reader checked in the devices-USB menu. This is an improvement.

    But, the smart card software on the XP VM still cannot recognize it and returns an error that it is not attached.

    Like many other customers, this means that parallels is "virtually" useless to me. If I can't VPN into work, I can't use it.

    Releasing at this time seems like a classic Microsoft manuver. When the bar for what constitutes a bug is set too low for the marketing dept., raise the bar. That's not a bug, its a feature.

    I don't mean to be too hard on the Parallels people, they are doing the best they can. But, there has to be a resolution to this in very short order. If I have to take the time to install Boot Camp, I'm not going to take the time to go back to Parallels.

    And, maybe because they already have my money, they don't care. But they will lose an important component to growth: positive word of mouth. At least from this customer.

    Otherwise, congratulations to Parallels on a good product, just one that's incomplete.
     
  2. Menace

    Menace Bit Poster

    Messages:
    52
    I would rename the Final Release to "Semi-Final Release" :) .
     
  3. grahamwright1

    grahamwright1

    Messages:
    1
    Being limited to an 80 Gig HD on my MacMini means that BootCamp is a long way from the ideal solution, forcing me to give up a significant part of my drive to an XP partition. The main advantage of Parallels is my VM image can go onto an external Firewire drive, and I can make it much larger than I could under BootCamp.

    I think this benefit of using external disks is key and I can live without perfection in the short term. Eventually they will get these USB issues resolved, and based upon their release cycles during the beta it is likely there will be improvements fairly quickly. My person feeling is they have made the right descison in getting it out the door where it is good enough for many people.
     
  4. dkp

    dkp

    Messages:
    1,367
    While you sit and pout thousands of us are using and are happy with Parallels. It is unfortunate it isn't working for you, but in fact it does work great for a lot of people - quite possibly the vast majority. That is the definition of a good product.

    And I don't think development is going to stop. With the release of the golden code you are now a customer and they are obliged to help you get your problem solved or tell you it cannot be solved and to refund your money.

    dp
     
  5. akac

    akac

    Messages:
    144
    I think from their comment on WM5 synching, Parallels' USB design is weak and requires a rework to support the more complex USB devices.
     
  6. rod

    rod

    Messages:
    1
    More USB issues...

    Parallels desktop is going to be a great product. I'm really glad to see it,
    and glad their price point is below Virtual PC for the PPC.

    But at the moment I'm pretty frustrated with the USB support on the
    released product (build 1848, June 12, 2006).

    I have three USB devices I want to use with it. All of them work with Boot Camp (which in spite of what Apple says can be installed from an upgrade (if you put the older MS CD in a USB CD ROM during the install)). None of them work properly with the Parallels product at the moment.

    Two are somewhat obscure, expensive products: a Skybound card writer
    from Jeppesen for updating Garmin GPS cards, and a digital oscilloscope
    (AX pro) from USBee. Both give the message 'can't load driver [code 10]'.
    One of them goes into a load, unload, load cycle while doing this. Neither of these devices is usable with Parallels.

    The third product is a Keyspan serial IO module (USA 19HS) which,
    I get the impresssion from Google's page rank, is the most popular
    serial IO device for OS X. (From my own experience it certainly works
    very well; much better than anything else I've tried.)

    The problem with the Keyspan device is the "USB device you are trying to connect to the virtual machine is being used by another process. Wait 5-10 seconds, then try to connect the device again." message.

    This is fixable with the command (run as root):
    'kextunload /System/Library/Extensions/KeyspanUSAdriver.kext'.
    (The OS X driver can be restored by rebooting or via:
    'kextload /System/Library/Extensions/KeyspanUSAdriver.kext'.)

    That's pretty obscure though, and it would be a lot better if toggling
    'Devices->USB->Keyspan USA-19HS' just worked.
     
  7. ArmyDuck

    ArmyDuck

    Messages:
    4
    Patches, I too think that this is a great product, BUT I really need CAC reader functionality for work. I am still struggling to make my CAC reader install. I'm running the final version of Parallels and Win2K and WinXP both recognize that the reader is attached, but it will lock up with trying to install/update drivers. Parallels desktop recognizes also that the reader is installed. Have you heard anything else about this? I submitted a bug/tech request and got an email saying that the USB issues would be fixed with the final release. Of course, I'm still having problems, but only with this one issue. It is a very minor annoyance, and without this functionality, I am still stuck with having to use a windows computer (argh!). I hate to say it, but my iBook running MS Virtual PC did actually allow me to use my CAC reader (although SUPER slow). Let me know if you hear anything...or if anyone knows of any chat of this being fixed. Thanks! Otherwise, I LOVE Parallels. It's a great product...but I'd like to see this issue addressed!
     
  8. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    ArmyDuck,

    Thanks for report - we will investigate problems with CAC reader.
     
  9. bobap1950

    bobap1950

    Messages:
    4
    USB Problems

    I have been trying to get answers regarding USB problems from Parallels support but so far their support has been the worst I have ever seen for a product that I purchased.

    USB would not work at all on my system and Parallels is useless to me without USB. With the latest beta version usb will now work while I am in Root, but not when I am in as a user. I am new to Linux (Ubuntu) so I am sure that I need to change some permissions or something. Any advise on getting USB to work right would be appreciated.

    Thank you.

    Bob
     

Share This Page