USB to serial converter

Discussion in 'General Questions' started by tonydenson, May 4, 2007.

  1. Zyrus

    Zyrus Bit poster

    can somebody tell me, when I am using a USB 2 serial adapter, recognize the Mac the adapter as an USB 2 device (in he USB tree in "about the Mac"), althouth the serial is working by 14 Kbit.
    (Thats because I need more than 2 USB Serial devices and Parallels is working only with two USB 1.1)
    Thanks from Vienna
  2. rstrauch

    rstrauch Junior Member

    Problem with SerialClient

    I'm trying to connect a Magellan Sportrak to Mapsend TOPO 3D using a keyspan adapter and I can't get SerialClient to connect to the Keyspan.

    SerialClient's dropdown menu offers me a choice of three serial ports -- named Serial-1, KeySerial1, and USA19H1d1P1.1. The latter two are the ports from the Keyspan adapater. SerialClient won't connect to either of those, giving me an error message "(2) No such file or directory."

    The only port that will connect is Serial-1. When I connect there and ask TOPO to search for the GPS, a repeating text string shows up in the SerialClient log. So the connection from TOPO to SerialClient is working, but there's no connection to the keyspan.

    I don't know what Serial-1 represents, so don't know if there's any way I can make use of it. Can I get SerialClient to recognize one of the Keyspan ports?

    Also, should I be using anything other than SerialClient's default settings for things like number of bits, parity, and flow control?

    Ralph Strauch
  3. SethPowsner

    SethPowsner Bit poster

    What worked for me --
    eTrex Vista 3.70 & 3.80 firmware
    Mac OS X 10.4.11 (Tiger)
    Parallels 3 build 5600
    Windows XP SP2
    USB Serial Radio Shack 26-183
    using Radio Shack Windows drivers
    Serial (at 9600 8,N,1, had trouble changing baud rate)
    KeySpan USA18-QW
    using KeySpan Mac OS X drivers

    What Did Not Work--
    Garmin MapInstall & MapManager 2030 Beta
    ran fine, including MapConverter Windows->Mac
    but does not recognize USB -> Serial -> eTrex
    documentation says it will only work with direct USB GPS unit
    Keyspan USA19-QW in Parallels
    various Parallels forum comments suggest that Windows driver
    does not run reliably in Parallels (perhaps specific a Keyspan issue)
    Parallels can't grab device from Mac OS X Keyspan drivers
    (can't be loaded at start up)

    The prior notes in this thread were a big help. Thank you all.
    Hope this note helps someone else...
  4. David Robinson

    David Robinson Bit poster


    I know it's been awhile since this was posted, but I finally ran into this problem and this suggestion got me off dead-center. However, I still have the problem (recognized by Garmin apparently) of the WebUpdater hanging during Erase. Since the discussion below got me almost to the point of solution, I was wondering if anyone had gotten Parallels/WebUpdater/Keyspan to not hang during transfer.

    Thanks in advance,

  5. SethPowsner

    SethPowsner Bit poster

    Pure speculation-- WebUpdater may need tighter serial port control than available through the WebUpdater, Windows, Parallels, Serialclient, Mac OS X combination of software. Sorry I didn't write in my June 2008 post that using a separate USB serial device worked better: presumably 'cause Windows has more direct control. Good luck.
  6. marceloc

    marceloc Bit poster

    Good afternoon

    I am looking for SerialClient utility to download, but I can't find.

    Do you have the installer in you HD?

    Could you sent it to me?

    Thank you
  7. wbanz01

    wbanz01 Bit poster

    USB Serial adapter com port #

    I have a Windows application which communicates with a weather station through a com port. I have installed Prolific Technologies USB-Serial Driver which comes with the USB-Serial adapter which comes with the weather station. The Weather software configuration assigns a Com Port number.
    However, whenever Windows is restarted (Vista running under Parallels 7) the USB - Serial Adapter is assigned a new Com port number and the software cannot communicate with the weather station.
    Is there a way I can define a fixed Com Port number for the USB-Serial Adapter?
  8. Riyald

    Riyald Bit poster

    There might be a possibility that you need to use kextstat to check out the appropriate bundle ID if you aren't using the same drivers. After the unload is done you have to connect the device into the VM and load the drivers of your requirement inside the guest OS.

Share This Page