USB Wireless Adapter WUA-2340

Discussion in 'Windows Guest OS Discussion' started by fmuhamm, Nov 20, 2008.

  1. fmuhamm

    fmuhamm

    Messages:
    5
    I need to use a USB wireless network adapter, because our company's wireless network uses certificates and the enterprise authentication via group policy. I am trying to use a D-Link WUA-2340. The adapter works great in Fuson, but not in Parallels. I would much rather use Parallels.

    Thanks
     
  2. Elric

    Elric Parallels Developers

    Messages:
    1,667
    Could you please try the HotFix build? It has several impovements for USB devices.
    http://forum.parallels.com/showthread.php?t=31764

    If something is not working in it we would greatly appreciate if you could send a problem report from menu "Help" -> "Report a Problem" and post the number of your report here.
     
  3. fmuhamm

    fmuhamm

    Messages:
    5
    Unfurtunately, I am not able to use the 'Report Problem' option while on the network at work, because of proxy. I installed the new version mentioned above. The guest OS recognizes the adapter, but the OS will not install the driver. I constantly get the message 'Cannot install this hardware. System cannot find the file sepcified'. I did not have the same problem in Fusion. In Parallels, I had to manually select the driver. The driver search option worked with Fusion.

    Thanks
     
  4. Elric

    Elric Parallels Developers

    Messages:
    1,667
    Hm. Could you please if it is possible Right click my computer, select "Manage" -> Device Manager, point to the USB device icon for your modem (most likely it will be under either "Other devices", "Network Adapters" or "Universal Serial Bus Controllers", right-click and select properties on this device and post here two screenshots:
    one for "Hardware Ids" and second for "Compatible Ids". For example on my machine for one of my USB devices it looks like

    [​IMG]

    Also it would be helpful if you could post version number of drivers for the D-Link WUA-2340 adapter.

    Thank you
     

    Attached Files:

  5. fmuhamm

    fmuhamm

    Messages:
    5
    Screen Shots

    Added a few more than asked for. Maybe they can help as well.

    Thanks for helping me with this issue.
     

    Attached Files:

  6. John@Parallels

    John@Parallels

    Messages:
    6,450
    Please reply me with in PM with following information:

    * an XML file with a copy of system profile: Applications --> Utilities --> System Profiler --> File
    * Guest OS full version with SP included (if they are);
    * From /Users/<username>/Documents/Parallels/<VM name>.pvm -CTRL+CLICK -select Show Package Contents
    - config.pvs
    - prallels.log
    * /Library/Preferences/Parallels (right click on folder --> Create Archive)
    * /Library/Logs/panic.log
    or ~/Library/Logs/CrashReporter/ from the Mac side;
     
  7. Elric

    Elric Parallels Developers

    Messages:
    1,667
    Thank you! Screenshots were helpful.

    Could you please unzip attached win_check.zip file somewhere in the Windows VM and execute win_check.exe and then post here the output? The output should looks like

    ----
    Stage 1:
    State 1 completed successfuly.
    Press Enter to continue.

    or

    ----
    Stage 1:
    Stage 1 completed with code 2
    State 2 completed with code 0
    Press Enter to continue.
    ----

    If you will see the former output with "Stage 1 completed with code 2", please try to connect the D-Link WUA-2340 adapter again. This time it shoud work.
     

    Attached Files:

    Last edited: Nov 24, 2008
  8. Elric

    Elric Parallels Developers

    Messages:
    1,667
    And if my solution will not help, John's requests are entered to the game
     
  9. fmuhamm

    fmuhamm

    Messages:
    5
    Eric, only got the "Stage 1 completed successfully." message.

    John, the files are attached. The OS is Windows XP SP3.
     

    Attached Files:

  10. John@Parallels

    John@Parallels

    Messages:
    6,450
    Thank you, I will proceed today
     
  11. fmuhamm

    fmuhamm

    Messages:
    5
    setupapi.log

    [SetupAPI Log]
    OS Version = 5.1.2600 Service Pack 3
    Platform ID = 2 (NT)
    Service Pack = 3.0
    Suite = 0x0100
    Product Type = 1
    Architecture = x86
    [2008/12/05 15:31:47 3392.2027]
    #-198 Command line processed: C:\WINDOWS\Explorer.EXE
    #I060 Set selected driver.
    #-019 Searching for hardware ID(s): usb\vid_07d1&pid_3a08&rev_0001,usb\vid_07d1&pid_3a08
    #-018 Searching for compatible ID(s): usb\class_ff&subclass_00&prot_00,usb\class_ff&subclass_00,usb\class_ff
    #I022 Found "USB\VID_07D1&PID_3A08" in C:\WINDOWS\INF\oem20.inf; Device: "D-Link WUA-2340 USB Adapter"; Driver: "D-Link WUA-2340 USB Adapter"; Provider: "D-Link"; Mfg: "D-Link"; Section name: "WUA2340_DEV.ndi".
    #I023 Actual install section: [WUA2340_DEV.ndi.NT]. Rank: 0x00000001. Effective driver date: 05/29/2007.
    #-019 Searching for hardware ID(s): usb\vid_07d1&pid_3a08&rev_0001,usb\vid_07d1&pid_3a08
    #-018 Searching for compatible ID(s): usb\class_ff&subclass_00&prot_00,usb\class_ff&subclass_00,usb\class_ff
    #-019 Searching for hardware ID(s): usb\vid_07d1&pid_3a08&rev_0001,usb\vid_07d1&pid_3a08
    #-018 Searching for compatible ID(s): usb\class_ff&subclass_00&prot_00,usb\class_ff&subclass_00,usb\class_ff
    #-019 Searching for hardware ID(s): usb\vid_07d1&pid_3a08&rev_0001,usb\vid_07d1&pid_3a08
    #-018 Searching for compatible ID(s): usb\class_ff&subclass_00&prot_00,usb\class_ff&subclass_00,usb\class_ff
    #I022 Found "USB\VID_07D1&PID_3A08" in y:\downloads\wua2340_drivers_150\drivers\winxp_2k\netA5AGU.inf; Device: "D-Link WUA-2340 USB Adapter"; Driver: "D-Link WUA-2340 USB Adapter"; Provider: "D-Link"; Mfg: "D-Link"; Section name: "WUA2340_DEV.ndi".
    #I023 Actual install section: [WUA2340_DEV.ndi.NT]. Rank: 0x00000001. Effective driver date: 06/12/2008.
    #-166 Device install function: DIF_ALLOW_INSTALL.
    #E154 Class installer failed. Error 2: The system cannot find the file specified.
     

Share This Page