Using BOTH Windows XP and Windows 7

Discussion in 'Windows Guest OS Discussion' started by MisterKenJ, Dec 13, 2009.

  1. MisterKenJ

    MisterKenJ

    Messages:
    4
    I have two VMs running on my new 27" iMac, one for Windows XP and one for Windows 7. Almost everything is working fine (except for the occasional loss of the keyboard, as others have noticed). I have a folder for Windows XP apps and one for Windows 7 apps.

    When, in Finder, I click on a .exe (Windows executable) file, Parallels insists on starting the VM for Windows XP, even though Windows 7 is running. I can right-click on the mouse and use "Open with ..." to select the proper Windows Explorer (running under Windows 7) to open the executable.

    I would like to be able to prioritize the two VMs (XP vs 7) so that clicking on a Windows file will open the right OS. Alternatively, Parallels should list BOTH the Win XP and Win 7 versions of Windows Explorer as options to "Open with..."

    Unless I'm missing something ...
     
  2. tacit_one

    tacit_one Kilo Poster

    Messages:
    434
    Hello MisterKenJ,

    Thank you for your feedback! But to be honest, I'm not completely understand - what keyboard problem are you referring to? Can you please elaborate a little bit on this: what happens for you, how do you workaround that, etc. What other forum threads are you referring to?

    Actually, both XP and 7 applications would be listed in the "Open With", the problem is that they will have similar names (say, "notepad.exe" and "notepad.exe") - so there is no easy way to differentiate between VMs currently... Unless i also don't really understand your problem. Can you provide a screenshot of what you see with "Open With"?

    Thank you,
    Max
     
  3. MisterKenJ

    MisterKenJ

    Messages:
    4
    Re the keyboard problem, see http://forum.parallels.com/showthread.php?p=396577#post396577. I can't reproduce the problem or make it occur. The keyboard is inactive, but the mouse is not. Seems to happen at random.

    Related factoid ... if I mouse to Devices ... and click on USB > Apple Bluetooh controller, both the mouse and keyboard are dead, and I cannot get back to Mac OS, and thus have to do a hard boot of the iMac.

    Re the use of both XP and 7, when I see only ONE application in Open With ... the same app is not listed twice.

    It would be also nice if the Open with ... dialog also showed the name of the VM to be used in addition to the app name. Screen shot attached, and both VMs are currently running.

    Thanks

    Ken
     

    Attached Files:

  4. I-che

    I-che

    Messages:
    492
    Ken, feature request regarding name of VM to be displayed in Open With dialog has been made, thank you.
     
  5. MisterKenJ

    MisterKenJ

    Messages:
    4
    Thanks .. any ideas about the keyboard problem?

    It's gotten worse. Restarting the VM and Windows 7 .. cannot get keyboard to work AT ALL.

    Yikes!

    Thanks

    Ken
     
  6. GlynD

    GlynD

    Messages:
    12
    I think you can reset file associations by
    1. removing the association on your Mac - use CMD-I to temporarily associate the file with another application
    (There is a nice free app http://www.rubicode.com/Software/Bundles.html#RCDefaultApp that lets you manage this from System Preferences instead of editing plist files*. It shows the path of the VM from the and has a 'disable' option)
    2. open only the version of Windows that you want as the default
    3. reassociate the file extension in Windows: this should reinstate the Mac link

    * if you're happy doing that though, it's fairly simple to change the name of the associated application to the preferred Parallels pvm file

    For simple self-contained applications like Notepad, why not just create a copy or shortcut for them with a descriptive name and associate that instead? (e.g. NotepadXP/Notepad7)
     
  7. I-che

    I-che

    Messages:
    492
    Hi Ken,
    what kind of keyboard are you using? Do you mean you loose the input totally? If it is an USB keyboard, you can try to unplug the keyboard and conntect it again, or try to reset keyboard settings in Parallels Desktop > Preferences.
     

Share This Page