Using Multiple Monitors and Built-In Screen in Full Screen mode

Discussion in 'Windows Guest OS Discussion' started by TravisG2, Aug 5, 2018.

  1. TravisG2

    TravisG2 Bit Poster

    Messages:
    3
    I am not sure if this is the right place for this thread, if not, can a moderator kindly move it?
    I am running PD13 for my MBP 2017. When I am in a Mac environment, I currently have two external monitors, and I use the built-in display for other stuff (i.e. keeping email opened). I've tested three external monitors with the lid close, and I can successfully run Windows on all three screens. However, when I try to use two external monitors and the built in display, the scaling is all off. I try to change the resolutions to match the monitors and the Retina display, but it does not work. I tried changing various settings in Parallels, but nothing seem to help. It pretty much like I want to click on something, but I have to aim either below or above what I want to clink in. Then when I try to change settings in Windows' Display Settings, nothing every matches up. For reference, the two external monitors at 1440, but the 2560x1440 resolution works just fine and allows to have enough screen real estate.

    I do not want to display multiple spaces as sometimes I may need to changes in case I need to use a Mac application. My end goal is to successfully run Windows on all three screens at once as if I was natively using a Windows machine. Is this possible?
     
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @TravisG2, please follow the steps mentioned below to fix the issue:
    1. Go to > System Preferences > Mission Control.
    2. Enable Displays have separate Spaces option.
    3.Log out from Mac user account and log in back.
    4. Enter Full Screen view mode with your virtual machine. To extend virtual machine to the external display go to View menu of the virtual machine > Use All Displays in Full Screen
    5. Open virtual machine configuration window > Hardware > Graphics.
    6. Set resolution setting to Best for external displays.
     
  3. TravisG2

    TravisG2 Bit Poster

    Messages:
    3
    I've tried this, and again, this produces the EXACT issue I've descrive above. When I got fall screen and have all displays enabled, trying to configure mutliple screens in Windows can be difficult. Also, when my laptop is on the right side, I have to move my mouse as if it was on the left side, even if the settings in "Display Settings" in Windows is correct.
     

Share This Page