Version 3116? MacWorld

Discussion in 'Parallels Desktop for Mac' started by Mac Pro 5GB, Jan 10, 2007.

  1. Mac Pro 5GB

    Mac Pro 5GB Bit Poster

    Maverick808 I do not have the auto resizing problem of the VM as you descibe above. Mine works fine. I am using 1320.
  2. Mac Pro 5GB

    Mac Pro 5GB Bit Poster

    Also if you look at "about Parallels Desktop" it now says release candidate instead of beta.
  3. drval


    This is version 3120?

    Also have you migrated/updated from a prior 3106 install? I'm wondering what issues you might have encountered when doing so. I'm on a MacBook Pro C2D 2GB RAM, not using Boot Camp.
    Last edited: Jan 10, 2007
  4. nycruza


    Do you have memory set at AUTO or MANUAL?
    If AUTO try manual and set for 1124

  5. STim

    STim Super Moderator

    I doubt it will help. In any case, be 400 MB the VM RAM or Total for all VMs, it shouldn't eat 1+Gig or 500 MB. Usually, one VM needs the amount of RAM assigned for this particular VM plus ~50 MB.


    Can you tell us what do you usually do inside your VM? What's the guest OS version? What is your Mac name and OS X version? Any specific operations? Do you use Coherence? Shared Folders? Anything unusual you might think leading to such memory leak?

    I would appreciate if you double your reply to mailbox, I can start officially investigating the problem in this case.

    Best regards,

    PS: Writing from XP SP2 running on Mac Book C2D inside Parallels Desktop build 3120 for about two days already. 384 MB assigned to the VM, 360 MB real memory is actual usage.
    Last edited: Jan 10, 2007
  6. drval



    As a member of the Development Team, could we get a quick statement about whether 3120 is (now) a Release Candidate, what fixes have been included and whether there have been any problems noted in updating from 3106?

    I'd certainly appreciate an answer to the last question as I'm waiting to see whether or not I should update now. I'm using a MacBook Pro C2D, 2GB RAM with XPSP2 as the only Guest and I'm not using Boot Camp.
  7. modular747


    Palm Hotsync fix?

    USB Hotsync for Palm Treo 700p still broken in 3120. Last worked reliably in 1970 and intermittently in 3036.
  8. rhind


    Responding to Tim Surgent:

    I have the same memory issue. I'm running 3106 on an MBP C2D 2.33GHz with 2Gb RAM. I have 768Mb assigned to the VM which is Windows XP SP2. It has 3 80Gb hard-disks, each with about 9Gb used (I'm not using BootCamp). I basically only run Borland C++Builder 6 and Visual Studio 2005 for windows development. Both these can start eating up quite a bit of RAM (150MB+ according to windows task manager) but the OS should still have plenty left even beyond this.

    But Parallels can quickly get to 1Gb RAM usage. I have the cache policy set to Mac OS X (not the default) which helps with the memory usage and helps OS X be a bit more responsive when the VM is running.

    I do use coherence - I also have the issue with coherence where the desktop starts to show through when I terminate an app being debugged. It looks as though coherence doesn't recognise the app has gone (because it wasn't exited gracefully) and so still things it should display that part of the windows screen. Could this be anything to do with it?

    I have tried with and without shared folders and still have the issue.

    I'm using shared networking.

    I had at one point upped the RAM for the VM to 1024MB but after a short while (roughly 1hr debugging in Windows), the whole MBP would become unresponsive. It would take make over 10minutes to get activity monitor running as I'd just get constant spinning beach ball from all OS X apps. When i finally got activ monitor running, everything was fairly idle, but as soon as I tried to do anything (activate app, move over dock, click spotlight etc) the spinning beach ball would return and it would be kernel task using most of the processor usage. Exiting Parallels fixed this problem. The other time it happened, I couldn't get enough response from the system to exit parallels so ended up killing power to the laptop.

    I've since dropped the VM memory back to 768Mb and haven't had this issue again but Parallels is still typically using over 1Gb or RAM after a short while.

    The other item people seem to notice problems with while Parallels is running is Rosetta (MS Office apps in particular). I've had issues with these too while Parallels is running. It got to the stage to day where entourage crashed and then no Rosetta app would launch until I rebooted. Then all were fine again. I haven't had this Rosetta issue without parallels running, but it has only happened once.


  9. betatester


    Another memory leak report under 3120 RC


    MacPro 3.0 ghz; 6 GB RAM; 1.4 GB allocated to Parallels.

    Parallels shows 10-50% CPU load

    One hour ago, real RAM was ~700 MB; now 877 MB and growing. Virtual RAM 2.7 GB

    Loaded two apps--Mail and Firefox; CPU load jumped, memory allocation did not.
    Quit apps--CPU load declined to 10%, memory continues to leak.
  10. Hugh Watkins

    Hugh Watkins


    have you tried even less memory?
    it seems to be a paradox that less is more efficient

    MS Office for the Mac is old and tired
    far better to use the freebie mac Mail for imap and POP mail
    (I archive my mail on the web)

    I abandoned Entourage within days of returning to the Mac

    I only run MS products native on WinXP on Parallels
    try reading Mactopia FAQ and the MS mac newsgroups to see what problems people have with these products

    MS Word for the Mac is usable
    if I need a new suite I will go for the Sun Java Star office on WinXP

    Hugh W
  11. betatester


    Per Tim's request, I am posting my update here.


    MacPro 3 GZ, 6 MB RAM, 908 MB allocated to Parallels, XP Pro SP2; two HDD's plus network mounted drive pointing to home directory on host. "Show live screen shot in Dock" enabled.

    Initially, real RAM usage increased rapidly to 768 MB with only Mail and Firefox running, then continued to increase past 800 MB.

    Then, following suspension of VM, dropped to 170 MB; now, after 1 hour, creeping back up again to 300 MB and climbing.

    CPU usage modest at 19%.

Share This Page