Virtual Machines List window not appearing

Discussion in 'Installation and Configuration' started by twynne, Apr 30, 2010.

  1. twynne

    twynne Kilo Poster

    Messages:
    154
    Recently migrated my Parallels installation across to a new Macbook Pro, and although the 'Virtual Machines List' window is enabled (ticked) in the Parallels menu, it doesn't appear anywhere visible on my machine. As such I've no way to properly add/remove virtual machines from the list.

    Can anyone suggest a 'trick' to get the window back?

    Thanks,

    Tom
     
  2. Scott_B

    Scott_B

    Messages:
    1
    The same thing has happened to me. The machine list is hidden off the top of the screen. If I switch back and forth between spaces I could see a glimpse of the window. I have tried setting extra spaces, changing resolution but am stuck as to how to get it back. I can open VMs by going to file > open but would like to have the list visible.

    Anyone know a shortcut for moving windows via the keyboard?

    Thanks, Scott
     
  3. Martin Wren-Hilton

    Martin Wren-Hilton

    Messages:
    1
    Me too. Can't see the Virtual Machine List after migrating to a new Mac.

    Martin
     
  4. twynne

    twynne Kilo Poster

    Messages:
    154
    Slightly off topic, but since migrating your VM's across, do you guys also find that the VM insists on opening in Coherence mode (even when resuming from suspend)? I've tried every setting to force it to open windowed, and it keeps reverting back. Very frustrating.
     
  5. twynne

    twynne Kilo Poster

    Messages:
    154
    Managed to briefly get this back after a bit of fiddling around. The thing that worked:

    - Ensure Parallels is closed.

    - Enable Spaces, and force Parallels to open on a different space than 1.

    - Launch Parallels

    Parallels should open onto the designated space, and in my case the Virtual Machines List was partially visible in the upper right corner of the screen. I simply dragged it back into view using the bottom of the window.

    Unfortunately after disabling Spaces, the next time I launch Parallels the window is again hidden. If I re-enable Spaces and jump between windows, I can briefly see the window flashing around the screen. Clearly this is a bug of some sort related to the change in display resolution with the upgrade of my Mac. I guess we'll just have to wait for Parallels to fix it.
     
  6. eric1234abcd

    eric1234abcd

    Messages:
    1
    Fix

    Hi,

    I just registered to say I found a workaround:

    Ironically when I wanted to report the problem I got a solution:

    When you right click the 'Parallels Desktop' Icon and click 'Report a Problem...' the virtual machine list comes back.

    Hope this is useful until a real fix comes.

    Gr,

    Eric
     
  7. arkbear

    arkbear

    Messages:
    7
    ...but be sure to *move* the list that appears...

    I'm having exactly the same problem, so kudos on finding that "report a problem" work-around!

    But - in order to get the machine list back, I noticed that you have to *move* the window and cancel the error reporting. If you don't do that, the list goes back into hiding.
     
  8. iduff

    iduff Product Expert

    Messages:
    231
    I've just sent a problem report, number 5811760, reporting this issue.
     
  9. Chun-KaiP

    Chun-KaiP

    Messages:
    1
    I think I have found out why this issue happened.

    It result from the automatic GPU switch for every new MacBook Pro 15/17 2010.
    Once you launch Paralles Desktop 5, the system will switch to descrete GPU. Then VM list will be out of screen.

    If you launch another program like Skype that activate discrete GPU instead of using Intel HD Graphic, VM list should be normal as before.
     
  10. Felixelgato

    Felixelgato

    Messages:
    3
    I´m not sure about the video switch is creating or solving the problem. I have been testing a cool tool called gfxCardStatus that allow to force the switch between the Intel and the NVIDIA and aditionally it shows what of those are in use. When I use it to make a switch, the Parallels Virtual Machine doesn´t appear... I hope parallels can help us quickly

    Note: I was following this issue in http://forum.parallels.com/showthread.php?p=412793#post412793
     
  11. jkwuc89

    jkwuc89 Bit Poster

    Messages:
    97
    Here is another workaround for this. Open /Users/jkwuc89/Library/Preferences/com.parallels.Parallels Desktop.plist inside the Property List editor. Select the entry named "VM List window.Geometry.Screen position" in the list and click on the Delete Item button in the button bar. Save the file and then, restart Parallels.
     
  12. DaleE

    DaleE

    Messages:
    20
    Okay where is the Property List Editor? In Get Info mine says open with Text Editor.
     
  13. jkwuc89

    jkwuc89 Bit Poster

    Messages:
    97
    It appears that the Property List editor is part of the Xcode development tools package. plist files are also in plain text XML files that can be changed using Text Editor. Make a backup before changing this file, regardless of the method you choose to do so.
     
  14. alexch

    alexch

    Messages:
    10
  15. iduff

    iduff Product Expert

    Messages:
    231
    The KB article fixed it for me. Thanks, alexx.
     
  16. NewNickName

    NewNickName Guest

    It has not solved it for me

    At least it did .... once ... and then the problem returned.

    Any news on a proper fix rather than a laborious work around?
     

Share This Page