Virtual Memory Low messages

Discussion in 'Parallels Desktop for Mac' started by Scott Willsey, Jun 18, 2006.

  1. Scott Willsey

    Scott Willsey

    Messages:
    174
    Greetings,

    Running XP SP2 in Parallels on a Core Duo mini with 2 gigs of ram and a 250 GB external FW drive as the boot drive.

    I keep getting messages about windows virtual memory being low whenever I boot into XP and fire up vs.net 2005. I didn't get these in the past, only with the GA version. Not even RC2 gave me this.

    The VM has 512 mb of ram allocated and Parallels has a max of 764 megs for all VM's.

    Anyone else seeing this issue?

    Thanks.
     
  2. ehamburg

    ehamburg Bit Poster

    Messages:
    46
    I'm getting the same message pretty regularly as well. I am usually running only one or two programs such as Access or Outlook.
     
  3. Marko

    Marko

    Messages:
    27
    Is the Virtual Memory warning comming from Windows XP???
    Have you Run Compressor on the VM HD?

    Sounds like just a WinXP warning saying the Allocated Paging File is too small and has been increased.

    After compressor I saw that my Allocated Memory Page File was reduced to 50 Meg.
    After 2 warning I looked and the Allocated Memory was chaged to slightly Higher.

    Have a look here:
    Right Click on My Computer > Properties > Advance > Performance Settings > Advanced > Virtual Memory
    you might want to up the min Page File size or set Page file to a Fixed Size to stop Fragmentation.
     
  4. chrisp

    chrisp

    Messages:
    29
    Yeah, same problem here, after running Compressor it would give me the message about the paging file. It seems pretty harmless so far and at some point the file should get big enough to stop the messages.
     
  5. LogicalVue

    LogicalVue

    Messages:
    10
    You might want to check your XP VM settings. I had the same problem; it turned out my VM was set to only 50MB. I switched it to "System Managed Size" and the problem has gone away.

    To change this go to the open System in the control panels and select the Advanced tab. Click the Settings button in the Performance section. Click the Advanced tab of the window that opens and then click the Change button in the Virtual Memory section. In the window that opens click the radio button next to System Managed Size and then click the Set button. Click OK to close the open windows. Eventually it will ask you to reboot. After it does so you should have a much larger VM file.

    -- Paul
     
  6. Scott Willsey

    Scott Willsey

    Messages:
    174
    Thanks, Paul. For some reason I was thinking the default was for Windows to set the size automatically.
     
  7. haralds

    haralds

    Messages:
    38
    Actually, it is probably best to start off with a reasonable, fixed size. For a 384MB memory allocation I set mine to start at 256MB and max at 756MB.

    This will avoid fragmenting the disk, and for most purposes, 256MB is enough.
     
  8. ajay

    ajay

    Messages:
    153
    Thanks Paul, your suggestion worked for me. It also allowed me to cut the memory allocation to WinXP back to 256Mb. This allows Windows to load/run faster on my setup.
     
  9. philnewts

    philnewts

    Messages:
    34
    Hi I have been having he same problem, I have tried changing my page file as suggested but I am getting an error message.

    error creating page file

    any ideas?
     
  10. jebworks

    jebworks Bit Poster

    Messages:
    62
    Pitiful overall performance......!

    I keep getting these low virtual memory messages in XP even after setting everything to ideal as per posts and the manual.
    The performance of the 1940 build is absolutely pitiful. It takes minutes not seconds to launch XP and to open any app even just a browser takes close to a minutes. I feel like I'm back running Virtual PC on my old Mac.....!

    At the same time my fan is running at top speed.

    Is this due to Windows Indexing running or does anyone have another idea.

    I'm about to give up after having paid for a full version. The original free trial seems to have worked best.

    MacBook 2 GHz Core Duo, RAM 2 GB 667 MHz DDR2 OS X 10.4.8
    Parallels Build 1940 Memory Allocation 512 Mb
     

Share This Page