VISTA not working after upgrade to Version 3.0

Discussion in 'Installation and Configuration of Parallels Desktop' started by ejparsons, Jun 24, 2007.

  1. ejparsons

    ejparsons Junior Member

    I have been using Parallels almost without any problems for the last year, upgrading when new updates become available. I have just bought the upgrade to version 3.0 and installed it and now Vista will not boot. I am getting the following VISTA message "a problem as been detected and Windows has been shut down to prevent damage to your computer prlfs.sys"? Has anyone else encountered this issue? Any help much appreciated.

    I understand that I cannot now roll back to version 2. So I am really hoping that I don't have to re-install!

    System Details:
    MacBook Pro 2.16 Ghz Intel Core Duo
    OSX: 10.4.10


  2. dkp

    dkp Forum Maven

    It's not true that you cannot go back to 2.x (build 3214 is Version 2.5). If you didn't follow the advice and backup your virtual machine then it is likely lost for for the purpose, but you can re-install 2.x and then reload Windows from scratch.

    I saw a post recently that described now to reuse your 3.0 VM in 2.5 but I can't find that now. I'll poke around a bit more and see if it shows up.
  3. Daekko

    Daekko Bit poster


    I had the same problem after I upgraded, here's how I solved it:

    1) Boot Vista into Safe Mode
    2) Open a Command Prompt (this is going to be tricky since the mouse won't work)
    3) Go to c:\windows\system32\drivers
    4) Remove (or move) the prlfs.sys file
    5) Reboot the VM normally and you should get back to the Vista Desktop
    6) Install the new version of Parallel Tools

    You should probably un-install the previous version of Parallel Tools before installing the new version, but that wasn't an option for me. It still worked though and Vista is functioning normally again. :)

    Hope This Helps
  4. w7ox

    w7ox Hunter

    Great first post, Daekko!

  5. jjimhoog

    jjimhoog Bit poster

    Daekko, great work.

    To open a Command Prompt without the mouse: press the apple/option key + ESC. That will open the start menu. Next type CMD and hit Enter.
  6. moose88

    moose88 Bit poster


    Here's the exact text you would put into the command prompt (for all you non-dos users)

    cd c:\windows\system32\drivers
    rm prlfs.sys
    shutdown -r 0
  7. ejparsons

    ejparsons Junior Member

    Great news. Daekko, thank you so much. all working now, though I had issues (as mentioned by other people) of how to use the mouse when it was not responding. Thank you so much!

  8. darkfader

    darkfader Bit poster

    I have 3.0.5160. I can remember it worked before but now I get a bluescreen of prlfs.sys when booting Vista in VMfW. I guess this also causes the bluescreen when starting from native bootcamp but it reboots too fast too actually see the message.
    I know I should be using Parallels, but it killed OS X when starting the VM. prlfs.sys should just do nothing when it does not find Parallels system.
    Perhaps there is some conflict when running it also from VMware fusion?
    Anyone know a way to create a hardware profile in Vista even they 'removed' support for it? I think that could solve a bunch of problems.
    Last edited: Oct 10, 2007
  9. louden

    louden Bit poster

    Is there a better solution to this issue yet? I've tried uninstalling the tools and deleting the prlfs.sys file, then reinstalling, but I always end back up at a bluescreen...
  10. benzion

    benzion Bit poster


    I appreciated moose88's addition to Daeko's post. However when I tried it, it didn't work. After an internet search I realized that he had used the unix command rm instead of the dos command del.

    It should be:

    cd c:\windows\system32\drivers
    del prlfs.sys

Share This Page