visual effects on Ubuntu 10.04?

Discussion in 'Linux Guest OS Discussion' started by schvenk, Mar 24, 2010.

  1. Bradrox

    Bradrox

    Messages:
    7
    Visual effects

    I have tried everything that Ive found on the ubuntu forums and my friend has ubuntu 10.04 and he doesnt have any problems. I have a Dell inspiron 1501 I have uninstalled and reinstalled my ati drivers and still no visual effects, Ive been at this since 10.04 came out. My compiz check says this Distribution: Ubuntu 10.04
    Desktop environment: GNOME
    Graphics chip: ATI Technologies Inc RS482 [Radeon Xpress 200M]
    Driver in use: radeon
    Rendering method: None

    Checking if it's possible to run Compiz on your system... [SKIP]

    Checking for hardware/setup problems... [SKIP]

    At least one check had to be skipped:
    Error: No rendering method in use (AIGLX, Xgl or Nvidia)

    Does this tell you anything? Please help if you can. I would appreciate it.
     
    Last edited: May 9, 2010
  2. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    @Bradox
    Sorry if it's an obvious question, but did you install Parallels Tools? (I think it's installed automatically)
    Is your ubuntu 64 or 32 bits?
     
  3. Bradrox

    Bradrox

    Messages:
    7
    Visual effects

    Well as far as I know I have everything installed that says Parallel. Is there a way to install it manually to make sure? I am fairly new to ubuntu and refuse to go back to windows so I am determined to fix this. I am running the 32 bit version of ubuntu 10.04 and my dell inspiron 1501 has a 64 bit dual core amd athelon processor. Does that help?
     
  4. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    @Bradrox
    I'm running Parallels 5.0.93.44 (for Mac) and Ubuntu 10.04 x64.

    After installed Ubuntu, did you update it? From command line:
    Code:
    sudo apt-get update
    sudo apt-get dist-upgrade
    
    You can install/reinstall Parallels Tools from Parallels main menu (when your virtual machine is running).
    In my case, there is a menu: Virtual Machine / Reinstall Parallels Tools.
    After install parallels tools, you need to reboot Ubuntu.

    Make sure you have enabled 3D acceleration for your virtual machine in Parallels.

    After installing parallels tools and reboot Ubuntu, I did the follow steps:

    1) Edited the GL.conf file
    Code:
    sudo gedit /etc/ld.so.conf.d/GL.conf
    2) Change the content of GL.conf file to: /usr/lib
    (I have deleted everything else)

    3) Run the follow command:
    Code:
    sudo ldconfig
    4) Activate the visual effects from the Appearance app: System / Preferences / Appearance

    I think that's all I did.


     
  5. Bradrox

    Bradrox

    Messages:
    7
    visual effects

    I did what you said with the update and upgrade. then I think I edited that scrpt right, I just deleted the end of it that said nvidia and saved it. Im not sure what you mean by virtual machine though. when I put in idconfig it doesnt do anything, and when I try to install or remove 3d acceleration it says there is a problem? Thank you for helping me. Do you think I have installed conflicting components or something?
     
  6. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    @Bradrox
    Ubuntu was not supposed to be so hard to install. I used to run Ubuntu on a Dell desktop a few years ago without any problem. I'm new to Parallels and don't have much experience running Ubuntu on it. I hope I could be more helpful.

    Also, take a look at this forum, and see if it can help you:
    http://forum.parallels.com/showthread.php?t=101376

    I don't know if you have installed conflicting components, one thing I saw you have is the ati/radeon driver. I don't think you need to install this driver is you are running Ubuntu in a virtual machine (Parallels).

    My computer also has an ati/radeon, but the driver instaled on Ubuntu is a generic one.

    You can check the driver in use by running the follow in the terminal:
    Code:
    lspci | grep VGA
    
    Mine is: "01:00.0 VGA compatible controller: Device 1ab8:4005"
     
  7. Holgi

    Holgi

    Messages:
    1
    3D activated?

    Might be that 3D Acceleration in the graphic configuration of the parallels-instanz isn't on?
     
  8. Bradrox

    Bradrox

    Messages:
    7
    Visual effects

    Well I ran that and got this. 01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M] And when I cick on my 3d acceleration it says xlinfo not found. And I checked out the link you gave me but I dont understand what the virtual machine is.
     
  9. GilbertoO

    GilbertoO Bit Poster

    Messages:
    15
    Perhaps you are not running Ubuntu on a Virtual Machine (http://www.parallels.com/products/desktop/)

    How did you install your Ubuntu? (entire HD? dual boot with Windows? using Parallels?).

    If you have Ubuntu installed direct on a HD partition, you will get more help from others forums. I can provide more information.

    Thanks.

     
  10. AjayK

    AjayK

    Messages:
    1
    My desktop effects is completely dead. How do enable it back?? :(
     
  11. JerrelL

    JerrelL

    Messages:
    1
    I cant get parallels tool!

    I was following all the steps on this thread and got stuck on the part regarding parallels tool.
    I'm running Ubuntu10.04 on Oracle VM virtualbox on windows 7,is it possible for me to get parallels tool?
    or is there another way for me to enable visual effects on Ubuntu10.04?
    thanks
     
  12. joevt

    joevt Kilo Poster

    Messages:
    1,202
    Parallels Tools is only for Parallels virtual machines.
     

Share This Page