VM cannot see other VMs in private sandbox domain

Discussion in 'Windows Guest OS Discussion' started by RaphaelF1, Dec 22, 2018.

  1. RaphaelF1

    RaphaelF1 Bit Poster

    Messages:
    15
    I have seen several posts here with the same issue. I've tried the suggestions I saw, especially when they were from someone from Parallels. None worked. I need someone from Parallels to hold my hand here and systematically apply specific steps to troubleshoot and resolve. I will open a support ticket with Parallels support if I cannot get the correct answer here. But for now, let's try the open forum.
    Details:
    • Host: Mac (27-inch, Late 2012) - 3.4 GHz Intel Core i7 - 32 GB 1600 MHz DDR3
    • VMs: A total of 5 VMs. 4 of the VMs are running MS Windows Server 2012 R2. These 4 VMs are able to communicate with each other and the Internet. I have no problems with them. Out of these 4, first is my domain controller. Second is my file server. Second has Starwinds vSAN installed to simulate a SAN, which are used by third and fourth via MS iSCSI Initiator. Third and fourth are a windows server cluster that has an instance of MS SQL Server 2016 Failover Cluster Instance (FCI). Again, these four machines are working with no issues, including the cluster, which fails over automatically with no issues. Again, all four see each other, including the domain server, and can login to the domain with no problems. Fifth is my application server. Fifth has Windows Server 2016 installed on it, and also an LMS (Learn Management System) installed on it. When I first installed everything on fifth, everything worked perfectly. Fifth could see all other servers, so much so that I was able to join it to the domain, install the application (which uses all 4 servers). Now, for two days, without me changing any configuration, fifth cannot see the other 4 VMs. It can't even ping them and the two network adapters I have installed on it read "Public Network", instead of "virtuarte.edu", which is what I do see on the other 4 VMs
    • Now the important part, network configuration details: All 5 computers are configured exactly the same as far as I can tell. All 5 have each 2 network adapters. The first adapter, configured as "External", for internet access, uses the Parallels defaults (ObtainIP address automatically and Obtain DNS server address automatically). The second adapter, for internal use in my domain, configured as "Internal", for access internally to my domain and the other four server, uses the Parallels network option of Host Only Network. I have configured all 5 external adapters to have static IP addresses,10.0.0.1 (domain server), 10.0.0.2 (file server), 10.0.0.3 (node 1 of the cluster), 10.0.0.4 (node 2 of the cluster), 10.0.0.5 (application server). All 5 are configured with subnet mask 255.255.255.0, and 10.0.0.1 for DNS server and gateway.
    Long story short: all 4 first computers see each other and the fifth, with the same exact configuration cannot communicate with any of the other 4 anymore (it used to without an issue).

    Please help. Thank in advance, Raphael.
     
  2. RaphaelF1

    RaphaelF1 Bit Poster

    Messages:
    15
    Never mind. I am not sure if I found the problem or if the steps I took are a work around that fixed the problem for some mysterious reason. Here's what I did that immediately fixed the problem, without even a need for a reboot:
    1. Right-clicked the network icon on the bar.
    2. Chose "Open network and sharing center."
    3. Clicked on "Change advanced sharing settings."
    4. On that page, you have (or at least my server/VM had) 4 drop downs: Private, Guest or Public, Domain (current profile), All networks.
    5. Just tinkering around and by chance, I expanded the Private option, and then I switched "Network discovery" to OFF for the private "network profile."
    6. Boom! Both my virtual NICs immediately switched to the domain "virtuarte.edu", which before were reading "Public network".
    7. I was immediately able to ping all other 4 machines and everything started working perfectly.
    Now, why the heck would this setting interfere with the network this way??
    Full disclosure: One more setting that I discovered after the fix was in place and the machines were already communicating successfully: I had made the mistake of reusing the same ip address for two "objects" in my AD: The WSFC listener had the 10.0.0.5 IP, AND the app server was also using the same IP. THAT would make much more sense as being the culprit. But again, going through steps 1 through 5 had already resolved the issue.

    Anyways, I hope this thread helps someone out there. Best, Raphael.
     

Share This Page