VM Host Screen Resolution

Discussion in 'Parallels Workstation for Windows and Linux' started by Ray, Mar 29, 2006.

  1. Ray

    Ray

    Messages:
    33
    Having set 1024x780 on my host computer I am unable to set the resolution on my Suse10 guest to greater than 800x600 - which leaves bits and pieces off the screen - especially OK buttons. I have changed details in the Graphics and Monitor section but these do not seem to filter down to the actual desktop which re,ains as 800x600. Any suggestions for a fix for this????

    Thanks

    Ray
     
  2. Nadine McSim

    Nadine McSim

    Messages:
    17
    In SUSE 10 guest OS screen resolution is changed in a way different from other Linux guest OSes. To change guest OS screen resolution in SUSE 10 to 1024x768:
    1. In the config file for grub menu.lst boot loader change the VGA setting (or create a new entry with a new vga parameter):

    kernel /boot/vmlinuz root=/dev/hda2 vga=0x0317 selinux=0 resume=/dev/hda1 splash=silent showopts

    2. Start xmode utility with resolution and frequency parameters, to receive parameters for the record in xorg.conf configuration file:

    xmode -x 1024 -y 768 -r 80

    For instance, you may receive:

    Modeline "1024x768" 86.18 1024 1088 1200 1376 768 769 772 803

    3. Add the record you received from xmode into xorg.conf file. The record should be first in the "Modes" section. For the instance from the previous list item the record will be:

    Modeline "1024x768" 86.18 1024 1088 1200 1376 768 769 772 803

    4. Restart the guest OS.
     
  3. Ray

    Ray

    Messages:
    33
    Nadine,

    Many thanks for your very clear instructions. Unfortunately it didn't help me, I finished up with even less of the desktop showing, so I reverted back to my original configuration.

    Could it be that the KDE Control Centre - Peripherals - Display which shows 800 x 600 at 75Hz is wrong?.

    The monitor in Xorg.conf shows Modelname as 1024x768@60Hz and the first line of the Modes section also shows a 1024x768 entry. So perhaps it is set correctly anyway although I am not sure why some of the OK prompts etc are not or only partly visible.

    Thanks again

    Ray
     
  4. Nadine McSim

    Nadine McSim

    Messages:
    17
    Do you change the 'vga' parameter for your boot entry?
     
  5. Ray

    Ray

    Messages:
    33
    Nadine,

    Yes I did. But reverted it back to it's original setting when things turned to custard.

    Ray
     
  6. tgrogan

    tgrogan

    Messages:
    255
    Ray,

    First off, there should be a resolution setting utility on the task bar that works quite well, or else use Yast and don't go mucking about in the X files - GRUB since that only has effect at boot.

    Do the math. :) :) If you're at 1024x768, have a task bar/start menu on your host, and have a window bar at the top of Parallels - you are going to barely be able to get a 800x600 window on the screen vertically. Realistically, 800x600 is all you an use on a host only running 1024x768 that way.

    Did you try using full-screen mode? That will give you 1024x768 if you set it in the SuSE guest.
     
  7. constant

    constant

    Messages:
    1,010
    .
    Ray,

    Have you considered running vise versa.

    I know for a fact that SuSE 10 as host and Windblows as the guest works perfectly. All the resolutions you could possibly want.
    .
     
  8. Ray

    Ray

    Messages:
    33
    Thanks for those replies, I had already worked out that to get the guest screens correct the best I could hope for was 800x600. My solution is probably going to be go for 1024x768 and work in full screen mode.

    As for using Linux as a host, no thanks. I have Vmware which I used as a while on a Linux host but I can't realistically use Linux as my main desktop. It was the way I had intended to go with Windows as a guest but it never worked out for me.

    Ray
     
  9. constant

    constant

    Messages:
    1,010
    .
    Firstly, forget VMware. It has poor host OS support.

    So all you need to do is install SuSE 10, which you can realistically use as your main desktop, then install Parallels which only takes 20 minutes. After this, not only will you have a much better solution, you can also install Windwoes to run your legacy programs. We have done extensive testing at our Linux User Group, and have found that ALL programs tested run perfectly in a Windblows VM this way.

    You know it makes sense.
    .
     
  10. tgrogan

    tgrogan

    Messages:
    255
    He's right, just do it. Sometimes there is a learning curve, but running Linux under windoze makes absolutely no sense. I develope M$ software for a living, but with all of the combinations of offices and windoze, plus any other side issues, there is no way that a C:\ drive can handle all of the b$ thrown at a PC by M$. So I encapsulate windoze under a reliable OS. With Parallels you don't ever have any compatibility problems with their junk software.
     
  11. dglock2

    dglock2

    Messages:
    107
    Running linux inside windows is backwards!

    Why would you want to run a stable great system like linux inside a buggy, unstable os like windows?

    The whole point of vm is to be able to use some windows programs that have no conterpart in linux,although that is becoming less of a problem every day with the progress of linux!

    If i could get my scrambled desktop icons problem fixed the only time i would see windows would be inside linux!

    don
     

Share This Page