What's New/What's Fixed in Beta3 (comments)

Discussion in 'Parallels Desktop for Mac' started by STim, Apr 12, 2006.

  1. simon

    simon Member

    MBP success.

    Win XP boot time about 7 seconds to a usable desktop. Great !
    The trick here is not to worry too much about the first 2 or 3 boots. I suspect Parallels is doing something to the images, because after taking 30 second on the first couple of boots I'm now down to 7 consistently.

    DHCP still doesn't work in bridged mode for Linux variants (not a big deal for me though)

    Wake from sleep works fine.

    Mouse still seems a little "jerky". I'll try reinstalling the VM tools and see if that makes a difference.
    This is an awesome product, I already pre-ordered so I'm doing my part and showing confidence.

    For those that haven't placed an order, get it while it's hot guys $10 off !
  2. quux

    quux Bit poster

    For those of you still having a jerky mouse with beta 3... if you changed the hardware acceleration setting in display properties while using beta 1 or 2, try setting the acceleration back to full. After restoring full acceleration my mouse is as smooth as ice. :)
  3. PCMacGuy

    PCMacGuy Junior Member

    I'm experiencing the same thing on my system. Enabled the sound the played a video clip and it went for about 5 seconds then hung. Rebooted and it hung :( not long after the desktop came up. It did play the Windows startup sound all the way through.

    Using iMac 20" 2.0GH 1.5GB RAM VM: Win 2k all patches, Zonealarm installed and McAfee virus scan installed.

  4. jelockwood

    jelockwood Bit poster

    Keyboard issues still present in beta3

    The keyboard issues I reported in thread http://forum.parallels.com/thread408.html are still present in beta3 (on a Mac mini running XP Pro with an Apple keyboard).

    Key repeat does now work however (F8 at boot time and the @ and " keys after booting are still messed up).

    I can also confirm the the full stop (decimal point) on the numeric keypad does not work (I had not previously tested this).
  5. sedek

    sedek Bit poster


    I am getting a little bit tired of the fact that my WiFi still doesn't work. I have chosen en1 for Network bridging and I am still offline. Could Parallel please publish a quick guide how to make it work? Do the TCP/IP settings have to be empty? Please respoond, otherwise I shall stop testing this software.
  6. mike3k

    mike3k Member

    en1 just works for me on my MacBook Pro. In Windows XP it just looks like a normal LAN connection.
  7. sedek

    sedek Bit poster

    Doesn't work here (Intel iMac).
  8. peter_b

    peter_b Bit poster

    On my MBP I need to statically assign an IP address within the client OS in order to get the network up and running. That was under Beta's 1 & 2. I haven't yet tested it with 3, but thought I'd offer it up in case it helps in your situation.
  9. dzins

    dzins Member

    For me en0 causes a kernel panic every time I start Windows, en1 (the wireless adapter) works perfectly every time.
  10. tj4shee

    tj4shee Member

    Long Boot time ? Auto mounting Network 'drives' ?

    My boot up is extremely slow also.... and I think the culprit is networking....

    I start my machine and the Windows XP window comes up.... loads quickly.....
    My windows desktop comes up and the windows startup sound comes across....

    but the icons and taskbar are non-existant for 2+ minutes.....

    I 'disconnected' the shared drive and TaDa.... not more than seconds after my desktop shows, everything else shows too.....

    Part of my problem is that somehow my SMB networking got REALLY messed up.... and I can't seem to figure out what is wrong.....

    Anyway, if you have any network drives that auto mount at boot up, you may disconnecting them and see if your boot up goes quicker.

    Does anyone have the auto mount network drives and NOT having boot time issues ? Just wondering if my boot time issue was caused strictly by my SMB problems on my host.....

    So, bottom line, at least my long boot times were NOT caused by Parallels.
  11. dblanch369

    dblanch369 Bit poster

    Keyboard issues in Beta 3

    I didn't see where to email the bug reports using the tool in parallels, so I'll just post it here...

    Problem report - Start

    Please send this file to Parallels Software International Inc.

    --------------- Users bug description --------------

    On the iMac keyboard, the numpad keys '=' and '.' do not function in any Windows program (using Windows 2000 sp4 under Parallels 2.1, Beta 3). The keys function normally in OSX itself.

    ------------ End of users bug description ----------
  12. skyking

    skyking Bit poster


    Once I installed Beta3 and went to En1 (which gave me an airport selection) my WIFI was operating normally. (IMac 20, 512 ram, Win XP/service pack 2
  13. sbatson

    sbatson Bit poster

    Problems I've seen with Beta 3

    - The system will try to mount a floppy when I specify the device name such as
    I see the light go on, but I can't access the files or boot from the device even though Mac OS sees it.

    - Sound is very jerky

    - With Beta 2 I was able to access and boot from CDs. Beta 3 is not seeing the CDs even though Mac OS does. This is preventing me from loading software. I've tried removing and adding the CD with no luck.
  14. eudyptes

    eudyptes Junior Member

    I have a MBP with an external (Apple) USB keyboard. The number pad behaves like the num lock is set to the cursor control mode even though this keyboard has no num lock (the number pad is aways in numeric mode).
  15. peter_b

    peter_b Bit poster

    Update: after installing Beta3, I set my client back to DHCP to see if it's working now. It is not. Setting the IP back to static got it working again. (this is while using WiFi on en1... no real way to test ethernet at the moment)
  16. bpanders

    bpanders Bit poster

    Beta3 + MBP

    I had some problems with wifi in SUSE 10, and had to switch to a wired ethernet and it worked fine. wifi in win2k and XP (under Beta2 - no longer using XP) seems to work fine.
  17. spooki666

    spooki666 Bit poster

    Numeric keypad issues

    Same here. This is with a Apple USB Azerty (Belgian) keyboard on a 17" iMac.
  18. jkh

    jkh Bit poster

    Actually, I still see the machine reset on sleep with Beta3, so I think that one's still unstomped. :(
  19. Daktari

    Daktari Bit poster


    I have a MacbookPro with 2GB Ram and Running Parallels beta 3 with Windows Xp SP2 as the guest os. Networking using ethernet works perfectly but I have never been able to get airport to work, ( I know to choose eth1) both at home where I have my own wireless network and at school [how does the bridged networking take care of networks where one is redirected to a login page that is required for network access?]

    Is there something I am doing wrong? If i want to completely uninstall Paralles and reinstall beta 3 what files do i have to get rid of? This is just in case the problem is the upgrade to beta 3 not with beta 3 it self.

    All help will be appreciated.
  20. dzins

    dzins Member


    I have MBP 2.16 Ghz with 1GB RAM, 100GB 7200 RPM disk guest OS is Windows XP Pro SP2. In beta 3, if I try to start the VM connected to en0 (ethernet port) I get a kernel panic a few seconds after the windows (ctrl-alt-del) screen comes up. en1 works perfectly for me and I can see the Mac through smb.

    If I install beta 2 (I just run the installer and it overwrites beta 3 and this seems to work fine) then en0 works, but I cannot see the Mac through smb (although I can ping the ip addr). en1 still works perfectly.

    I am wondering what could be different between your and my setup that would make en0 work for you and not me and en1 work for me and not you?

    Do you bind to a Windows domain?

    I also use a USB mouse.

Share This Page