Why ist Citrix Receiver so slow at Parallels Windows?

Discussion in 'Windows Virtual Machine' started by JorgW3, Feb 6, 2020.

  1. MarcusH8

    MarcusH8 Bit poster

    Have you heard anything about your support case?
  2. JamesBeaumont

    JamesBeaumont Junior Member

    Disabling 3d acceleration makes Citrix Workspace usable for me too, so this is great and thank you Roman57, but latency is not great. I'm assuming this is due to no 3d acceleration. So I'd also be very interested if Parallels has responded and whether there's a fix likely. For reference Citrix for Mac has much better latency for me, but I much prefer to run under parallels for 2 reasons: 1) I can connect a Windows keyboard direct to the VM which gives me all the right shortcuts on my Citrix session and 2) I use 3 monitors and parallels allows me to switch spaces (between Mac and Windows/Parallels) for each monitor independently whereas Citrix for Mac switches all 3 monitors which I find much less flexible.
  3. WilliamG17

    WilliamG17 Bit poster

    Best Answer
    Have run into this in the past a number of times. Best way to fix is to disable Hardware Acceleration in the Citrix Workspace App:


    From the article - set this in the Registry:

    Registry Path : HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\ICA Client\Graphics Engine
    Name: HWacceleration
    Type: REG_DWORD
    Data: 0
  4. RomanS7

    RomanS7 Bit poster

    If anyone, that affected by this issue, write to the support - they will increase the severity of the case and (I believe) the issue will be resolved much sooner.
  5. JamesBeaumont

    JamesBeaumont Junior Member

    Wondering if anyone has any updates on this issue? I still get the problem on both Intel and Apple Silicon Macs - have to disable 3d acceleration to make my Citrix session usable, but that introduces an annoying latency. I have raised with Parallels support twice, but nothing helpful back yet - have just raised again with them.
  6. JamesBeaumont

    JamesBeaumont Junior Member

    Parallels support got back to me with "we have been approached by several customers with this issue and disabling 3D acceleration is the only way to improve the performance of a Citrix application." Disappointing, and I'll just have to live with it.
  7. SalmanA4

    SalmanA4 Bit poster

    Same issue here despite the solutions on this thread. They keep telling me to reset my network settings and put it into bridged mode which hasn't helped.

    MICHAELW65 Bit poster

    FIX: I'm running MacOs Monterey, Parallels with Windows 11. Citrix workspace
    Prior to fix Citrix environment had lots of latency issues. Really unusable.

    1. Within Windows 11, Download DirectX SDK, and install
    2. Run DirectX Control Panel
    3. Choose Direct3D 10x/11
    4. Under Scope: Edit List ...
    5. Add C:\Program Files (x86)\Citrix\ICA Client\Receiver\Receiver.exe
    6. Choose Direct3D 9
    7. Choose Software Only
    8. Hit OK and reboot.
    9. Now my Citrix is running well under the Windows 11 Parallels environment.

    I hope that helps!!

    Phil P and Salman2 like this.
  9. Nazeemabanu@P

    Nazeemabanu@P Moderator

    We really appreciate your contribution. Thanks.
  10. Salman2

    Salman2 Bit poster

    This is the fix we've all been waiting for. You're a hero. Accuro EMR on Citrix and Dragon Medical One working just as well as booting into BootCamp now with Parallels. You should get paid for this...
  11. Phil P

    Phil P Bit poster

    This should work better than the originally discussed method that disables 3d rendering for the VM entirely. Instead, this method would only disable 3D rendering for the Citrix app.

    However, DirectX SDK is deprecated in Windows 11. Here's a modern way:
    1. (Unsure if required) Download and install Windows SDK https://developer.microsoft.com/en-us/windows/downloads/windows-sdk/
    2. Within Windows 11, download Graphics Tools
      • System Settings > Apps > Add an optional feature (View features) > Graphics Tools
    3. Start > Run > dxcpl.exe
    4. Scope > "Edit List..." and add:
      • "C:\program files (x86)\citrix\ica client\receiver\" (Yes, may as well add the whole directory. This requires the "\" at the end)
      • "C:\program files (x86)\citrix\ica client\"
    5. Set Feature level limit: 11_1 (Parallels 18 does not support DirectX 12)
    6. Check "Force WARP" (This forces software rendering)

    I haven't had much luck either way, but I figured as long as I was trying it out, I would share the steps I took.
  12. Salman2

    Salman2 Bit poster


    Unfortunately this miracle fix doesn't work on windows 11. I made the mistake of upgrading, now everything is broken again. I'm going to have to find a way to go back to windows 10 tonight.

    I tried the fix by Phil above, also no luck.
  13. MelissaM1

    MelissaM1 Bit poster

    Has anybody figured out a recent solution to this? My Citrix Workspace is totally unusable on my M1 Macbook Air running Ventura 13.2 and Parallels 18.1.1. I tried the fix above, but no luck.......I can't believe nobody else needs to use Citrix to access corporate resources.
  14. SebastianJ2

    SebastianJ2 Bit poster

    We are facing the same issue. I do not know if it helps someone but for me it helps to use an older Version of Citrix Receiver. With Version 4.6 it works fine for me. How ever i do not know if this version still can be downloaded from the officially Citrix site.
  15. MichaelS195

    MichaelS195 Bit poster

    Hi, just bumping this post - I am using Mac OS 14.1 (Sonoma), Windows 11 Pro (2023-10 update), and Citrix for Windows 11 version (2309). Citrix is unusable. Thank you!
  16. AlessandroL8

    AlessandroL8 Bit poster

    Same issue here with macOS 14.3.1, Windows 11 and Citrix Receiver 23.11. Scrolling in a Citrix web browser is unusable. The funny thing? The same configuration works well (performance wise) with UTM.
  17. GuyA1

    GuyA1 Bit poster

    I can definitely confirm that this solution works seamlessly on Parallels with Windows 11 on MacBook Pro M1.
    Many thanks to WilliamG17 for providing such an effective fix!
    Additionally, if the registry path doesn't exist, simply create it.

Share This Page