Why won't Fedora display graphical desktop?

Discussion in 'Parallels Desktop for Mac' started by ayrton, Jan 16, 2007.

  1. ayrton

    ayrton Bit poster

    I installed Fedora Core 6, and used the graphical installation. After it finished, I was prompted with the text-based login. I tried running startx, but it says that the server is already running. What's the dealio?
  2. palter

    palter Hunter

    It's a bug in Fedora Core 6. Login as root and run the command gdm-stop and you'll get the graphical login. Run yum to update your VM as they've already distributed a fix for this bug.
  3. ayrton

    ayrton Bit poster

    Thank you! That was fast.
  4. astewart

    astewart Bit poster

    I know abit of Unix, I'm unable to run the command.
    I also get this error when I do sudo -s to login as the root, "Temp user is not in the sudoers file."

    Just after installing Fedora 6, it booted into the Graphical Desktop. After rebooting it now only boots into the the Terminal.

    What should I do from here?
  5. rhind

    rhind Member

    You are logged on as 'Temp' then. The post above says you need to log on as root to run this command. 'Temp' doesn't have privileges to do 'sudo' (cat /etc/sudoers will list which users do).


  6. L-Key

    L-Key Junior Member

    Please stop calling something a 'bug' because it doesnot work for you. ayrton, if you used the image posted here for Fedora 6, the /etc/inittab is set to level 3 which tells the system to boot into command line mode. you have 2 options:

    1. edit the file, look for the "id:3:initdefault: " line (without the quotes) change the 3 to a 5 and you will get the GUI everytime.

    2. start the VM the way you have been. once its booted , press ctrl+alt+f7 to f12 to pull up a GUI. you can toogle from GUI to CLI by pressing ctrl+alt+ f1 to f6 for CLI and f7 to f12 for GUI. or form the GUI just right click to bring up a terminal, Just keep working at it and you will feel comfortable in no time


Share This Page