Win 7 guest display resolution changed to 2560x1600 after Thunderbolt display use

Discussion in 'Windows Guest OS Discussion' started by costabas, Oct 8, 2015.

  1. costabas

    costabas Bit Poster

    Messages:
    38
    I have a MBP 15" which I use at work with a Thunderbolt display (as main monitor) bought sometimes in 2012 (it's not a retina display). At home I simply use the laptop without the monitor..
    Before I upgraded to the latest version of Parallels as of yesterday (Oct 7), i.e. 11.0.2 (31348), when I used the laptop without the monitor, the resolution on my Win 7 64 bit guest was set to 1680x1050 which was the expected behavior. After the upgrade, parallels switches the resolution to 2560x1600 in windows 7, again, when I use just the laptop, after having used the Thunderbolt display (turned my laptop off, went home, open the laptop again). I run Yosemite. On the OSX side, under Display settings I am using the option between Default and More Space. Under the VM options, the Graphics settings for Retina display is set to Scaled.
    How can I make parallels to have the same behaviour as it had in the previous release such that it uses the proper resolution for the main display?

    Thank you!
     
  2. AnthonyB2

    AnthonyB2 Bit Poster

    Messages:
    23
    I'm noticing this too, my setup:
    - Macbook Pro Retina 15" (native res 2880x1800)
    - BenQ GW2765 external monitor (native res 2560x1440)

    Running Parallels Desktop on the laptop screen works fine. It Parallels graphics options defaults to 'Best for Retina' and things look as they should

    Running Parallels Desktop on the BenQ results in the Parallels scaling the Windows resolution to 5120x2880 when it's set on the same 'Best for Retina' graphic option. Text, in particular looks bad. I have to manually override it to 'Scaled' resolution mode.

    On the previous version of Parallels Desktop, when I launched the VM it would set the correct resolution and mode according to the monitor I was launching it on.
     
    costabas likes this.

Share This Page