Win on VM does not exit cmd line programs after execution

Discussion in 'Windows Guest OS Discussion' started by StefanM8, Apr 2, 2019.

  1. StefanM8

    StefanM8

    Messages:
    1
    Hi All,

    I am new to this and I have one issue with Parallels, I hope you have an idea.
    For work I run a program that acts as an interface to call cmd-line programs. These are supposed to run in the background and exit after the calculation is completed. On a normal PC this works absolutely fine, the program exits. But on every VM on my Mac I tried (Win 7, 8, 10; 32 & 64 bit) the cmd-line program does not exit after the calculation. This causes the interface program to wait for eternity for the results and makes it absolutely unusable on a Parallels VM.

    The interface program is not malfunctioning, as doing it manually in the cmd-line also shows the same result: the program does not exit on a VM. But doing the same things manually on a regular PC works fine. I tried several settings for compatibility and admin-priviliges, but nothing works.

    I am glad for any ideas you might have.
    I am using a MacBook Pro 2015 with macOS 10.14 and Parallels Desktop 14
     

Share This Page