Windows 10 1607 scaling not working with v12

Discussion in 'Windows Guest OS Discussion' started by JasperH, Aug 20, 2016.

  1. JasperH

    JasperH Bit Poster

    Messages:
    1
    Everything was fine with v11. I was running Windows 10 Anniversary Edition smoothly.

    Then I upgraded to v12 and the desk looks like Doublo (you know the big LEGO for toddlers).

    Configuration/Hardware/Graphics is set to Best for Retina on 15" rMBP.

    Configuration/Options/Scale To Fit Screen to Auto.

    In Windows it says "A Custom scale factor is set. Turn off custom scaling and sign out". I did so but after signing in again scaling is still locked.

    What to do?!
     
    BrianT2 likes this.
  2. BrianT2

    BrianT2 Bit Poster

    Messages:
    7
    yup same problem here, now I know I need glasses but my eyesight isn't that bad!
     
  3. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    Just as a starting point what have you done to troubleshoot? Have you reinstalled parallels tools?
     
  4. BrianT2

    BrianT2 Bit Poster

    Messages:
    7
    Yup I've re-installed parallels tools and no change, screen resolution in Win10 is 2880 x 1800 (recommended) it can't go any higher. Where you would normally set the scale to something like 125% it's currently at 300% and grayed out so there is no way to reduce it back down. As the OP said if you follow the instructions to turn off custom scaling and sign out, when you sign back in again scaling is still locked.
    edit..... I've just found this article and it has solved my problem albeit the font on some text isn't as clear as it was https://www.pdf-archive.com/2016/08/25/resolve-windows-based-programs-issues/
     
  5. BrianT2

    BrianT2 Bit Poster

    Messages:
    7
    Just to add to this although the pdf provides a solution the screen resolution is not at the same retina level as before P12. text on icons is fuzzy.
     
  6. NickB3

    NickB3 Bit Poster

    Messages:
    2
    I'm having exactly the same problem. I just upgraded to 12.0.2 hoping they would have fixed the problem, but alas, I'm still in "Duplo" mode!

    Do the developers respond to posts in this forum? It would be good to get an indication they've at least acknowledged the issue.
     
  7. BrianT2

    BrianT2 Bit Poster

    Messages:
    7
    In the config panel in Parallels under graphics change the resolution to "Best for External displays" you will then have control of the scaling again. I know it's not an external display but it works
     
    GavaskarN and NickB3 like this.
  8. NickB3

    NickB3 Bit Poster

    Messages:
    2
    Brilliant! Thanks Brian. I'd tried just about everything EXCEPT that. :)
     
  9. BrianT2

    BrianT2 Bit Poster

    Messages:
    7
    Glad it helped, it's still not as sharp as having it on "Retina Display" but until Parallels recognize this I don't suppose it's going to change
     
  10. jsblau

    jsblau Bit Poster

    Messages:
    9
    I had the same problem and switched resolution to Best for External displays, which helped. I filed a ticket with support, and they replied saying that the development team knows about this bug and is working on it, but has no ETA for the fix. They recommended checking for Parallels updates regularly.
     
  11. winfashion

    winfashion Bit Poster

    Messages:
    1
    This still hasn't been fixed.....
     
  12. Guna@Parallels

    Guna@Parallels Parallels Support

    Messages:
    433
    Hi @winfashion
    Please follow the steps outlined in this article & keep us posted.
     
  13. jsblau

    jsblau Bit Poster

    Messages:
    9
    Guna - the solution in the article suggests using Scaled. That doesn't fix the problem: the resolution is terrible using Scaled with a Retina display. I suggest using Best for External Displays, where you can adjust the scaling and the resolution is acceptable. But neither solution is as good as using Parallels Desktop 11 with the Retina setting. The real question: when will this be fixed??
     
  14. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    if you set to scaled you can set the resolution and DPI to whatever you want to use in windows. It can be set to the same resolution as the old retina setting in PD11

    so go to windows and right click your desktop and click screen resolution. Then you can set to high resolution and Whatever DPI you want.
     
  15. jsblau

    jsblau Bit Poster

    Messages:
    9
    Dustin - I've tried "Scaled" but the fonts come out grainy no matter what combination of text size or resolution I pick. The only thing which makes fonts look crisp, like they did under the "Retina" setting in PD11, is using "Best for external displays". That setting also permits me to control text size and resolution. I am still running El Capitan, 10.11.6. Do you recommend upgrading to Sierra - will that help?
     
  16. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    I found that all the scaling and windows screens in general look better with pd12 and sierra. I run a lot of automation software that before in pd11 looked grainy and some elements were broken that now look just like my Windows box. I love sierra so far but some things are different mainly external displays and how they are handled.
     
  17. MICHAELM33

    MICHAELM33

    Messages:
    1
    I'm on PD 13.1 running macOS High Sierra, and I'm still having these kinds of issues with a brand new Windows 10 installation. Using the "Best for External Displays" setting (with scaling at 100%) seems to be the best compromise, but it results in my cursor/pointer being about half the size it should be. Still, text and graphics are normal-sized, so I'll take it, but it's annoying to me that this issue has been around for so long without (from what I can tell) a true solution.
     
  18. jsblau

    jsblau Bit Poster

    Messages:
    9
    Michael - that's exactly my experience. I'm on a MacBook Pro with a Retina display, running Sierra 10.12.6 and PD 13.1.0. I have "Best for external displays" and my virtual machine is Windows 10 Home version 1703. I use the "Picture in Picture" view mode. My Windows display resolution is 1680 x 1050 with 100% scaling. That seems to work well with the Windows apps I'm running (mostly Office and a browser that is running a Citrix extension to connect to another network). The cursor is really tiny, which is annoying though I've gotten used to it.

    There's a good discussion of these issues in this thread - see the long post by serv about half-way down: https://forum.parallels.com/threads/parallels-desktop-13-for-mac-retina-with-windows-10.341737/
     
  19. GavaskarN

    GavaskarN Bit Poster

    Messages:
    3
    Awesome......just the option we leave and it does the trick. ty anyways dude...
     
  20. ChristopherS15

    ChristopherS15

    Messages:
    2

Share This Page