Windows 10 ARM 20H2 on M1 Mac with Parallels 17 not working.

Discussion in 'Windows Virtual Machine' started by TomN5, Nov 5, 2021.

  1. TomN5

    TomN5 Bit poster

    I have Parallels 17 (Business) on a Mac-Mini M1 (ARM CPU running macOS Monterey).
    I am able to configure a Windows 11 (21H2) ARM VM without issue.
    I am not able to configure a Windows 10 (20H2) ARM VM from the ISO downloaded from the Microsoft VLSC. It crashes during the same installation step repeatedly. I've tried configuring it from scratch multiple times.

    Is Windows 10 ARM just not supported in Parallels 17? From what I understand, the preview version worked but is no longer available. Obviously, I wouldn't want to use a preview version for production purposes, that's why I've got the 20H2 version.

    Replicating the Failure
    After selecting the Manual Configuration option (No Sharing between Mac and Windows as an attempted workaround), It boots the ISO and I select the Language (US English) and OS version (Pro or Enterprise) as usual for any version of Windows 10. It starts the file copy process and then almost immediately BSOD's with the error "SYSTEM THREAD EXCEPTION NOT HANDLED".

    Any help would be appreciated (Are Parallels support staff here?)
  2. MikeM44

    MikeM44 Bit poster

    I have the same issue - tried many versions of ARM Win10 ISOs. Anyone have a fix?
  3. SiddharthS

    SiddharthS Bit poster

    Any updates on this issue? Was anyone able to install Win10 successfully on the Parallels?

Share This Page