Windows 10 can't utilize more RAM/CPU

Discussion in 'Windows Virtual Machine' started by DarKxRaideR, Aug 31, 2020.

  1. DarKxRaideR

    DarKxRaideR Bit poster

    Hello community,
    I was running Parallels 14 with Windows 10 Pro 1909 and Mojave, I decided to do the full upgrade and upgraded to Catalina 10.15.6 and Windows 10 Pro 2004.
    I had to realize that Windows 10 became significantly slower so I checked the Task Manager for any disturbances. I then discovered that from my 4 GB RAM I assigned only 2GB were usable, so I shut down the machine and increased the amount to 6GB and checked again but had to realize that the usable RAM only increased by 700MB sinse the hardware reserved amount increased drastically to 3,3GB. I then did the same but this time I increased to 8GB (my System has 16GB build in). And then I started to wonder, the hardware reserved part increased to 5,3GB and the usable memory was still stuck to 2,7GB.

    What I already tried:
    1) Upgrade to Parallels 16
    2) Used msconfig to set the usable memory to full 8GB.
    3) Checked the VM BIOS to see if the memory is displayed fully.

    What I also observed:
    1) Also if I increase the usable CPU Core count it is not displayed in the task manager according.
    2) Sometimes it seems to undo the changes made to the shutdown VM (memory reverted to 4GB).
    3) The total amount of RAM my System uses is not displayed the slider bar in th VM config ony goes up to 8GB maximum.

    I can't find any solution, so any help is appriciated.
  2. Hello, could you collect the tech report please (once the issue reproduced) and post the report's ID here?
    (Screenshots will be very helpful also).
    Looking forward to your reply.
  3. Jose17


    I'd also like to know more about assigning RAM. I upgraded my iMac (i5 chip) to 128GB or RAM. My Mac runs like a rocket and my Windows applications are fast too, but I when I try to assign 64GB (not even the full 128) to Windows/Parallels I get a message that reads "You don't have enough memory to start Windows"!!! Finally, I was able to assign 42.7GB of RAM, but 1MB over that prevents me from opening Windows. Please let me know if there's another option. I have various day trading programs open and receive streaming data. OH, and another thing: When I run a speed test in Apple (safari) my internet speed is 330MB -- LOVE IT... in Windows/Microsoft Edge, it's under 10MB ! Please help. Thank you
  4. Jose17


    Hi Aries. I trade the futures markets full time (various markets, which mean a lot of streaming data in real time). I probably don't need more than 8-16GB but since I paid for more I want to use it. I have Windows PCs but love trading on my 27 inch monitor; I also have a 24 inch external monitor hooked up to my iMac. I'm not sure what the memory demands of having a second monitor are, but I assume there are some. I spoke with a gentleman at Parallels tech support who helped me out big time; I believe his name was Yasser - he was terrific! He changed some of my settings so that I could utilize up to 44GB; then told me to contact Apple to remove a partition in order to assign more than 44GB. It turns out that when I went from Catalina to Big Sur 2 partitions were created. Big Sur was problematic so I reverted to Catalina; apparently those processes created partitions on my computer that was eating up a lot of hard disk space. Although I have a lot of RAM I don't have a ton of hard disk space which was preventing me from utilizing more of my available RAM.

    Currently, I have 94.208GB (has to be in multiples of 1024) running on Windows via Parallels and my machine is lightning fast. So, if anyone is experiencing this issue it could be because they don't have available hard disk space. This will prevent one from assigning more available RAM.
  5. PatrickJ

    PatrickJ Member

    That makes some sense actually, if I'm following you correctly. Windows creates a swap file for hibernation purposes as large as your available memory. If your disk space is less than ram you'd likely be limited to the max size of the swap file. Maybe? Interesting and glad you got it fixed!

Share This Page