Windows 10 Default Browser

Discussion in 'Windows Guest OS Discussion' started by LaurenceH, Jul 18, 2016.

  1. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    The apps won't appear. The option will be open in Mac. Set that as your default and the file or link will open in your default Mac browser
     
  2. Martin9

    Martin9 Bit Poster

    Messages:
    23
    I found this http://www.winhelponline.com/blog/edge-hijack-pdf-htm-associations/ interesting article and messed a bit around in my registry also with the http and https associations but nothing worked unfortunately. But I am almost sure that the solution must be in these keys somewhere as Edge is defined there everywhere. I even tried to set "Safari (Mac).exe" for the open commands but this wasn't a successful either....
     
  3. Martin9

    Martin9 Bit Poster

    Messages:
    23
    seems that I could solve the problem on my Mac. I found this article https://is.gd/NDNRtB and switched from my local account to my Microsoft account. Again I changed the default browser from Edge to "open on Mac". After a restart Edge was again set for default browser :( so I logged out from my MS account and logged back into my local account. In the W10 settings, where I can change the default browser, Edge was no longer shown but it just said "select standard". But from the menu which offers Edge and "open in Mac" none of the two can be selected. So then I went to fiile associations. .html and .htm were already associated to Safari (Mac). Since there is no http or https offered in the list (probably cause this is not a file ending) I had the idea to change .url instead. So I set .url to Safari (Mac). What can I say? Even after a restart all urls are now still opened in Safari on Mac. I don't know if this is connected on my trials with the MS account or not. Probably only the change of the file association for .url would have done it alone. I will check this on my MacBook now...ok, I checked on my MacBook which has same installation and had same problem with the sticky Edge for default browser. Going to file associations and changing the setting for .url from "internet browser" to "Safari (Mac)" solved the problem immediately. I don't know why I did not do this right from the start...this sticky Edge browser made me blind...no need to take care of the default browser settings at all as long as the association for .url is connected to Safari on Mac. :)
     
    Last edited: Aug 26, 2016
  4. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hello Guys, please be informed that Parallels Desktop 12 for Mac Hotfix 1 (12.0.1-41296) was released and the issue has been addressed. Please update Parallels Desktop to the latest build http://kb.parallels.com/123948 Latest version always available here: www.parallels.com/directdownload/pd12 Please note that Parallels Tools also needs to be updated (Actions > Update Parallels Tools) and let us know how it works. Thanks!
     
    Martin9 likes this.
  5. SteveR3

    SteveR3 Bit Poster

    Messages:
    3
    Yes, it's fixed! Thank you.
     
  6. Guna@Parallels

    Guna@Parallels Parallels Support

    Messages:
    433
    Great! Feel free to reach us for further assistance.
     
  7. Martin9

    Martin9 Bit Poster

    Messages:
    23
    I don't know whether it fixed it cause I already fixed it myself earlier as described in my previous post :cool: Since I overlooked that the hotfix is for Parallels 12 while I was still on Parallels 11 I now unintentionally installed Parallels 12. As I wasn't sure if I can simply interrupt the installtion without facing troubles later I bought a new license key while I would have probably waited with the upgrade until Mac OS comes out in autum. So @PaulChris@Parallels is nominated for employee of the week by Parallels sales dept. ;) I am now facing problems installing Parallels Toolbox but I will check the forum first before I open a new thread on that...
     
  8. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    Let me know if i can help with the toolbox issues
     
    Martin9 likes this.
  9. KaiS1

    KaiS1 Bit Poster

    Messages:
    8
    Is there any plan on fixing this on Parallels 11? I actually upgraded from Parallels 10 to 11 because I ran into this exact same issue after upgraded to W10 (default web browser will reset when restarting the VM), and I'm going to be royally pissed if I have to upgrade to 12 when there are literally no new features that I care about, just to get this fixed.
     
  10. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    The issue is with windows. Change your default file associations like martin posted above. Be sure to set safari or open in mac to the url associations also not just http and https. This should get it working.
     
    Martin9 likes this.
  11. KaiS1

    KaiS1 Bit Poster

    Messages:
    8
    No, it's not with Windows. I've tried changing them to "Open in Mac", using both the Default apps section in Settings and by specific protocol / file extension, and they always reset to Edge upon restart. If I change them to another Windows VM browser (Chrome) though, it sticks.

    And again, I ran into this exact same issue with the initial release of W10 on Parallels 10, and upgrading to 11, while running the exact same Windows install, resolved it. So the issue is how the "Open in Mac" (which was actually called something else in Parallels 10, though I can't remember what) is implemented.
     
    Last edited by a moderator: Sep 2, 2016
  12. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    No the issue is how edge handless this problem in Windows 10. If you block edge from running it won't happen anymore
     
  13. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    But most people don't want to block it completely. Have you tried setting safari instead of open in Mac?
     
  14. Martin9

    Martin9 Bit Poster

    Messages:
    23
    @KaiS1 actually there is NO need for any fix at all for version 11. You can fix it yourself as described above in my posting (#23) and you can stay with version 11 as long as you like...
     
  15. KaiS1

    KaiS1 Bit Poster

    Messages:
    8
    Then why does it not happen if you try setting another (native) browser as the default? As I've said, if I set it as Chrome, the settings stick without issue. It's only when set to "Open in Mac" that it breaks.

    Safari is not an option, in both sense of the phrase - I do not want to use Safari (I use Chrome on OS X), and it does not show up. See below image.

    There is no option to set the .URL file association with anything other than "Internet Browser". See below image.

    These are the options I have when trying to change the default app through the various different ways W10 allows you to.
    [​IMG]
     
  16. Martin9

    Martin9 Bit Poster

    Messages:
    23
    I preassume that you made all necessary adjustments in Parallels settings as well (Internet & e-mail > open in Mac) and set Chrome for default browser in OS X. I have no explanation why for you not even Safari is offered to be associated with ".url". As mentioned above for me it was offered even before using the fix. Probably interesting to know is that after applying the fix (for Parallels 12) the file association for ".url" is "internet browser" again (not Safari). I just found out now (see screenshot below -german-). So even if Safari is still offered after the fix, the standard setting is back to "internet browser" while urls are properly opened on Mac.

    Sceenshot.png
     
  17. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    because windows 10 uses a hash algorithm to check default file extensions. The mac file extensions sometimes do not Work right with the windows security features. This is why i recommend not setting your default to "Open in MAC" but to "Safari (MAC)" Or "FireFox (MAC)". You see the difference in the setting? This natively sets the Program instead of setting it to the Mac controlled default which doesn't play well with windows security on some systems. Why im not exactly sure because i do not have the source for the application. If you do not see these options in you defaults please make sure that parallels shared applications shows up in windows.
    If it does not go to you VM configuration < Options < Applications < Share windows applications with mac checked
    Share mac applications with windows checked.
    Also be sure you are logged into windows as an administrator.
     

    Attached Files:

    Last edited: Sep 3, 2016
  18. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    Here is a Screenshot of the parallels shared applications folder under the windows 10 start menu.
    See if your mac applications (Chrome for OS X) are available here.
     

    Attached Files:

  19. Martin9

    Martin9 Bit Poster

    Messages:
    23
    seems there is a problem here with attached files/pictures...at least for me using Safari. Can't always open them. An the screenshot that I attached to posting #36 is no longer available...
     
    DustinHullett likes this.
  20. DustinHullett

    DustinHullett Product Expert

    Messages:
    181
    click the link to open them and then after they open in a new window wait about 5 seconds and click refresh in your browser. This is how i have to sometimes get them to show. Thanks martin9 for pointing that out.
     
    Martin9 likes this.

Share This Page