Windows 10 major delays after Monterey install

Discussion in 'Windows Guest OS Discussion' started by FrankO1, Nov 29, 2021.

  1. FrankO1

    FrankO1 Bit Poster

    Messages:
    42
    I've been running Windows 10 Home 19041 under Parallels Desktop Pro 17.1.0 on a 2018 i9-based MacBook Pro. Until recently this was under macOS Catalina, but I've since installed Monterey and am now running macOS 12.0.1.

    Immediately after the macOS update I've been seeing *major* speed issues within Windows under Parallels. For example, if I click on a menu selection in the Windows OS, it often takes 5 or 6 seconds to register.

    Are there any known issues that could cause this? Or any suggestions on how to troubleshoot it?
     
    MarkG17 likes this.
  2. MarkG17

    MarkG17 Bit Poster

    Messages:
    5
    I have the same issue, only I'm running Home edition of Parallels on a 2019 27" iMac running Monterey 12.0.1
    Eagerly awaiting a response/solution
     
  3. ArifL

    ArifL Bit Poster

    Messages:
    1
    Hello. I had the same issue. It was since my MBP upgrade to Monterey, Windows 10 is very slow. I though it should be upgrade to Windows 11. But it has the same issue.
    So, I made a new VM for Windows 10 with fresh installation. It is the same situation. Slow and I have to wait until I could do Right click and click Refresh for more than a minutes may be more.
     
  4. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hi, please visit https://kb.parallels.com/125506 to know about all the knows issues with Mac OS Monterey.
    Kindly reinstall Parallels Tools by following https://kb.parallels.com/4841 and update us if you see any changes on performance.
     
  5. MarcoW2

    MarcoW2 Bit Poster

    Messages:
    12
    I've experienced similar issues and the mentioned KB did not resolve any. My impression is that it is related to accessing files on my Mac from Windows. I've got a lot of files on my Mac which I access through the available shares. Both the Explorer seems very slow, as accessing files. This behaviour is almost identical on Windows10 and Windows11 virtual machines.

    Any idea's or suggestions?
     
  6. MarkG17

    MarkG17 Bit Poster

    Messages:
    5
    Tried reinstalling Parallels tools but that didn't help a bit. My Windows 10 VM is now virtually unusable. When are you going to fix this issue?
    Doesn't help at all. VM is virtually unusable. Need a fix for this MAJOR issue
     
  7. FrankO1

    FrankO1 Bit Poster

    Messages:
    42
    Just an update on this topic as the OP.

    I tried reinstalling Parallels Tools, but this didn't help. Besides general slowness, after this I was now seeing Windows freeze every few seconds when the mouse/touchpad was moved. I tried different mice without improvement.

    Since my other VMs (Ubuntu, earlier macOS, etc) were all working fine in Parallels Desktop, I figured the issue had to be specific to the Windows 10 installation. I therefore did a fresh install of Windows 10 from scratch as a new VM, using the menu option within Parallels Desktop to install Windows 10. (This required then upgrading Windows Home to Pro, and finding/applying my activation key.)

    The result is that the new install of Windows 10 is running super-fast. No issues at all. Of course now I have to go back and figure out what apps I need to install in the new VM, and how to get data ported. Hard to do within the old Win 10 VM as it freezes up constantly.

    So, my takeaway is that the problem was no doubt caused by the fact that my old Windows 10 VM was installed several versions ago of both Parallels Desktop and macOS, and probably there was some issue with a driver or what-not. With the old Windows VM I did see some error messages saying Windows couldn't reach its hard disk. But a fresh Windows 10 install seems to be the fix.
     

Share This Page