Windows 10 Preview 2 - Parallels Tools installs on every restart

Discussion in 'Windows Guest OS Discussion' started by Diane_Wilson, Jan 23, 2015.

  1. Diane_Wilson

    Diane_Wilson Bit Poster

    Messages:
    2
    I just installed the Windows 10 Technical Preview 2 that was released today (January 23). Parallels Tools installs, and says that the install was successful, and wants to restart. After the restart, it does the same thing again.... and again.... On restart after installing the tools, it does not seem to recognize that the Parallels tools are installed.

    Any suggestions?
     
  2. EricM1

    EricM1 Bit Poster

    Messages:
    1
    I'm experiencing the same problem using the latest version of Parallels 10. It's very frustrating :-(
     
  3. Dan_Friedman

    Dan_Friedman Bit Poster

    Messages:
    2
    I'm seeing the same thing.
     
  4. auros

    auros Bit Poster

    Messages:
    4
    Hmm, that's not encouraging. I'd love to know from the Parallels team if they foresee being ready to deal with Windows 10 when it comes out officially for the public later this year.
     
  5. MagicBoy

    MagicBoy Bit Poster

    Messages:
    10
    Same here - build 9926. Previous Windows 10 releases worked fine though.

    Parallels will be getting the test builds at the same time as us. Other than that it works quite well really.
     
  6. Specimen

    Specimen Product Expert

    Messages:
    3,244
    You might try to work around this issue temporarily, you can disable the PT Auto Update mechanism following these steps:

    IMPORTANT
    Proceed at your own risk, you should know what you are doing, if you have any question or doubt regarding these instructions then don't do it, incorrectly editing the config.pvs may result in the loss of data, backup your VM first.

    1) Shutdown the the Virtual Machine, it shouldn't be suspended or running.

    2) Go to the .pvm package if the VM in Finder -> right click on it -> Show Package contents

    3) Find the config.pvs file and open config.pvs in any text editor, for example TextEdit.

    4) Find "<AutoUpdate.......>
    <Enabled>1</Enabled>
    </Autoupdate>"

    5) Change the value in "Enabled" from 1 to 0: i.e "<Enabled>0</Enabled>"

    6) Save the changes and exit the text editor.

    By doing this, the Parallels Tools won't check for update.

    You should revert these changes once a new Parallels Desktop update is released (change the value back to 1).
    To be more precise, this disables the mechanism by which PT checks if the PT version installed is the same as the one in Parallels Desktop and autoupdates if not, might or might not workaround this issue, please share your experience.
     
    Last edited: Jan 24, 2015
    TomM1, Ming1, JoachimI and 1 other person like this.
  7. FrankGeelen

    FrankGeelen Bit Poster

    Messages:
    1
    U the man, @Specimen ! Works flawlessly....
     
    Specimen likes this.
  8. slackpacker@mac.com

    slackpacker@mac.com Bit Poster

    Messages:
    4
    CTL + ALT +DEL and stop PTools from re-installing. Then use Cortana to find the startup apps and disable PTools from starting. This also seems to work. But PTools still does not fully install correctly.
     
  9. TerryG1

    TerryG1 Bit Poster

    Messages:
    1
    Same issue here. Thanks for the work around tips! Hopefully they'll fix it soon.
     
  10. jtdavidson83

    jtdavidson83 Bit Poster

    Messages:
    4
    If you move the HDD to a new VM shell then it stops trying to reinstall.
     
  11. StanislavZ

    StanislavZ Parallels Developers

    Messages:
    102
    It should be enough to cancel Parallels Tools installing dialog. You should click close (red 'x' in the corner) button when PTools installation has started and answer 'Yes'.
     
  12. James Rome

    James Rome Kilo Poster

    Messages:
    120
    Clicking the X does not stop it for me. Changing <autoupdate...> to 0 did fix it.
     
    Specimen likes this.
  13. JamesC2

    JamesC2 Bit Poster

    Messages:
    9
    I did the new install, shut it down, and checked the "enable" value in config.pvs. Interestingly, it was already set to zero. The weird graphic characters on all the Modern UI screens are gone - in fact, there is no text at all (which makes it rather difficult to use the Settings app to change the user from the Mac username to my Microsoft user account, or to make any settings. The settings app shows all blank, with nine grey squares, each of which leads to another screen, and is only visible if I hover the mouse above it. I won't delete this copy, but will wait a day or so to see if Parallels comes up with any answer and will see if I can search the forums to find an answer.
     
  14. JamesC2

    JamesC2 Bit Poster

    Messages:
    9
    Changing the configuration from DirectX 10 to DirectX 9 fixed the lack of text. On another thread, it was reported that the newest Mac Mini worked without the change, but the 2011 version required the change. Problems fixed. Thanks.
     
  15. Specimen

    Specimen Product Expert

    Messages:
    3,244
    This is a terrible official suggestion, canceling the installation will result in partial install of PT since cancel does not roll-back changes (why?). Besides, it doesn't work.
     
  16. LarryB2007

    LarryB2007 Bit Poster

    Messages:
    1
    Changing AutoUpdate to the "<Enabled>0</Enabled>" solved the problem for me. This was occurring on the Windows 10 Pro Technical preview Build 9926. Thanks for the tip. Your help is greatly appreciated!
     
  17. StanislavZ

    StanislavZ Parallels Developers

    Messages:
    102
    Specimen, maybe I didn't express myself clear. What I meant to say was: if you're caught in PTools reinstallation loop (second, third iteration, etc.), you can stop it by cancelling Parallels Tools Installation agent with close button.
    Close button is available before installation progress reaches 15% and does not leave system in inconsistent state as nothing has been modified in system yet.

    If this solution does not help, please make a problem report with detailed logging enabled and post ID here.
    Thank you. We're working to resolve this problem.
     
  18. dsilverman

    dsilverman Bit Poster

    Messages:
    4
    I was having this problem as well on a 2012 Mac Mini. Initially I had it after updating from the first Win10 Technical Preview to the latest one, build 9926. I was able to stop the Tools installation using Task Manager, but once I restarted the VM, the installer would return. I wound up trashing this VM and starting over from the ISO, and had the same problem AGAIN.

    I went into the configuration and noticed that the VM was showing it had 2 optical dives. This is a Mac mini, there is no optical drive, let alone two. One of the two was connected to the Parallel Tools ISO, so I disabled that virtual optical drive. That seemed to fix the issue. I didn't get a chance to look at the first VM (the updated one I trashed), but I suspect it, too, had an optical drive bound to the Tools ISO.

    When set up the new Win10 from scratch with its ISO, I used the default settings, for what that's worth.

    Oh, and I updated Win10 VM on my 2014 MacBook Pro without seeing this issue.
     
  19. GrahamSt

    GrahamSt Bit Poster

    Messages:
    2
    Same as 'dsilverman' ... I also spotted 2 optical drives, with one connected to 'unattended.iso'. I have no optical drives on this MacBook Pro so disabled that virtual optical drive. The Parallels Tools installation agent no longer appears each time I start the VM.
     
  20. Teddy Gordon

    Teddy Gordon Bit Poster

    Messages:
    2
    I had that very issue to but for me the suggestion from StanislavZ is working at least for the moment.
     

Share This Page