Windows 11 ARM and Epson Printer Driver // Virtual Port Driver

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by ParallelsU860, Aug 10, 2022.

  1. ParallelsU860

    ParallelsU860 Bit Poster

    Messages:
    5
    Hej, I have problems installing Epson Print Drivers or Virtual Port Drivers for an Epson POS (Point of Sale) Thermal Printer Model TM-T88VIwith Network Connection (Ethernet) on Apple iMac 24" M1 with the latest version of Parallels Desktop an Windows 11 ARM.

    In the case "EPSON Advanced Printer Driver for TM-T88VI Ver.5.13E" every time I try to install the drivers it stops installation after 30sec and is ending the process with dialog "Installation failed"
    In the second case i tried only to install the "TM Virtual Port Driver Ver.8.70a" - this stops also with "Error: Can´t open \\.\EpsonPA
    Both Installers can be found here under "Windows Printer Driver" or "Virtual Port Driver":
    https://download.epson-biz.com/modules/pos/index.php?page=prod&pcat=3&pid=4983

    Maybe someone have also experience the installation problem and allready found a solution for this.
    Thanks!
     

    Attached Files:

  2. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    774
    Looks like those are Intel drivers. You can only use ARM drivers.
    Have you tried installing the macOS driver and sharing the printer with Windows?
     
  3. ParallelsU860

    ParallelsU860 Bit Poster

    Messages:
    5
    Yes - but it seems to be not possible sharing this type of printer.
     

Share This Page