Windows 11 ARM, trouble installing HP printer driver

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by JonathanK13, Feb 8, 2023.

  1. JonathanK13

    JonathanK13 Bit poster

    Messages:
    1
    Hey all, I've been having trouble getting a specific printer working on my windows 11 VM. The goal is to have multiple versions of the same printer, an HP P4014, each set up with its own tray when selecting which printer to print from (tray two for one type of paper, tray 3 for another, ect). The problem we are running into is upon installing the appropriate Windows 11 64-bit driver, we get the error message operation could not be completed error 0X800f0214 the specified path does not contain any applicable device infs. Our next idea was to install the printer driver for the Mac OS and share it through parallels with the appropriate tray configurations, but there is no Mac OS driver for the P4014. Finally we tried installing the HP Smart Helper tool, which does install the printer on the Mac OS (does not appear as an option through the VM though) but ultimately gives no options to configure which tray to draw from. Is there a way to fix this initial Windows 11 VM driver issue, and if not, a workaround that can get us to have multiple versions of the same printer each configured with its own paper source settings?
     

    Attached Files:

  2. RyanM35

    RyanM35 Bit poster

    Messages:
    1
    Did you find a solution I was having the exact same issue.
     
  3. BillH12

    BillH12 Bit poster

    Messages:
    2
    same here - it was working until a couple of days ago. I tried re-installing the printer software & now getting 0X800f0214 error.
    Does anyone have any pointers?
    This is Windows 11 Pro Insider Preview running in parallels 19 on MacoS 14.2.1 M1 chip
     
  4. Avinash Bundhoo

    Avinash Bundhoo Staff Member

    Messages:
    385
    Hello,
    Thank you for your feedback

    To to disable Windows firewall and uninstall your antivirus.

    Once done, retry the printing software.

    Let us know if this helped.

    thanks
     

Share This Page