Windows 11 install fails due to no network

Discussion in 'Windows Guest OS Discussion' started by AndrewF17, Nov 9, 2021.

  1. AndrewF17

    AndrewF17 Bit Poster

    Messages:
    1
    Trying to install Windows 11 on Intel iMac running Big Sur.
    Installation works until it gets to step "Let's connect you to a network" - no network is listed & Next button is greyed out with no other options available.
    iMac is connected to internet via WiFi - I have tried changing from "Shared Network" option to each of the "Bridged Network" options, but no luck.
     
    brunomelobr likes this.
  2. LarryW1

    LarryW1 Bit Poster

    Messages:
    7
    Has anyone else seen this, or discovered a solution? I just tried installing Windows 11, and ran into the same problem at the same point in the installation process. All other processes and applications on my iMac run without problems while this is occuring in Windows 11 on Parallels Desktop 17. I've never had an issue installing Windows on Parallels until now, and I have several other Windows VMs that run (on Parallels 17) without problems. I also tried doing the installation with all macOS networking firewalls and networking monitoring tools turned off, and rebooted the cable modem. No success.
     
  3. mmika

    mmika Kilo Poster

    Messages:
    488
    I would suggest to check virtual network adapter type in VM preferences.
    There shouldn't be VirtiIO adapter selected _for_this_case_.
    If you started installation in express mode, this adapter is set by default. But when installing windows in express mode, drivers for VirtIO network adapter automatically installed. But if something goes wrong and you continue installation in manual mode, VirtIO network adapter could be set in VM config, but Windows doesn't have build-in drivers for that one.
     
  4. LarryW1

    LarryW1 Bit Poster

    Messages:
    7
    mmika - I checked, and sure enough, VirtiIO was selected. Once I set it to the same adaptor as my other VMs, it worked correctly. Thanks!
     
  5. ArnisJ

    ArnisJ Bit Poster

    Messages:
    1
    Spent 2 hours searching for solution and it ends up really simple:

    * Just press Shift + F10
    * At the cmd window type taskmgr and then enter
    * Expand to more details
    * Find 'Network Connection Flow' - right click and choose End task
    Thanks to Youtube user @Neowin video:
     
  6. LeeC13

    LeeC13

    Messages:
    1
    Hello, Had this same issue as AndrewF17 and tried all solutions which followed nothing worked but the following. I was trying to setup on a new Mac mini (M1) Parallels 17 and Windows 11. What I missed was I needed Windows 11 ARM version. After trying multiple times to install and reinstall all items.(2 days) The best advice was to delete all and follow a Youtube post from
    How to Install Windows 11 on an M1 Mac with Parallels 17 - Full Walkthrough! It worked perfectly. Good Luck
     
  7. MattB23

    MattB23

    Messages:
    1
    I didn't know I could change the adapter type, so instead I did this and it brought up the interface pretty easy:
    • mount the Parallels Tools CD (actions, Install Parallels Tools)
    • hit Shift+F10 to bring up a CMD (on Mac, use Shift+FN+F10 if you have default keyboard settings)
    • 'cd d:\' to change to CD drive, then 'cd D:\Drivers\Virtio_net\Win10\'
    • 'start .' runs and Explorer window at that path
    • Right click INF, hit Install
    • the adapter springs to life (run ipconfig to check)
     
    brunomelobr and SabinoA like this.
  8. Bhargava@Parallels

    Bhargava@Parallels Staff Member

    Messages:
    302
    Hello, please follow the below steps to resolve the issue: 1. Send Shift+10 to VM, 2. CMD will open. Run task manager from it and kill the "Network Connection Flow" process. Thanks.
     
  9. akshayvj

    akshayvj Bit Poster

    Messages:
    1
    How can I change windows security settings using python? i.e. Password Requirements / Require Ctrl - Alt - Delete to log in

    I am writing code in Python 2 or 3 to script Cybersecurity functions. Functions such as Lockout Duration, Password Length, and other things that involve a lot of clicking that could easily be automated.

    import subprocess
    subproccess.call(x, shell = True)
    I plan on using that format to run (or enter ((so I don't have to type only press the answer button))) commands in command prompt (with Administrator privileges). However, I have no idea how I should do this, especially the "Require Ctrl - Alt - Delete on Startup."
     
  10. MatthiasL7

    MatthiasL7 Bit Poster

    Messages:
    2
    sorry, but the first thing didn´t work. and i´m not sure, but i think i don´t understand you right.
    what should i do after getting to the folder "D:\Drivers\Virtio_net\Win10\"???
    if i type start, a new explorer opens, but how to do a right click in cmd? nothing happens...
     
  11. osmane

    osmane Bit Poster

    Messages:
    2
    Well it works but when you open the command box after shift 10 open task manager by running "taskmgr" command without quotes and when task manager opens press run new task write explorer - an explorer window will open - if not then run new task and explorer again - there locate D parallel tools and find the driver file from the ss i attached right click as shown and it will auto continue finding network [​IMG]
     
  12. osmane

    osmane Bit Poster

    Messages:
    2
    [​IMG] Screen Shot 2022-07-04 at 4.20.22 PM.png
     
    AdamL2 likes this.
  13. MatthiasL7

    MatthiasL7 Bit Poster

    Messages:
    2
  14. brunomelobr

    brunomelobr Bit Poster

    Messages:
    3
    Best solution.
     
  15. mial1

    mial1

    Messages:
    1
    ILYSM TY<3333
     
  16. life

    life

    Messages:
    1
    Please I don't know what to do from the taskmgr
    I use a mac 2020 m1 chip
     

Share This Page