Windows 11 on Arm

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by kundanno, Jun 23, 2021.

  1. Sebastien

    Sebastien Bit poster

    Messages:
    1
    Hi, I use Parallel on my MacBook Pro M1 (16GB) with Windows 11 Insider, but everything is very very slow since 1 month, especially with x64 applications. I use only 2 x64 applications, sometimes can take 15 minutes to open an x64 application ! Win CPU always at 100% when MacOS CPU is at 15/30%.
    Win11 high usage is many time : System, Explorer...
    The build is Win11 Pro Insider Preview 22543 / 220122-2315.
    Parallel settings are CPU/RAM : Auto, Graphics : Scaled.
    Did you encounter same problem?
     
  2. CarlH2

    CarlH2 Junior Member

    Messages:
    16
    Go to System Preferences > Spotlight > Privacy and press the + sign and add the folder where your VMs are stored.
    This helped a lot for me.
     
    SergioI1 and WilliamT14 like this.
  3. BAMR

    BAMR Junior Member

    Messages:
    17
    Does anybody have issues with interference/crackling from the speakers in Windows 11 on ARM? Its not happening in macOS, just in Windows, even when there's nothing playing, just random crackles!
     
  4. SWANDY

    SWANDY Pro

    Messages:
    315
    I do hear. it occasionally - usually when certain games are playing sound effects - but not constant or often enough to be really annoying.
     
    BAMR likes this.
  5. BAMR

    BAMR Junior Member

    Messages:
    17
    I've had to start using Teams for some work I'm doing and the audio was a bit crackly on there compared to the Mac version so I'm wondering if its related.
     
  6. davidmenges

    davidmenges Bit poster

    Messages:
    1
    I was about to return Parallels Desktop - very slow. This fixed it. Thanks!
     
  7. HaraldSt

    HaraldSt Member

    Messages:
    99
    I keep my VMs on a separate Volume that I can easily exclude from snapshots etc. I periodically back them to my NAS with ChronoSync and to a disk with CarbonCopyCloner.
     
  8. CG_7

    CG_7 Bit poster

    Messages:
    1
    Hello all, I have been reading through everything I could find about installing Parallels 17 on my M1 iMac. I think I'm ready to take the plunge, but have one question that I couldn't find an answer to. It looks like Parallels is updated about once a year. If I purchase Parallels 17 now, would a new version be out in about 5 months from now that may require me to purchase an upgrade to continue running Win 11 on my M1 iMac? Sorry if this has been answered before, I'm a total newbie to this.
     
  9. HaraldSt

    HaraldSt Member

    Messages:
    99
    [QUOTE="CG_7, post: 901404, member: 6778924"It looks like Parallels is updated about once a year. If I purchase Parallels 17 now, would a new version be out in about 5 months from now that may require me to purchase an upgrade to continue running Win 11 on my M1 iMac? Sorry if this has been answered before, I'm a total newbie to this.[/QUOTE]No. If you buy outright, version upgrades are only available for about two months after the sale using their typical Tech Guarantee - at least that's what it was last year. You will qualify for upgrades, which were $49.99 last year.
    My three Pro licenses are subscriptions. I use them a lot including for work, so it is worth it. For more than a decade I used VMware products with more liberal license policies, but Parallels has left them in the dust.
     
  10. AndyB9

    AndyB9 Junior Member

    Messages:
    18
    I had a similar problem with networking on Windows 11 ARM edition running under Parallels 17. The culprit for me was that IPV6 needed to be disabled somewhere in the Windows Settings for Network connections. Hope this helps.
     
  11. AndyB9

    AndyB9 Junior Member

    Messages:
    18
    I recently purchased an Epson WF4830 Inkjet Multi Function Printer. Bad Mistake - the drivers for the Mac are cut down versions compared to the Windows version. The drivers WILL NOT INSTALL in Windows 11 ARM edition and upon contacting Epson Support, they said they HAVE NO PLANS TO SUPPORT WINDOWS 11 ARM edition.

    I also purchased Logitech MX Keys Keyboard for Mac and Logitech MX Master 3 Wireless Mouse for Mac recently - drivers (or what Logitech call their Logi Options +) software installed and runs ok on the macOS side, but once again WILL NOT INSTALL on Windows 11 ARM edition - meaning that all the bells and whistles of these products WILL NOT WORK IN WINDOWS 11 ARM edition. I see this as a huge step backwards in Windows usability and compatibility on the Parallels platform. But who do we blame? Both Epson and Logitech seem to take the easy way out and state: "Our products are not meant to work in VM's". Ah yeah....bullsh*t! They should work. Do we blame Apple for arming their new machines with "M" series processors that no longer support X86/X64 versions of Windows? Or do we blame the peripheral manufacturers for being too lazy to produce Windows 11 ARM drivers/software.

    To me, this whole problem doesn't seem like an easy one to solve. I wanted all the benefits of the new "M" series processors when I purchased my 2021 16 inch MBP (with M1 Pro Processor) *boy that's getting a mouthful*, but as for Windows compatibility, these new "M" Series Macs are problematic from a Windows driver point of view. So many devices simply won't work to their full capability because of the lack of suitable Windows 11 ARM drivers. It reminds me of the early 90's when I had to beg different printer/device manufacturers to build drivers for the Commodore Amiga computer. You basically had Buckleys and None chance of them doing it. Lots of manufacturers just
     
  12. AndyB9

    AndyB9 Junior Member

    Messages:
    18
    won't invest the money required to create drivers for Windows 11 ARM because they think it will not be popular enough or used widely. A sad state of affairs indeed.
     
  13. Don Awalt

    Don Awalt Hunter

    Messages:
    132
    There has been a problem between Comcast as the ISP and Netgear routers, at least the Orbi mesh ones - IPv6 connectivity would drop - the Netgear router showed it had an IP for v6, yet the online IPv6 tests would show no IP address. I suspect the system would start to fail in networking activities because it seems v6 may be the default if both v4 and v6 are operational - and Windows thought both were running ok. For me, Windows laptops on our network stopped working on the network, yet for some reason Macs seemed ok. It could drop network connectivity anywhere from several hours to 3-5 days after getting a new IP address. Once this happened, IPv6 would stay down until a manual intervention re-established the IP connection - on a Netgear router, setting it on "Auto Detect" or DHCP for Comcast, apply, and a new IP address was established and things ran again. This was not really a Parallels issue, as people saw this in a number of forums that were not running Parallels VMs (reddit, netgear, DSL reports being a few of them where the problem was reported).

    IMHO the problem happened on lease renewal between Netgear and Comcast - the Netgear router thought it had a good renewed IP address, Comcast did not. That's just a hunch though.

    In my case I have the Orbi RBR850 mesh router, and its latest firmware update, 4.6.8.5, which came out around June 22, appears to have fixed this. I have been running IPv6 since June 23, almost 13 days now, with no interrupts in IPv6. Maybe this situation is what you are facing?
     
  14. WilliamT14

    WilliamT14 Member

    Messages:
    26
    This needs to be a sticky! Thanks for this!!
     
  15. WilliamT14

    WilliamT14 Member

    Messages:
    26
    I also have a NetGear Orbi setup, however it's the RBR750 with the same firmware. I also enabled email logging (see Netgear forum), appears to fix a bizarre bug as this apparently clears logs that fail to clear otherwise and cause occasional dropouts/reboots of the WiFi service.
    Between the new firmware and the email logging being enabled, I've had solid networking experience in Windows 11 under Parallels.
     
  16. WilliamT14

    WilliamT14 Member

    Messages:
    26
    Totally agree! However, I don't blame Apple nor Parallels. I do blame Microsoft/Qualcomm for their exclusivity agreement for the Surface Pro X ARM edition being the only OEM source of Windows 11 ARM for so long. I'm seeing a few other Windows 11 ARM systems now, so the exclusivity has expired. Not a compelling large enough market base for device developers. I remember how long it took to get new drivers for some of my devices during the Windows XP to Vista and newer Windows OS releases. Also many were likely put off by the much older Windows R/T way back.
    However, I'm amazed with what does work with Windows 11 ARM and hopefully the market share will continue to increase. Until enough customers petition these device driver developers at the different vendors, likely it will continue to be an issue. If Metal 3 API (currently in beta with macOS 13) does a great job and brings the better ability to provide DirectX12 compatibility, I expect Parallels deployed versions of Windows 11 ARM will help that market base to grow. Especially considering how well the base M1 performed Windows 11 ARM via Parallels compared to Microsofts/Qualcomms own SQ1 and SQ2 SoC's. That's impressive and promising enough for me to stick with it despite device driver frustrations.
     
  17. Don Awalt

    Don Awalt Hunter

    Messages:
    132
    I have had this setting for awhile, and Windows/Parallels does run very fast for me!
     
  18. berendB

    berendB Bit poster

    Messages:
    1
    hi guys, windows 11 on mbp14inch here, after installation it just keeps spinning in this screen for ever.. any ideas how to fix? Thanks. Couldn't find it on the forum elsewhere
     

    Attached Files:

  19. DaveK10

    DaveK10 Bit poster

    Messages:
    4
    Has anyone installed Oracle 19 or 21 on Windows ARM? Trying to decide if I should make the switch from an intel mbp to m3.
     
  20. DaveK10

    DaveK10 Bit poster

    Messages:
    4
    For anyone else wondering.. I went ahead and tried it and was able to successfully install Oracle 19c on Windows ARM with no issues.
    The only problem I ran into is the Oracle Visual Studio Tools are not compiled for ARM and will not install. Hoping that they will release an updated version with support.
     

Share This Page