Windows 11 PRO ARM/Parallels 17.1.0 (51516) and Xbox BLUETOOTH Controllers

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by SWANDY, Nov 14, 2021.

  1. SWANDY

    SWANDY Kilo Poster

    Messages:
    236
    Yes I know there is another thread about Windows 11 ARM and Xbox controllers but that was started as a discussion about USB connections. My question is about using BLUETOOTH as a connection.
    I have the setup in the title. I am currently running OS Build 22000.318 (just recently updated to that from .282). I have a Bluetooth Xbox One S controller. It pairs and connects perfectly to the Mac OS side (Monterey 12.0.1).
    However on the Windows side I see it listed as paired under Bluetooth devices. I also see something that says "Virtual Bluetooth Controller" - which I assume has something to do with Parallels. But I cannot get the controller to CONNECT on the Windows 11 side. Whether I first make sure it is connected on the MacOS side or make sure it is disconnected from the Mac side first, it will never connect to the Windows side. (I do remember at one point being able to connect it to the Windows side - however whether that was when I was running Windows 10ARM, an earlier build of Windows 11ARM or an earlier version of Parallels 16 or 17 I am not sure at this point. But I do remember testing it with the one controller game I have on Windows for someone on the forum here and it did pair/connect/work.)
    Any advice/suggestions would be appreciated. Thanks
     
  2. GabeZs

    GabeZs Bit Poster

    Messages:
    16
    Hello Swandy,
    I tried the same config as you. However, the pairing / connection doesn't work proper (either way that you tried). If the Xbox controller happens to show up in the VM, it will either ask for a pin and fail, or it will connect and then disconnect immediately after. If you want to see the behavior, you can sometimes flip the Bluetooth toggle on and off in the Windows VM and it will sort of kick it Bluetooth into shape (long enough to see the controller and fail at pairing or staying connected).
    There is no fix, and the only way to use the controller is to roll back to parallels 17.0.1 and connect with a USB cable. To test, you'll want to make sure the controller isn't paired to anything. Then, turn the controller off and connect the USB cable. The controller will vibrate. Click on the USB icon and choose "controller" or agree to allow it to connect to the VM if prompted. Then, press the Xbox logo to turn on the controller and observe that it blinks and turns solid. You will now be able to use it.
    It is important to note that not even parallels 17.0.1 is working correctly with Bluetooth (unless 8bitdo adapter and PlayStation 3 controller).
     
  3. SWANDY

    SWANDY Kilo Poster

    Messages:
    236
    Thanks for the info. At this point the controller working was more of a "computer puzzle" for me. I only have one Windows game installed that needs a controller and I basically reinstalled it to test out the controller. Probably just give up and wait for MS or Parallels to fix the issue.
    (Now if someone can explain to me how to fix the Xbox app being unable to install games....)
     
  4. kevin56

    kevin56 Bit Poster

    Messages:
    1
    Same problem.
    I am using the latest PD 17.1.0 (51516) + Win11 ARM (build 22499.1010).
    1. xbox controller + bluetooth ❌
    The system cannot find my controller.
    2. xbox controller + receiver ❌
    The receiver does not blink anyway. The system control panel shows that something wrong with the driver. Tried to install several drivers but none of them works.
    3. xbox controller + cable ✔️
    This is the only solution right now. Seems to work well.
     

Share This Page