Windows 7 Beta 1 Build 7000

Discussion in 'Windows Guest OS Discussion' started by GMB1, Dec 28, 2008.

  1. Peter Whysall

    Peter Whysall

    Messages:
    10
    Because, in a stroke of genius, Microsoft designed Safe Mode such that you can't use it to uninstall software that uses the Windows Installer service, I had to work around.

    Firstly, create a new admin user and give it a password. Log in with this user, holding down SHIFT as you do so (this may be placebo, but it's supposed to stop things running at login) and then you can uninstall Windows Live.
     
  2. articos

    articos

    Messages:
    1
    no sound

    I installed the 64 bit version of the 7 beta with build 3810, and everything is great except no audio. iMac 2.16 20" (white). Tried the Intel drivers to upgrade off of, no go - won't install. Tried the RealTek drivers - the Vista drivers install, but still no sound. The XP drivers won't install. Audio multimedia device is "unknown". Everything else is perfect - install was cake. Added Tools no problem as well.
     
  3. beta_mick

    beta_mick

    Messages:
    2
    I had the windows live hag my system in parallels as well in 32bit W7 but i did a quick windows repair and that sorted it out, without needed to reinstall or uninstall anything. Now i find the parallels video card doesn't seem to work with movie maker or dvd maker. no so worried about dvd maker but movie maker a little annoyed about the lack of movie maker (stating that video card isn't supported). Also the isight camera doesn't install with parallels tools, which is annoying i have to install it with the bootcamp drivers instead. anyone have another solution to that ?
     
  4. mobilehavoc

    mobilehavoc

    Messages:
    13
    I have everything working now after doing a clean install of Windows 7 B1 on build 3810, however, now whenever I suspend the W7 VM and then resume it, it just hangs and I have to shut it off on to get working.

    Anybody else's suspend working with PD4 and W7? Everything else seems to work - it just doesn't want to resume from suspend. No clue why. Sucks big time though.
     
  5. macguy

    macguy Bit Poster

    Messages:
    51
    Windows 7 installed fine, Parallel tools, network, fine

    Windows 7 installed fine under Build 3810 for me. The network works, no problems there. I didn't turn on Folder Sharing but I am able to drag and drop files from the Mac Desktop to the Windows 7 desktop with no problems.

    However, as soon as I try to start up simple applications like the default games that come with Windows 7, such as Hearts or Solitaire, the Virtual Machine just stops responding to any input. The mouse moved but the games don't start and the system does not respond to any keyboard input. The only thing I can do at that point is to reset the machine.
     
  6. uidepara

    uidepara

    Messages:
    126
    Shared folders do not work! Any clues?
     
  7. glyphrunner

    glyphrunner

    Messages:
    2
    Parallels 3 Build 5626
    Mac OS 10.5.6
    iMac 2.33GHz Intel Core 2 Duo
    3GB 667 MHz DDR2 SDRAM

    Currently running an XP and Vista install on an external firewire hard drive without any issues.
    Attempted to install Windows 7 using Typical and Custom settings. Tried the different suggestions in this thread (OS -> Windows Other, OS -> Windows 2008, OS -> Windows Vista), using 32GB and 65GB disk drive space (both dedicated and expanding). Run it from DVD and ISO.

    Nothing works. Start the installation and it crashes Parallels... every time.

    I'm reluctant to place this on my system's main drive, and I have no desire to upgrade to Parallels 4 since they *still* haven't gotten my games to work on any version of Parallels.
     
  8. Mike Boreham

    Mike Boreham Kilo Poster

    Messages:
    205
    I installed the 32 bit version with no problems, but the 64 bit sound didn't work at all. When I installed the 32 bit version Windows update downloaded a sound driver update, but the 64 bit version didn't.

    The sound controller is shown as a "Multimedia audio controller" with a yellow triangle next to it. Update driver can't find a driver, and uninstalling it and redetecting it is the same result.

    I downloaded and installed Vista AC97 64 bit driver from:

    http://www.download3k.com/files/6285_Vista_APO.zip

    With this the sound works but is horribly distorted. The device manager now shows it as an AC 97 controller but can't find a better update.

    Can anyone who has achieved good working sound in the 64 bit version please say more specifically how they did it?

    Thank you very much.

    Mike
     
  9. tinyblob

    tinyblob

    Messages:
    4
    I'm having the same problem as some people here - after installing the parallels tools i can't run certain applications (like the windows games) without the whole OS freezing.
     
  10. VintageGeek

    VintageGeek

    Messages:
    29
    Windows 7 Installed w/o Issues Other Observations P4

    I downloaded the Beta today but updated my Parallels v4 to the latest version first (which went extremely well on my MacBook). Parallel Tools started automatically and installed with out issues too. Windows 7 runs very nicely, Speed is good and programs seem to run for the most part. Nice thing about the 7 vs Vista was how nicely it attached to the Net. This was a nightmare under Vista. I have no audio for Windows 7 under Parallels 4 so far but that will probably come soon. I've tried a number of Video Players: Windows which seems to play avi ok but no audio. I downloaded Quicktime and VLC Player also. Both installed w/o issue but would not run either video or audio. In fact Quicktime locked up the VM. Only way out was to quit Parallels itself. Just my observations so far. Oh, one last thing. IE 8 in Windows 7 is lightning fast on the net. Quite a surprise.
     
  11. ebaydan777

    ebaydan777

    Messages:
    7
    i wanted to install windows 7 on my 2.4 imac (aluminum) with leopard already on it

    currently i have xp on it, would i be able to upgrade xp into windows 7 with the .iso from microsoft or create a whole new virtual machine just for windows 7 and delete xp?

    also is there anything i should worry about in doing this or would it be a clean install?
     
  12. VintageGeek

    VintageGeek

    Messages:
    29
    Aero Peek in Windows 7 on Parallels 4

    I haven't been able to get the Aero Peek (taskbar open apps preview) capability to work. The trouble shooter says its a video driver issue, which is what I expected since everything is an early release. Just curious if anyone has found a workaround to get this feature to work???
     
  13. MissionMan

    MissionMan

    Messages:
    11
    Live Messenger works in VMWare so its definitely a Parallels issue that is hanging Windows 7 after installing Live Messenger.
     
  14. tinyblob

    tinyblob

    Messages:
    4
    I've just encountered exactly this issue - now that Live Messenger is installed, the OS just freezes up on boot.

    I rebooted in safe mode, and used the system restore functionality to return to a point prior to installing Parallels Tools.

    I can now start up the windows games which previously crashed the OS. The interesting thing is that upon running, say, Mahjong, i get a pop-up explaining that the graphics hardware acceleration isn't functional - Parallels Tools installs a video driver, so i imagine the problem lies here!
     
  15. ekohn00

    ekohn00 Bit Poster

    Messages:
    8
    Does anyone know how to activate Windows 7 Aero Glass UI?
     
  16. tinyblob

    tinyblob

    Messages:
    4
    Just a quick note for anyone having a problems with certain apps freezing the OS (as mentioned above).

    Disabling 3D acceleration resolves this issue. I couldn't find any setting within Windows 7 to do this, so i did it in Parallels.

    Some apps pop up a message explaining that 3D acceleration has been disabled, but they appear to work perfectly - and Windows Live no longer freezes the virtual machine.
     
  17. uidepara

    uidepara

    Messages:
    126
    Shared folders, Aero, Games, Audio

    Aero and Games: As long as Parallels does not provide a WDM video driver with all capabilities Aero and Games that use extended video functionality won't work.

    Audio: I installed the driver from the attached package. It won't work. But afterwards I could download a WDM driver via Windows update that works perfectly.

    Shared folders: I'm not able to get shared folders running. Every time I try to connect to a \\.psf storage I get an error message. Help needed!!!
     

    Attached Files:

  18. trustme99

    trustme99

    Messages:
    6
    When I installed Windows 7 I disabled the audio controller. Later I shutdown the VM enabled audio then when Win7 rebooted it used Windows update to install and audio now works.
     
  19. Mike Boreham

    Mike Boreham Kilo Poster

    Messages:
    205
    Thanks,

    Was this with 64bit or 32bit ? I have had no problem with 32 bit sound, but can't get sound to work in 64 bit?

    I have tried uninstalling the driver in Device Manager which causes it it search for a driver (unsuccessfully) on reboot.

    When you say you "disabled the audio controller", do you mean in Device Manager in Windows or Parallels Configuration?

    I assume the latter because when you say you enabled it before rebooting. I'll try what I think you did. Thanks for any clarification.

    Mike
     
  20. trustme99

    trustme99

    Messages:
    6
    32 bit. And yes I disabled the audio in Parallels Configuration. Best of luck.
     

Share This Page