Windows 7 VM screen freezes after resume from sleep

Discussion in 'Windows Guest OS Discussion' started by jkwuc89, Feb 8, 2010.

  1. LeonardF

    LeonardF

    Messages:
    3
    Parallels Freeze after Sleep Solved

    I purchased a new MacBook Air 13" running OSX Lion this summer, with Parallels 6 and Windows 7 Ultimate, and I experienced the same problems as other writers in this thread. One consistently reproducible problem was to start MS Word with Windows 7 running in full screen mode and then close the lid of the computer or make it sleep from the Apple menu. The whole machine would always freeze. I opened up a support request to Parallels and I was advised to upgrade to Parallels 7. That solved the problem with Word and the request was closed.

    Later on, however, I experienced the computer freezing intermittently on resume from sleep with Parallels running when the computer was asleep overnight. Recalling what happens with my Windows 7 laptop when I close the lid, it occurred to me that the problem might have something to do with the hibernation mode. The Windows 7 laptop goes into a shallow sleep for a brief period and then, if it is not reactivated, it goes into a deep hibernation in which the contents of the memory are written to disk and power to RAM is cut off. It occurred to me that something like that might be happening on the MacBook. Parallels was resuming just fine if the computer was brought out of sleep immediately, but it was freezing if the computer was allowed to sleep for more than an hour or so.

    Investigating OSX sleep modes, I discovered that there is a similar form of hibernation on the Mac that is enabled by default and that writes the contents of RAM to disk. My solution was to change the sleep mode of OSX from mode 3, which is the default mode on computers after 2005, to mode 0, which keeps the RAM powered up until the computer wakes. Instructions for doing this can be found here:

    http://www.macworld.com/article/53471/2006/10/sleepmode.html

    After making this change I have had no further problems with the computer freezing after resuming from sleep with Parallels running. The disadvantage of this solution is that the computer sleeps in a higher power sleep state, which causes more battery drain, and if the battery does fail then anything in RAM is lost. But I consider that a small price to pay for being able to make my MacBook sleep without shutting down Parallels.

    I have no idea what Parallels support is currently saying about this problem. I haven't contacted them about it. But I can report that this solution works for me. I've been using it for a couple of months now with the setup described above: 2011 MacBook Air, OSX Lion, Parallels 7 in full screen mode, Windows 7 Ultimate.

    The only other problem I've experienced is a problem with the Windows 7 taskbar. After several sleep-resume cycles, closing a program leaves the taskbar icon for that program still highlighted, and reclicking on the icon will not reopen the program. The only solution is to reboot Windows. On the MacBook Air, with its solid state hard drive, this is fairly quick. But it is something Parallels ought to look into.
     
  2. KennethF

    KennethF Bit Poster

    Messages:
    50
    Thank you!

    I have pretty much the same setup as you, except using XP and Coherence instead of Full Screen and 7 Ultimate. I've been having the freezing problem consistently since I got the machine and it has been driving me crazy. I've searched for discussions of this to no avail until now. When I remembered, I was pausing the VM before I closed the lid, but sometimes I forgot, and invariably the machine was frozen when I opened it up.

    I made the change you suggested yesterday, and (knock on wood) the machine has NOT frozen again. I'm glad to be past that annoyance, but the Parallels folks should certainly fix whatever is the problem.
     
  3. LeonardF

    LeonardF

    Messages:
    3
    You're Welcome!

    I'm glad it helped.

    LF
     
  4. DHarman

    DHarman

    Messages:
    21
    The problem with that 'fix' is that you are now having to use the less battery efficient suspend. Not really a compromise I like.

    So I moved to fusion and guess what it has the same issue! At least vmware doesn't have the process that spams my cpu!
     
  5. ArkadyK

    ArkadyK Bit Poster

    Messages:
    1
    xp guest os freezes after sleep , laptop close

    Super annoying ! Any resolution to this ? Running Desktop 7 build 150055 and windows xp on an old Macbook
     
  6. JPeterS

    JPeterS

    Messages:
    2
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
    Last edited: Jul 30, 2012
  7. JPeterS

    JPeterS

    Messages:
    2
    Use Win 7 setting to adjust Parallels energy scheme

    Had the same issue. My Win 7 would freeze (that is not wake up without freezing) if it had been asleep for more that one hour or so. The issue started after I updated to the latest version of Parallels - Build 7.0.15104 (previous to this update all was fine and I had no issue with Win 7 waking up from sleep).

    Found out that the sleep option from the Win 7 Start menu/button is not necessarily doing what you expect it to do -- that is: a sleep is not necessarily a sleep. This is because Parallels has particular settings which seem to override the action/meaning of the sleep option from the Win 7 Start menu/button.

    Parallels installs its own energy management option/settings/scheme. You will find those options under your power settings under your system settings in Win 7. You will find that you can specify and decide how windows should act as a response to a click on the Win 7 Start - sleep button. The particular action is adjusted by selecting the advanced options link and adjusting the behaviour for closing the computer’s lid or pressing the sleep button/switch.

    Now make sure that the options for closing the computer's lid or pressing the sleep switch only activates the sleep option and *not* the suspend option (sorry for not knowing the proper function name on Win 7 UK/US -- mine is in Swedish).

    This did solved my issue. I did not have to change any hibernation/sleep options on the mac side.
     
    Last edited: Jul 30, 2012
  8. Tony Z

    Tony Z

    Messages:
    4

Share This Page