windows 7 wont load, trying to boot from SATA drive 1

Discussion in 'Windows Guest OS Discussion' started by NeilMurphy, Mar 2, 2011.

  1. NeilMurphy

    NeilMurphy

    Messages:
    6
    I installed this a few weeks ago and it worked fine, most impressed. Then I had a system crash and now windos always fail to load on the black screen with the message "Trying to boot from SATA drive 1..."
    I tried to use mounter to load the pvm file, but it said it cannot do so; I tried to use mounter to on the hdd file, but its not in the finder where its supposed to be.

    I am increasingly of the opinion something has been deleted somehow and I will have to reinstall.
     
  2. NeilMurphy

    NeilMurphy

    Messages:
    6
    Update

    I viewed the pvm and did a 'show package contents' and found the hdd file there. I tried using mounter on the hdd file and got a 'cannot open' message.
     
  3. JamesOldfield

    JamesOldfield

    Messages:
    1
    Same problem here

    I have exactly the same problem. Mine crashed and then from then on I have not been able to start up the machine, it just says there is no OS. Also with Windows 7 and it had been running fine up until recently.
     
  4. NeilMurphy

    NeilMurphy

    Messages:
    6
    depressing

    Parallels suport have suggested various options to restart or repair it and nothing has worked so far.

    I suspect I will have to uninstall parallels and start again, or at least that particular VM.

    I will post here again if I manage to find a solution without doing that though.
     
  5. asfsadfa

    asfsadfa

    Messages:
    1
    Ok so I had the same problem. how you fix it is:
    try to start windows in a window, it'll hang on the trying to boot...
    in the bottom right of the window click the TOOLS icon
    go to boot order select CD/DVD as first (even if you use an image with the win installation cd)
    then go to the cd/dvd option and put in the connected & if you're using an image of the win cd select the image.

    click ok

    in the top of the mac screen go to the parallels menu virtual machine -> reset (or stop/start).
    it'll try to boot from cd click a key to start from cd if it asks to (do it before it shows 5 dots .....) otherwise it'll hang again trying to start from your hd.

    it'll go to the win installation cd. Go to REPAIR option. go to the command prompt.
    win xp -> run FIXMBR and FIXBOOT commands (google how to use them)
    in win vista / 7 -> BOOTREC.EXE /FIXMBR and bootrec.exe /FIXBOOT.

    both files were on a disk it created called X:\ but I think they can be found on the installation cd too.
    if you want to know where type
    dir /s fixboot.exe
    dir /s fixmbr.exe
    dir /s bootrec.exe

    i ran the /fixmbr and /fixboot options and now it starts again :)

    Cheers!
     
  6. Smeds

    Smeds

    Messages:
    2
    Awesome...

    It's been a few days of not starting up and I was getting frustrated... This worked like a charm.

    Just a clarification for others following these steps. To change boot order I had to stop my virtual machine, change the boot order, point the cd/dvd "connect to" option to my windows 7.iso file stored on my mac hard drive, and THEN restart the machine - no need for "reset" step.

    After it loads from the cd, click next, then repair (down at the bottom) instead of install, and it will take you to a menu screen with a few options. I tried to go rogue and tell windows to fix the boot errors on its own...didn't work. Just click the command prompt option like asfsadfa mentioned and enter the two commands one at a time and hit enter. It should say that "the operation completed successfully" or something similar after each command (also, yes, there is a space between "exe" and "/"). After that, start up your machine! Good as new! Thanks again asfsadfa!
     
  7. JuliaThorne

    JuliaThorne

    Messages:
    5
    Hi! This really works very smooth on mine. Had trouble about this. Thanks for sharing. [​IMG]
     
  8. Ryan81

    Ryan81

    Messages:
    3
    Need Help

    Hey guys

    So I am having the exact issue you are having. Even paid the $10 for email support - and I'm sick of waiting around for some help.

    I have all the same signs you were having. Go to start Windows and it pops up to a black screen where i can either Launch Startup Repair or Start Windows Normally. Of course starting windows normally doesn't work, and i can get to the Startup Repair. I go to the startup repair, select command prompt - and enter your bootrec.exe /fixmbr and then the /fixboot commands. They both say operation completed successfully (or whatever the exact response is).

    However, I go to restart Windows and no luck. Is there something special I am missing?

    One thing I'm confused on is an installation disc. I have one software disc when I purchased Windows 7. Would this have a .iso (image) file on it? That whole part confuses me. That's where I draw the line of being any sort of 'technical' haha... any help is much appreciated. Thanks in advance.
     
  9. Ryan81

    Ryan81

    Messages:
    3
    windows 7 .iso

    Where do you find the Windows 7 .iso file? I think that's where my problem is. I need to find the correct files for the bootrec.exe commands to actually work.

    Thanks, still having issues.....
     
  10. Ryan81

    Ryan81

    Messages:
    3
    completed tasks....but no fix

    I was able to get install CD to get recognized and boot up. Entered the bootrec.exe commands and got back operation successful responses. Is there a step after that? I simply shut down, and started up again from hard disk and it didn't work. I even tried to start up from DVD and it didn't work.

    Looks like I may have to start all over. No good...
     
  11. LeanneB

    LeanneB

    Messages:
    1
    unsucessfull :(

    I followed the exact steps and received the 'completed successfully' prompts for both the fixmbr and the fixboot, however when I restart the VM, it still hangs at ''trying to boot from SATA drive 1'. Any additional thoughts would be greatly appreciated.
    Thanks!
     
  12. rippon

    rippon Bit Poster

    Messages:
    5
    No luck with this either. When I ran bootrec.exe /fixmbr Mac OS gave me a message saying that it had prevented the application from modifying the boot record on my drive.

    I had struggles getting Windows installed via bootcamp on my laptop as I have two internal drives and no optical media, but finally got it working. I have Mountain Lion installed on my second drive, a 120GB SSD, and Windows 8 installed on my main drive, a 500GB standard drive, which used to be my primary Mac drive until I added the SSD. I have several partitions on each drive:

    disk0s1: Microsoft Reserved
    disk0s2: Boot Camp - NTFS
    disk0s3: EFI
    disk0s4: An exFAT drive
    disk1s1: EFI
    disk1s2: Mac drive - Journaled HFS+
    disk1s3: 10.8 recovery drive

    I've tried manually setting the available partitions, even editing the Parallels settings files by hand with textmate to make sure they were pointing at the right place, but I always end up getting the message about trying to find the OS on sata1.
     
  13. rippon

    rippon Bit Poster

    Messages:
    5
    I tried installing Parallels on one of my other Macs that doesn't have a second drive installed, and it works just fine there. This definitely appears to be a bug, perhaps related to having multiple drives? Also noteworthy - Parallels reports my Boot Camp drive as being 0.0GB when I look at the settings for the virtual hard drive.
     
  14. rippon

    rippon Bit Poster

    Messages:
    5
    Upon even further investigation today, if I set the virtual machine to boot only from CD, I am indeed able to see my boot camp drive as the C: drive. If I have the boot order include the HDD, even if it's after the CD, though, it will not boot from the CD and it will continue to hang. Does the Parallels team even read these forums? I would have thought they'd at least have commented on this by now.
     
  15. sgtwicki

    sgtwicki

    Messages:
    2
    Me too

    I am having a similar issue getting Parallels 8 to work with my functional Boot Camp install. I have no problems booting into Windows 7 using either the Startup Disk preference pane or the option key after restart.
    After the initial setup with Parallels, it says "Upgrading My Boot Camp" for a long time stuck at around 20%, and then Parallels tells me "You need to log in to Windows to complete configuring your virtual machine". However, when I press OK I just get a DOS screen saying "Trying to boot from SATA drive 1..."
    Unfortunately, I can't use the method suggested by asfsadfa because I get a Mac OS error "Mac OS X has prevented the guest operating system from changing the boot loader on your physical hard disk."
     
  16. rippon

    rippon Bit Poster

    Messages:
    5
    Yeah, that's what was happening with me. Parallels support team was useless (You hear me Parallels support team? Stock responses to complex problems only make you look like idiots!). I ended up taking out my solid state equipment, putting my DVD drive back in and returning my Macbook to stock, migrating Mac OS back to my original drive, installing Windows via Bootcamp with a DVD, installing Parallels and setting up my VM, removing my DVD drive and putting my solid state drive back in, and copying the virtual machine profile back from the HDD onto my SSD.

    What I took from all of it is that Bootcamp Assistant seems to have serious dislike of trying to install Windows via USB on non-Air Macbooks. You can make it work by modifying a plist, and you can get Windows installed no trouble, but Parallels won't recognize the installation during bootup. Basically if you try to boot up to Windows and the boot menu doesn't call the drive "WINDOWS" (and render the label in an aliased Arial font, which I assume is a jab at Microsoft from the Apple EFI developers), Parallels probably won't go for it.

    But all that said, I ended up switching to VMWare :p Seriously Parallels, your support team doesn't seem to have any knowledge whatsoever. Pathetic.
     
  17. walden

    walden

    Messages:
    3
    Same Problem Here

    Same problem here. My BootCamp partition works perfectly for BootCamp, but Parallels 8 gets stuck at "Trying to boot from SATA drive 1". I'm using Windows 7 64 bit ultimate expensive edition.

    Tried the fixes suggested here, but like others, the Mac OS is preventing the repair utilities on the Windows DVD from making supposedly "necessary" changes to my boot-sector. Obviously the boot sector is perfectly good, or I could not boot into BootCamp directly, so this is clearly a Parallels bug and nothing else.

    About to go try Fusion instead. Better get this one fixed ASAP Parallels people...
     
    VenkatR1 likes this.
  18. Vanessa2

    Vanessa2 Bit Poster

    Messages:
    7
    Hi,

    Sorry to retrieve this post.
    I'm having a similar problem.
    Recently I transfer the pvm file to an external drive and it was working fine. Now, it says it does not have windows installed. I tried to change the boot order but I get the same message:
    "Trying to boot from CD-ROM drive... failed"
    "No boot device is available, press ENTER to continue".
    There is not Repair option.
    Any suggestions?
    Thanks,
    Vanessa
     
  19. Raj@Parallels

    Raj@Parallels Guest

    Messages:
    467
    Hey guys,
    The virtual machine does not start with an error " Trying to boot from SATA drive " follow this steps and let us know whether it works?
     
  20. CliftonY

    CliftonY Bit Poster

    Messages:
    4
    Hello,

    Please help. I uninstalled Parallels 9 and installed Parallels 12. Still getting the "Trying to boot from SATA drive." I'm not able to follow a lot of the complex suggestions here. Can anyone point me to a solution in plain English? Much appreciated!

    Clifton
     

Share This Page