Windows 8

Discussion in 'Parallels Remote Application Server' started by MIHFT, Mar 19, 2012.

  1. MIHFT

    MIHFT

    Messages:
    7
    I know that Windows 8 is only in CP mode; however, just thought I'd put it out there, that the 2X client doesn't seem to work with Windows 8 (so far).

    I can install and run 2X client; however, trying to run an app through the client does not work.
     
  2. woqz

    woqz

    Messages:
    180
    I don't think it can be listed as a supported platform up until a final release is out at this point
     
  3. data3oh

    data3oh Guest

    Aye, I'm not sure why it is not working, unfortunately I require the use of 2x and I am using Windows 8, I'm currently using a VM on Windows 8 so that I can use it.

    Is there any information available regarding the development of 2x Client for Windows 8. Mozilla is creating a Metro version of Firefox for Windows 8, is 2x going to do the same?

    It would be interesting to see or have a roadmap in any such development.

    I am however attempting to run 2x in Windows 8. If I have any success, I shall post here =]
     
  4. sclavux

    sclavux Guest

    I have the same problem, a've try:
    connect over local network to Windows 8 from 2x for iOS and Android, and over Internet with the same iOS and Android clients, and always blank screen
     
  5. jpc

    jpc Kilo Poster

    Messages:
    296
    @data3oh: The latest windows client should work Windows 8 (Pro, not RT though)
     
  6. iamthedan

    iamthedan Guest

    I'm having issues on Windows 8 Pro with the Windows 2X Client.

    After I install the 2X client, it performs wonderfully, even going so far as to place icons for applications in the start menu after connecting the first time.

    Unfortunately when I restart the machine after the install the machine seems to get caught in some sort of loop upon booting again, where a blue screen will start to appear but will flicker the display like it is refreshing. It is as far as I can tell impossible to continue on to Windows and try to resolve the issue, and my attempts to access safe mode also fail (thought that may have more to do with my BIOS, which is catching me rapidly tapping the F8 key and errors out, claiming it is a stuck key on the machine).

    The fastest way I have right now to resolve the issue is to load up the Windows 8 install media and perform a "Refresh" that automatically wipes the 2X client from the machine, as well as any other desktop-installed software.

    I initially thought this was an issue with the NVIDIA video drivers due to the 'flickering' nature of the screen, but I tried three different versions of their drivers and even disabling them entirely and I cannot reproduce this issue without the 2X client being installed.

    Running: Thinkpad T410, 64-bit Windows 8 Pro. NVIDIA NVS 3100M graphics.
    Installing: 2X Client for Windows 64-bit v10.5.1323
     
  7. mylargo

    mylargo Guest

    I recognized the same behavior on my Win8 Pro x64 maschine.

    I also get the flickering, when I used the power saving mode. Actually a no go to use 2X Client :(
     
  8. ajnadox

    ajnadox Guest

    Hi!
    I got the exact same error.
    There are really severe problems with the 2x client for Windows 8, we have been installing it on 3 different machines.
    Installation workes fine and we can add the connections BUT when we reboot the machine the system goes into a loop and windows cannot start or repair.
    The screen just flickers and we have the spinning weel, only solution is to boot the machine with installation media and repair installation so it removes the 2x client.
    We have great problems with this cause no one of our companys/clients can use 2x now and that is great trouble.

    Been trying with both intel and nvidia graphic cards but same error happens.

    RGDS André
     
  9. woqz

    woqz

    Messages:
    180
  10. Anonymous

    Anonymous Guest

    guys with this issue:
    are you using the candidate or the release?

    i tried it on the release on exactly 14 machines, and none of them gave me that behaviour.

    plus are your versions licensed? did you remove uac (i'm asking that as 9200 gave me some issues on permissions..)
     
  11. ajnadox

    ajnadox Guest

    HI!
    i´ve tested with latest version "Windows 64-bit v10.5.1323" that you can get from http://www.2x.com/rdp-client/windows-li ... loadlinks/

    Im running a fresh installation of windows 8 and i have not changed anything, just installing the client and rebooting machine. Login is made with "live" account not local
     
  12. jjgullo

    jjgullo Guest

    Exact issue as above .... Running fully licensed Windows 8 Pro on intel core2 platform (4 GB Ram) with NVidia GTS8-600 GPU. The 2x installs and connects to my PC at work just as it did on Windows 7. After installing 2x and rebooting my computer Windows 8 starts to boot (I see the initial 'cover screen' (prior to the login screen) for a fraction of a second and then my screen cycles between blue and purple screens and hard drive thrashes. Running windows 8 refresh brings my windows 8 back up, but I have to re-install all my apps. (except for 2x, until a resolution is found).
     
  13. woqz

    woqz

    Messages:
    180
    what build of Windows 8 are you running into this problem with?
     
  14. RajputSmurf

    RajputSmurf

    Messages:
    15
    We have the flashing screen problem as well. I have a licensed copy of Win8 Pro set up in a VM on my Win7 desktop and have installed both the 64 and 32-bit 2X clients and can confirm that if the VM goes to sleep or if I lock my Win7 machine I get the flashing issue and have to restart the VM. My colleague has Win8 Pro set up on his laptop as the primary OS and he got the flashing in the same situation as me when he installed the 64-bit 2X client but he does not appear to have the issue when running the 32-bit client. The flashing does not occur once the 2X client is removed and this was confirmed by three separate install/uninstall cycles so it is definitely 100% reproduceable.

    I'm not sure why mine does it with both clients but I do know that the client isn't completely uninstalling because when I remove and then reinstall it my settings are retained somewhere. We have overe 200 users and don't plan on migrating to Win8 as a company any time soon, if ever, but this issue would be a show-stopper if we were going to and it's problematic for those of us testing Win8.

    Edit: I rolled back to the 10.1.1275 version of the 64-bit client and am not experiencing the issue. My colleague is testing as well.
    Edit: While 1275 seems to be a bit more stable than the newest version insofar as you can lock the computer for some period of time without triggering the flashing, eventually locking again triggers it and you have to restart. I've had it happen three times today; once while it was open and idle for about half an hour, once when it had been locked for about an hour and once, just now, where I had been actively working for over an hour and locked it.
     
  15. rozenberg

    rozenberg

    Messages:
    26
    Hi there,

    When you are installing the client, are you installing SSO module also?
    Have you tried to go without SSO?
     
  16. RajputSmurf

    RajputSmurf

    Messages:
    15
    I have been using SSO so I'll try it without and see what happens. Sticking with 10.1.1275 64-bit just because I had better luck with it than with 10.5.1323 but if this makes any difference I'll try 1323 again.
     
  17. RajputSmurf

    RajputSmurf

    Messages:
    15
    I'm now on hour six without a crash so it is appearing that not installing SSO did make a difference but I don't know enough about that process to know what it might be. The other thing I did differently this time was to blow 2X out of the registry after the uninstall so I could get a clean reinstall but I don't know if that made a difference in the performance or not. I'm still in 10.1.1275 but tomorrow I'll try it with 10.5.1323 and see how it goes.

    Thanks for the suggestion!
     
  18. MIHFT

    MIHFT

    Messages:
    7
    Wow, this post is still going.
    Anyway, maybe someone knows a fix for this...
    Running Windows 8 Enterprise 64bit with the latest 2X client
    Except for one issue, all is working perfectly
    The one issue is SSO
    Installed the client with the SSO option; however, the SSO option "Use system credentials (SSO)" is greyed out and doesn't seem to log in unless I supply credentials
     
  19. RajputSmurf

    RajputSmurf

    Messages:
    15
    Possible stupid question but I have to ask: You restarted after the 2X install, correct? Just asking because even though SSO appeared to blow my Win8 up it was functioning on mine and the other two Win8 installs we tested and the only times I've seen it grayed out were right after an install or update where the user hadn't restarted their machine.
     
  20. woqz

    woqz

    Messages:
    180
    I tested this on Windows 8 ent at work too. SSO works fine after a reboot
     

Share This Page