Windows clock often goes "out of sync" for a few seconds

Discussion in 'Windows Guest OS Discussion' started by smartm1, Jul 11, 2017.

  1. smartm1

    smartm1 Bit Poster

    Messages:
    2
    I have a problem with the clock of my Windows: often, during the day, it goes ahead ot 2 hours. E.g., if it's 8:40 AM, the Windows clock goes to 10:40 AM, while the Mac clock remains at 8:40 AM. After a few seconds, the Windows clock returns to the correct time (8:40).
    I'm in the Rome timezone, UTC+2, so maybe the 2 hours shift is related to this.
    This happens several times during the day (every 1-2 hours) and it's quite frustrating because a couple of software that I use have some issues due to this.

    I already have the setting "Sync from MacOS X" in the Parallels options, as explained in this article: http://kb.parallels.com/en/113271
    I've already tried several networking settings (only shared network, only Wifi/ethernet), but nothing changed.
    Actually, also in the previous MacBook that I had up to some months ago, I had the same problem.
    I have all the software updated to the last version (Windows 10, MacOS X, Parallels Desktop).
    Do you what could cause this problem and if there is a solution?
     
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi @smartm1, have you reinstalled Parallels Tools for the virtual machine? If not, please start your virtual machine and go to Action( From Mac menu bar) and select "Reinstall / Update Parallels Tools" to fix the issue.
     
  3. smartm1

    smartm1 Bit Poster

    Messages:
    2
    Hi Paul, I've tried to reinstall the Parallel Tools, but the problem is still happening.
     
  4. europaa

    europaa Bit Poster

    Messages:
    1
    bootcamp trouble - clock jumps forward/backward intermittently
    0. the clock in windows / mac bootcamp jumps in hours from time to time, when (either booted directly into windows using bootcamp or) used the bootcamp partition as a vm in parallels
    1. check to see if the amount of the time jump coincides with your timezone offset (e.g., +9 hours from utc in korea)
    2. if yes to 1, the probable cause of the problem is that windows considers the system clock read from mac uefi as utc (i.e., greenwich mean time) - hence the time jump; windows tries to correct the clock by adding your timezone offset to the uefi system clock reading [* e.g., clock jumps ahead 9 hours if you have set your timezone as seoul (utc + 09:00)]
    3. this behavior can be corrected just by adding a registry value in windows:
    under
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation
    add a 32 bit value (DWORD)
    RealTimeIsUniversal
    and set it to 0
    (* or, of course, just set it to 0 if the value already exists)
    then reboot the windows
    4. this registry value tells windows to take the mac uefi system clock reading as local time (not utc); now windows stops trying to apply the timezone correction, hence no more time jumps in windows
    5. this had been giving me a headache for a few months up until yesterday; it seems okay now
    (* note: i'm using a bootcamp partition as a vm in parallels most of the time; it is possible that the registry value should be set to 1, not 0, when booted directly into windows because i've seen someone claiming that the actual mac uefi maintains the system clock as utc; the parallels-virtualized hardware, though, seems to store/retrieve it as local time)
     

Share This Page