Windows File Associations Not Working

Discussion in 'Windows Guest OS Discussion' started by joco, Jul 10, 2007.

  1. joco

    joco

    Messages:
    24
    Windows File Associations - Not Updating with Newly Installed Windows Apps

    I have read through many posts on similair problems. However, the issue I am having is that my Windows files never seem to associate with any programs that I install.

    For example, after I installed Acrobat on my Win XP machine, PDF files are still not associated with any application. Thus everytime I double-click an PDF file it asks me to select a program to open with.

    How can I allow Windows to properly associate files?

    BTW this happens with all my Excel (.xls) docs as well.

    Joe
     
    Last edited: Jul 11, 2007
  2. joco

    joco

    Messages:
    24
    Glad to see we get a prompt response for our issues.....
     
  3. Egurt

    Egurt Parallels Team

    Messages:
    24
  4. joco

    joco

    Messages:
    24
    I read that article, however I do not have SmartSelect turned on and now new apps that get installed DO NOT associate with ANY application. How do I restore my file associations and allow new apps to properly associate their files?
     
  5. Egurt

    Egurt Parallels Team

    Messages:
    24
    To restore your file association please start your Windows and in the "Applications" menu and choose Reset Windows Applications.
    In Windows side you can associate files with different extensions:
    1) Right click on required file.
    2) In the pop up window choose Open with-->Choose program
    3) Select the program from the list or add a new one.
    4) Enable "always use the selected program to open this kind of file" and click OK
     
  6. joco

    joco

    Messages:
    24
    Are you kidding? Of course that re-associates my files... but WHY is the file associations being prevented on install of new software?
     
  7. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,547
    joco,

    Could you please describe your environment and testcase once again - point by point?

    * Which version of Parallels installed?
    * Which guest OS installed?
    * Which particular application installed?
    * Where assosiations are lost?
     
  8. joco

    joco

    Messages:
    24

    Parallels Version: v 3.0 Builde 4128
    Guest OS: Windows XP sp2
    Application Installed: Any new app installed has this problem... currently Excel and Adobe Acrobat (see previous post)
    Associations are lost in Windows... everytime I install a new app (the last one was Acrobat) the PDF file extension never associated with the APP and I have to choose the app to open it with.
     
  9. Blogthis

    Blogthis

    Messages:
    4
    I have the same problem with build 4560.

    I'm having the exact same problem with file associations being broken by Parallels with Desktop mac 3.0 build 4560. Suggesting that I manually, by hand, try to fix every single file association out of the hundreds of them in the system, is out of the question and not going to happen.

    Also, I wanted to point out that when I complained of this bug to a few co-workers using this same version, they indicated this same problem is quote "the only thing that drives me nuts about parallels" --- so it isnt just us with this problem, it's a bigger problem than you think, just people aren't complaining about it so much yet.

    I sure hope this bug gets fixed soon.
     
  10. Kelvin

    Kelvin

    Messages:
    2
    I had the same problem with PDF files not being associated with Adobe Reader 8.1 after it was installed. I took the following extreme method of fixing the problem:

    - Backing up all important files
    - Uninstalling everything including Parallels
    - Deleting any remaining Parallels preference files
    - Reinstalling Parallels
    - Reinstall Windows XP virtual machine - custom install, then go to VM configuration prior to installation from CD
    - Deselect Folder Sharing and application sharing options (ie. SmartSelect etc)
    - Install Windows XP
    - DO NOT install parallels tools until all required applications are installed
    - Install parallels tools as final application install, using custom installation - turn off any option that involves sharing between Guest and Primary OS (eg application sharing, shared folders, drag-and-drop etc)

    This will lead to a VM completely isolated from the primary OS (as far as I know).

    I only need Windows to run a single SQL database client program, so I don't need sharing with the primary OS.

    Hope this helps.
     
    Last edited: Aug 8, 2007
  11. Blogthis

    Blogthis

    Messages:
    4
    bug acknowledged...

    From Parallels tech support, after a week of arguing with them....

    <deleted by spectre>
     
    Last edited by a moderator: Aug 9, 2007
  12. spectre

    spectre Parallels Team

    Messages:
    281
    This bug is under serious investigation currently and we would like to get any information available from the affected users to re-produce it in house. We'll do our best to deliver the fix in the nearest update, but I'd like to ask your co-operation on this.
    If you have a clear case on re-producing the problem (i.e. you know after what actions the bug appeared) or you are willing to upload your VM to us for investigation - please PM me.

    Blogthis,

    I'm sorry, but the information provided to you by our support engineer was a bit misleading, looks like she confused this bug with some other one. I've edited your post to avoid confusion.
     
  13. Kelvin

    Kelvin

    Messages:
    2
    Spectre, FYI I had the PDF association problem both with fresh installs of Windows 2000 and Windows XP. It would occur with new installations of the guest OS in Parallels 3.0 on default settings, followed with installation of Parallels Tools then Adobe Reader.

    Prior VMs set up in Parallels 2 and then upgraded did not have the PDF file association problem if Adobe Reader was already installed on it.

    Cheers
     
  14. jorge.buitrago

    jorge.buitrago

    Messages:
    5
    Same Issue!!!!!!

    I have the same problem; specifically I have Excel and Powerpoint Files associations in Windows XP messed up (I can open them, but when I open Windows Explorer, a file association called " xls_auto_file" or "ppt_auto_file" is showed up instead of the usual "Microsoft Excel Document" or "Microsoft Powerpoint Document"). BTW, for a weird cause, Word files are ok. That particular thing drives me crazy because: (i) when I'm working with an excel file open and I open another Excel file, it opens a different Excel window which isn't able to communicate with the previous one (not being able to reference cells from one file to another); and (ii) it affects the normal procedures of a financial software I have that works over Excel.

    Parrallels support team wrote me that they found it was their bug that was being fixed in Built 5060 Beta version. But it seems is not true at all, ‘cause I installed it, and haven’t been able to fix it.

    I’m posting my conversations with Parallels FYI.


    James. Thank you for you response. I downloaded your 5060 Beta Built, and installed it (by the way I liked the combination of Windows Programs in Expose). So far my problem remains the same. I understand that you found that it was a BUG in your software, affecting Excel and PowerPoint Associations (because Word files are OK). Can you tell me what is the procedure to correct it ???

    After installing Built 5060, I tried:

    1. Unistalled and then Installed Parallels Tools in Windows XP
    2. Used Parallels Desktop "Applications" menu - "Shared WindowApplications" - "Populate" option
    3. Used menu Applications->SmartSelect->Set to Default

    Thank you.

    I'll appreciate any help.

    Jorge Buitrago


    On 14/08/2007, at 22:15, Parallels Customer Service via RT wrote:

    Dear Jorge,
    Thank you for your information. It was our bug. We have already fixed it
    in our BETA version:
    http://www.parallels.com/en/download/desktop/beta/
    http://www.parallels.com/en/support/beta/
    --
    Best regards,
    James
    Parallels Customer Service
    http://www.parallels.com

    On Thu Aug 09 18:22:49 2007, jorge.buitrago@mac.com wrote:
    Hello. I made a support request seven days ago (5 business days ago)
    and I havent received any feedback from you. I hope you can help
    solve my problem.

    Thank you.

    Jorge Buitrago Escobar

    Begin forwarded message:

    From: Jorge Buitrago <jorge.buitrago@mac.com>
    Date: 2 de agosto de 2007 13:05:58 GMT-05:00
    To: support@parallels.com
    Subject: Re: [Parallels #187242] Issues with SmartSelect on Windows XP

    Robert, Thanks for your help. But I still have the same issue. I'm
    gonna give you a summary of some facts related to the problem so
    you might find a solution:

    - Windows Word files associations are OK
    - Windows PowerPoint and Excel associations are wrong (appear as
    "ppt_auto_file" or "xls_auto_file"
    - I uninstalled and reinstalled Office with everything on the
    Virtual Machine Options related to Smart Select unchecked ((i)Share
    Windows Applications to Mac (ii) SmartSelect (iii) Share Mac
    Applications to Windows)
    - Used Parallels Desktop "Applications" menu - "Shared
    WindowApplications" - "Populate" option
    - Used menu Applications->SmartSelect->Set to Default
    - Installed in another computer (MacBookPro), first build 4560,
    then windows xp, then office 2003. And it has the same problem.
    - Windows Office Files Associations were OK before update to
    Parallels Desktop 3.0

    I'll appreciate any help.

    Thank you.

    Jorge Buitrago Escobar

    On 2/08/2007, at 2:29, Parallels Customer Service via RT wrote:

    Hello,

    It looks like there is some problem with MS Office file extensions
    registration in Windows VM. Please try re-installing MS Office and
    see
    if it helps.

    On Mon Jul 30 14:50:10 2007, jorge.buitrago@mac.com wrote:
    Hello Robert.

    I tried what you suggested in the e-mail sent earlier today, but I
    still have problems with Excel and PowerPoint associations on
    Windows
    XP Guest System.

    I'll appreciate any help on the topic.

    Thank you.

    Jorge Buitrago Escobar

    On 30/07/2007, at 9:44, Parallels Customer Service via RT wrote:

    Hello Jorge,

    Try using Parallels Desktop "Applications" menu - "Shared Windows
    Applications" - "Populate" option to solve this problem.
    If it won't help please try re-installing Parallels Tools from the
    "Actions" menu. It's recommended to uninstall Parallels Tools
    beforehand
    from Windows Control Panel - Add/Remove Programs.

    On Mon Jul 30 09:42:17 2007, vladimirs wrote:
    Quote:

    Originally Posted by Andrew @ Parallels

    Brian,



    In build 4560 you can reset all file associations to default using
    menu
    Applications->SmartSelect->Set to Default. It should fix your
    problem.



    PS: If it won't help try to locate your VM folder in
    ~/Documents/Parallels/<VM name> and remove "Windows Applications"
    folder
    there.





    Andrew @ Parallels,



    I already updated my machine to build 4560, and used menu
    Applications->SmartSelect->Set to Default. It seems it fixed
    Mac OS
    associations problems, but I still have problems with Windows File
    Associations.



    I use Parallels @ work so I'm able to use Microsoft Office on
    Windows.
    My Word files associations are OK, but my Excel and Powerpoint are
    messed up. When I go to Windows Explorer, and I look the type
    column for
    an Excel or Powerpoint file, it appears and extension named
    "xls_auto_file" or "ppt_auto_file, respectively. It should appear
    "Microsoft Excel Document" or "Microsoft Powerpoint Document", as
    for my
    Word files which are working OK. Files do open OK on Excel and
    PowerPoint, but that particular characteristic, hampers my normal
    use of
    Excel and PowerPoint (e.g. moving between worksheets with keyboard
    shortcuts, using a Third Party software based on Excel, etc.).

    Please Help!!!! I waited all the way for build 4560, and it hasn't
    solved my problem so far.

    All this is getting on my nerves, is pretty frustrating. I will
    appreciate any aid ASAP!!!!!!




    Jorge Buitrago
    --
    Best regards,
    Robert
    Parallels Customer Service
    http://www.parallels.com



    --
    Best regards,
    Robert
    Parallels Customer Service
    http://www.parallels.com





     
  15. rkcarter

    rkcarter

    Messages:
    19
    Same problem with Excel and xls_auto_file association

    Mac OS X 10.4.10
    Parallels 3.0 build 5160
    Windows XP SP2 fully updated as of last week.
    Microsoft Office 2007 fully updated as of last week.

    I noticed that xls wasn't in the list of file types for Microsoft Excel that I could associate with Parallels SmartSelect for it. I then tried changing in Windows .xls from xls_auto_file to Open with: Microsoft Excel, and rebooted the VM and it still doesn't show up as associateable.

    Came out here and saw this thread, tried Application | SmartSelect | Reset to Default, but xls still shows in Windows to be associated with filetype xls_auto_file (and in Windows creating a new .xls file and clicking on it shows that it's an "unknown file type.")

    I won't bother reinstalling MS Office 2007 at this point, sounds like that doesn't fix it. Let me know if there's something that will, or info you can use from me to help fix it.
     
  16. akg

    akg

    Messages:
    2
    Same Issue with Excel 2007 and PPT 2007 File Association

    I have the exact same configuration as rkcarter and I'm having the same issue with Excel 2007 and PowerPoint 2007 file associations. For whatever reason Word 2007 is associating fine. Excel and PowerPoint files open fine when they are opened from within the respective applications. However, double clicking on saved Excel files doesn't open the files.

    The following process didn't work either because Excel 2007 wasn't listed as an option. I even browsed to the Program Files-->Microsoft Office-->Office12-->Excel icon and the Excel icon would never appear as an option to select.

    1) Right click on required file.
    2) In the pop up window choose Open with-->Choose program
    3) Select the program from the list or add a new one.
    4) Enable "always use the selected program to open this kind of file" and click OK

    This issue has been outstanding for three months. Parallels support team, when do you expect a fix for this?
     
  17. samepop

    samepop

    Messages:
    1
    Same issue... in networked macs through Airport Express

    Same issue... in networked macs through Airport Express

    Hi

    I just purchased 2 iMacs (20-inch, 2.4GHz Intel Core 2) and 2 MacBook Pro (MacBook Pro, 15-inch, 2.4GHz Intel).

    Setup:

    iMac
    Mac OS X 10.4.10
    Parallels 3.0 build 4128
    Windows XP Professional SP2 (Spanish)
    Everything works seamlessly, I then install Acrobat 8.1 and Office 2007 Enterprise (both legal copies) and everything still works fine.

    BUT when I install a separate license of Parallels 3.0 in my second iMac (networked wirelessly through Airport Express with exactly the same setup as the previous one, except for the Windows app, which is Windows XP Professionel SP2 - French), the VM gets installed but any single Windows application I install (Acrobat, Office, etc.) shows the "auto_XXX_file" extension.

    To make some checks, I repeated the procedure in one of the MacBook Pro... and everything works OK! But when I uninstall and try to check in the other MacBook Pro, with the FR setup, the extension problem arises again!

    I am going crazy. Why does it work seamlessly in 2 of my computers and it does not work at all in the other 2 ???

    Is it because they connect wirelessly through Airport? If this is a cause... why does it work in 2 computers but not in the other 2?

    Does the fact that one of the installs is Wind XP in French?

    Please help, I am going nuts with this all weekend!

    Many thanks in advance

    samepop
     
  18. Stan O

    Stan O Parallels Team

    Messages:
    69
    Hello!
    I have consulted our R&D dept. about the latter issue.
    They have this malfunction scheduled to be fixed in the next update.
    The issue has a high priority in our database.
    Thank you for the report.
     
  19. jorge.buitrago

    jorge.buitrago

    Messages:
    5
    Stan O thanx for your help. But this problem has been going on and on since you launched the smartselect feature (pretty long time). I have wrote you guys some e-mails regarding this issue, and everytime you reply me: a)"Yeah we aknowleged that. We're fixing it on next built"; b) "Go to applications menu reset, etc..."; or c)"Uninstall Office and Reinstall it". I've done everything you have told me and nothing works. And then I install every new built launch and the problem remains. Its very frustating. I hope this time you actually are working on something to fix it. I would actually uninstall windows and start all over, but the time and the cost of installing third party software based on Excel is too big. If it wasn't for the cost I would even switch to Fusion.

    Thank you.
     
  20. BenInBlack

    BenInBlack

    Messages:
    372
    hey jorge

    I feel your pain...

    I started with parallels way back, and in earlier days would even just run beta, I had some quirks with build 4560, but it was the most stable of the version 3 for me.

    I have tested 5160 and now am trying beta build 5158, it has been running better than 5160 but just locked up whole Mac, so no trouble report, to send in. I have narrowed down most of the problems to Smart Select.

    I have volunteered to be on beta, I have noted on many threads what I have done, they just came out with 5162 and this mentioned nothing about this issue.

    If I didn't have so much invested in Parallels, i would try fusion. I going back to 4560 and ill watch this forum for new features, or if they finally figure out to just dump the whole smart select...

    It's true, once the starter company sells out the heart leaves, and we are seeing that effect now.
     
    Last edited: Oct 15, 2007

Share This Page