Windows File Associations Not Working

Discussion in 'Windows Guest OS Discussion' started by joco, Jul 10, 2007.

  1. davew

    davew

    Messages:
    12
    xls_auto_file

    I am a first time Parallels user.

    Having just moved to an Intel iMac, with the express purpose of (a) booting up in Mac mode as normal for audio, email, internet etc but (b) running a virtual machine for all my Office applications, I am dismayed that Parallels appears not to recognise excel file extensions, likewise PDF - though .doc appear fine.

    I read that a Parallels fix is in teh making - when will this be available?

    Have other users found a way around this issue?

    Is VMware Fusion (or anything else) any better?

    Dang dang dang
     
  2. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello davew,

    Could you specify what you mean by "Parallels appears not to recognise excel file extensions, likewise PDF"? Please describe exactly what you do and what you see. Screenshots are desirable.
    What PD version have you installed?

    With the last update the following steps could help:

    1. When your VM is running go to Applications menu on the toolbar, choose Shared Windows Applications and click the Populate button. You'll see Parallels Shared Applications.

    2. On your Mac click with right mouse button any excel file and choose "Get Info". In the window opened after that choose "Open with" -> Excel -> "Change all".

    Waiting for your feedback.

    Best regards,
    Xenos
     
  3. davew

    davew

    Messages:
    12
    Xenos


    Many thanks for getting back to me.

    1. On the Windows file associations point:

    Simply:
    In my shared folder window of folder/files - Excel files “icon†does not appear on the left hand side; the file name is correct, but the file type is shown as: xls_auto_file (rather than “Microsoft Excel Document). Until just now, these files can only be opened, individually, by assigning (as prompted) excel to open them. But when saved and closed, they retain the “wrong†icon (not the X for excel) and also the xls_auto_file remains.
    I have now tried highlighting one of these files, right clicking to select Properties, and assigning to Excel. The result is that all the excel files are now recognised as excel and carry the X logo on the left hand side of the file listing. The odd xls_auto_file is however, still there, which is a puzzle;
    Applying the same principle above to PDF and Winzip files appears to make them all readily accessible too. Just the odd extra _auto_file remains after pdf or zip.

    So, prima facie, I think my problem with accessing the files is “fixed†but, given that word file types are readily accessible (without any intervention) and have a standard “Microsoft Word Document†description under “Typeâ€, I should be interested to know when there will be a formal fix. (I think my issue is the same as many others are facing?)


    2. Display Resolution

    I am running an iMac (2.8Ghz, 24†screen, 4 Gig Ram).

    My problem is that the script fonts in Windows are....â€faint and not very clearâ€. For example, the X icons next to the excel files are barely distinguishable. Words look very grey and spidery. In contrast, the Windows screen in boot up is black, bold and full of contrast, as I should expect from this machine (and as it is is Mac mode). I have run Parallel Tools and tried various Windows Display settings changes, but to no avail. Is there anything else you can suggest I do, either in Windows or Parallels? I haven’t used a PC for a long time, but I can’t believe that what I’m seeing is as good as it can get. Feels like it might some kind of interface or compatibility issue. (When prompted by Windows during set up whether I wanted to take up the offer of improving screen settings, I accepted).

    Any assistance would be much appreciated, since the whole idea of having and Intel machine was to enable parallel running, and a lot of my work will be done in Windows mode – as long as these two issues can be resolved.


    Cheers

    Dave
     
  4. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello Dave,

    For your first issue fixing please try the following:

    1. When your VM is on but Windows not running, go to Configuration Editor -> Shared Applications and put check in the box at "Enable SmartSelect". Start Windows.
    2. Go to the Applications menu and choose the "SmartSelect - Set to default" menu option to recreate file associations.
    3. After that click one of the buttons ("Only for this VM" or "For all VMs").

    You should press Apple together with Shift while clicking the button. This will make all your Mac file associations and Windows Applications folder with all applications removed.

    In 5 - 10 minutes please restart your Mac.

    For your second issue fixing go to Control panel -> Display –> Appearance -> Effects. Choose "Clear type".

    If this does not help, please send me your Display, Display settings and Device Manager screenshots. (To get to Device manager go to My Computer -> mouse right click -> Properties -> Hardware -> Device Manager).

    Best regards,
    Xenos
     
    Last edited: Nov 23, 2007
  5. angelday

    angelday

    Messages:
    11
    I'm having the same problem with 5540. Step 1 was OK, but 2nd step is greyed out. I don't get this part where I should restart my Mac. You mean for real? :-I
     
  6. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello angelday,

    Are you sure you've launched Windows before going to Applications menu?

    Best regards,
    Xenos
     
  7. davew

    davew

    Messages:
    12
    I still have the issue with Excel files.
    Parallels 5540: Office 2007 Ultimate: iMac 2.8 S 10.4.11

    Thus - even opening Excel 2007 and saving a new spreadsheet:
    (a) the spreadsheet file extension is xlsx_auto_file; (unlike say word files that are recognised correctly, as simpy .doc);
    (b) once saved, the spreadsheet will not open with a double-click in the finder window (folder I have created in the My Documents folder) I have to first open Excel 2007 and browse from there.

    Not as it should be, on either count surely?
     
  8. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello Dave,

    Please let me know, did you try the steps I proposed in post #24 before installing beta?
    Did they help?
    Did you try them on beta?

    Best regards,
    Xenos
     
  9. davew

    davew

    Messages:
    12
    Apols, I am actually on build 5162 - I have tried the actions at 24 but to no avail.
    Dave
     
  10. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Dave, please try this workaround:

    1. Start your VM, launch Windows
    2. Run Excel application
    3. Right-click Excel icon in the Dock and choose "Show in Finder".
    4. Right-click the Excel icon in the window that will open and choose "Get info".
    5. Remember the path and the name of the application.
    6. Navigate to any Excel document in Finder.
    7. Right-click this document and select "Get Info".
    8. Go to "Open with..." menu and select "Other..." menu item.
    9. In "Choose Other Application" box select Excel application (the one you have remembered in step 5).
    10. Press "Add" button.
    11. Click "Change All..." button.
    12. Close "Get Info" window.

    Now all .xls documents are supposed to be opened with Excel application.

    Best regards,
    Xenos
     
  11. davew

    davew

    Messages:
    12
    Step 3?
    I do have an Excel icon in the (Mac) doc - the MacOffice 2004 version.
    I'm wanting to sort the Office 2007 Excel out in my VM - right clicking the Excel icon in the toolbar at the foot of the Windows screen (in blue to the right of the Start button) only gives, Restore/Minimise/Close options.
    Dave
     
  12. davew

    davew

    Messages:
    12
    No response from you yet on Q32?
     
  13. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello Dave,

    Please sorry for the answer delay and for the confusion. For your VM you should try the following:

    1. Point to any Excel file
    2. Right-click it to open the menu
    3. Select "Open With" Menu item. Open With dialog appears.
    4. Select Excel application from the list or use "Browse" button and select the appropriate application.
    5. Put a check in the box at "Always use the selected program to open this kind of file".
    6. Click OK.

    Make sure you do not choose Excel for Mac.

    Best regards,
    Xenos
     
  14. davew

    davew

    Messages:
    12
    I have done as instructed a route I think I have tried before.

    1. Excel files remain show with xls_auto_file extension (even having been attributed to open with Excel 2007);

    2. However (any) excel file cant however be opened from any window (in Explorer etc) only by first opening Excel 2007 and locating it from there can it be opened. Surely I ought to be able to access directly from (the Windows equivalent) of Finder?

    3. If I do open Excel and access a file from the Parallels Shared Folder to work in Windows mode; then say save and close Windows; the
     
  15. davew

    davew

    Messages:
    12
     
  16. Xenos

    Xenos Parallels Team

    Messages:
    1,596
  17. davew

    davew

    Messages:
    12
    Third issue fixed with installation of build 5582.

    I have downloaded WAssociate 3.4.3 but haven't got a clue what to do with it? Can you help?

    Regards
    Dave
     
  18. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Dave, could you use the Guide?

    Best regards,
    Xenos
     
  19. davew

    davew

    Messages:
    12
    I've looked, but knowing nothing about "how Windows assigns properties to file name extensions through file types and classes" etc - I'm not confident about what I need to do, and am mindful of the caveat in the "Need to Know" section which says.."If you don't know anything about the registry and its HKEY_CLASSES_STUFF, advance with care". I'm sure you don't need to be a programmer to understand it but it feels a bit out of my league.

    Can you help me find a way in?

    Is this something that a new Parallels will fix?

    Cheers
    Dave
     
  20. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Dave, here is the only thing you should do:
    start WAssociate 3.4.3, type .xls in "Extension" field and choose Excel in "Application for Extension" field.

    Best regards,
    Xenos
     

Share This Page