Windows File Associations Not Working

Discussion in 'Windows Guest OS Discussion' started by joco, Jul 10, 2007.

  1. Wittaya

    Wittaya

    Messages:
    2
    I still found this bug on Parallels 4.0.3810!

    I use Macbook Aluminum Late 2008 2.4 Core2duo. (Default spec)
    My MacOS 10.5.6 has iLife'08, iWork'08, Office for Mac 2008 and Adobe CS3 installed.

    I create a new VM with the custom option so I disable ALL Shared Application features (including SmartSelect) BEFORE I install the Guest OS.

    After that I install Windows XP Pro SP3 (Original MSDN CD Version) (FRESH INSTALL)
    then install a Parallels Tools.

    Once Parallels Tools is installed, I saw hundreds of _auto_file in the Folder Option > File Types
    For example .doc, .docx, .xls, .xlsx, .ppt, .pdf, .psd etc. (which are all file extensions that MacOS known)
    and also in regedit HKEY_CLASSES_ROOT

    The "Parallels Shared Application Folder" in Windows XP Start Menu has hundreds of Mac application shortcuts.
    (Disabled ALL Shared Application features in the configuration is mean-less)

    No matter I install Acrobat Reader 9.1 or Office 2007, these applications cannot register their file extensions anymore because of Parallels pre-registered _auto_file.

    I tried to delete these _auto_file from "Folder Option" and "regedit" manually one-by-one.
    But it not so convenient, take a lot of time and easily to make a mistake which harmful for the OS.

    Many user have experienced with this bug, please fix it asap.
     
  2. camealy

    camealy

    Messages:
    11
    I have the same exact problem with 4.3810 with x64 Windows. Regardless of what choices you turn on or off in the VM configuration all available Mac apps get populated as extension handlers in Windows. After using Fusion for almost 2 years, this is a huge problem for those of us that want our Windows environments isolated....

    Does Parallels even know about this issue???
     
  3. Robert Snider

    Robert Snider

    Messages:
    1
    How I fixed PDF file associations

    I had this problem of Acrobat PDF files not being recognized in Windows after installing a Boot Camp partition to run Windows XP. I set up the boot camp partition, and set up my Parallels 4.0 virtual machine to use the boot camp partition for the hard disk. Then, I installed Adobe Creative Suite 3 Web Premium, which includes Acrobat 8. As part of the installation, I got updates from Adobe Updates (over the web), which were installed. After all this was done, I noticed that PDF files had some generic icon and double-clicking them would give a message that Windows didn't know what program to run.

    Here's how I solved it, based on the information from John@Parallels and other web sources. The correct icons for PDF files were restored, and they open correctly when double clicked. I had Adobe Acrobat 8 Professional version 8.1.3 and Adobe Reader 9 version 9.1.0 installed. Although I have Parallels 4.0 installed on my Macbook, I did this all after booting natively to Windows from the Boot Camp partition. In other words, Mac OS X wasn't running.

    If you are new to editing the Windows Registry, I recommend you back up your system just in case a mistake is made.

    1) Run REGEDIT (Start, Run, regedit).
    2) Find the key HKEY_CLASSES_ROOT\.pdf
    An easy way to do this is to click on the top My Computer item in the left pane, and choose from the menu Edit, Find. Type in .pdf in the box. It should take you to this key. Be sure to confirm you have found key "HKEY_CLASSES_ROOT\.pdf" which will be displayed in the status bar at the bottom of the Rededit window.
    3) Edit / Rename this key to .pdfbad or something or, if you are brave, delete this .pdf key (including its sub-keys).
    4) Run your Acrobat or Adobe Reader program.
    5) Note: after this step you will have to restart Windows. From the program menu, select Help / Repair Acrobat Installation (or Repair Adobe Reader Installation). It will run for a while. It will allow you to restart after it is finished.
    6) Restart Windows.

    To change which program is the default when double-clicked (I have both Acrobat and Reader):
    Right click on a PDF file in Windows Explorer.
    Click Properties.
    If the program shown in Opens With is not the program you want, press the Change button.
    Select Acrobat or Reader, or another program as you wish.
    Verify that the checkbox "Always use the selected program to open this kind of file" is checked.
    Press OK.

    If all is working OK, you can clean up by running Regedit again and deleting the renamed .pdfbad key.

    I hope this helps someone.

    -Bob
     
  4. Wittaya

    Wittaya

    Messages:
    2
    Thanks Robert but how about the other applications (eg. MS Office, Adobe CS, etc)?
    Do we have to fix these files manually one by one???

    I hope Parallels will fix "Parallels Tools for Windows XP" which is the root cause of this problem.
    Not just telling their customers to fix these auto_file associations manually by themselves.

    I upgraded my Parallels Desktop for Mac to 4.0.3844 (May 5, 2009) and this bug still ALIVE!! :-(
     
  5. AbedB

    AbedB

    Messages:
    1
    Just bought last week, problem remains...

    Fixed a few associations manually and it fixed the problem, do not relish the thought of finding and fixing all of them manually though...
     
  6. TonyRich

    TonyRich

    Messages:
    3
    go public

    I have had this problem and followed this thread for a couple of years. In the meantime, I have paid to upgrade parallels (they don't even deserve a capital P) and installed several updates and still the problem remains. Various people from parallels have posted responses describing workarounds that may or may not work (none have worked for me) and expect us to fix their software. Clearly, parallels don't give a damn about their users and don't intend to fix the bug in any new releases. What we need is for someone with clout (obviously not me) to go VERY public and describe what a crappy piece of software parallels is (or more correctly how parallels couldn't give a toss about their users). Actually, parallels is a good, and could be a great, piece of software if only the company could be bothered listening to their users and fixing a problem which should have been fixed years ago.
     
  7. solus

    solus Bit Poster

    Messages:
    27
    I also have dozens, if not hundreds of *_auto_file associations. This is really damn annoying. I have DISABLED all file connections between OSs. I don't EVER want to open a Mac app from within Windows, or a Windows app from within OS X. Parallels completely screwed up my Boot Camp partition.

    Reinstalling Office 2007 did not fix the association errors, nor did "repairing" it via their installer.

    Also, under OS X, when right clicking on nearly any file, the context menu includes options for "Open with" > "Run a DLL as an App -- <VM name>" ... for each VM I have under parallels. Often there are also Windows applications associations listed as well. For example, when opening the context menu on a GIF image, I get all the DLL entries as well as an "Internet Explorer" entry and a "Paint" entry for every VM installed. How do I get rid of these?!?

    I shouldn't have to manually remove this associations, because they should never have been created in the first place.

    How can I get rid of these associations under OS X, and get rid of the *_auto_file under Windows?
     
  8. paolod

    paolod

    Messages:
    1
    just to add some spice...

    Hi all.
    I just stepped in a new problem, but it is linked (I think) with the one discussing here.

    I have had no problem in the file association thing, and if I doubleclick on a .DOC file it is correctly opened in Word for Windows.

    However, I just connected to a network share, and even if the icon is shown correctly, by doubleclicking on it I get nothing, only the "zooming icon" happens.
    If I copy the very same file over the network, I can happily doubleclick on it and have it opened.

    Should I open a new thread, or is it something related with the problems discussed here?
     
  9. Shepherd

    Shepherd

    Messages:
    25
    Same issue for me with Parallels 4 last built.

    I created a new VM this way: ignore automatic detection, customize installation, in the last wizard window, clic on Terminate (not on Start).
    Set the VM before installing Windows (Vista Home 32 bit in my case) :
    - start VM in window mode,
    - disable file and profile sharing,
    - disable applications sharing (including SmartSelect of course),
    - then install Windows.

    Right after Vista installation, associations and file types were OK in Control panel -> Default programs.
    - I created a snapshot and installed // tools: they overwritten most of the file types and associations (reminder: files, profile and applications sharing were disabled).
    - I uninstalled // tools and returned to previous snapshot (file types were OK in Default programs).
    - I installed Office 2007 and Adobe CS3 Suite from DVD drive (the only device available anyway). All file types and associations (including icons) for these programs were OK.
    - New snapshot before installing again // tools: in my case, they didn't overwrite Adobe and Office file types.

    However this is only another poor workaround solution since :
    - Parallels tools changed many other file types/associations: can become problematic sooner or later,
    - we don't always have CD for installing software before // tools,
    - VM without // tools doesn't provide minimum requirements for installing too many important applications: InDesign, Illustrator for instance. Only Acrobat 8 and Photoshop CS3 were installed and I'm sure I will have trouble when I will complete with InDesign.
    Last but not least, if I wish to upgrade to CS4, minimum requirements will upgrade as well! It may be impossible to install any CS4 applications without // tools.

    Parallels should wake up! I switched to Mac recently and meet the same file types/associations issue both with Vista and Seven RC.
    IMHO Parallels is more user-friendly than Fusion but this association problem is really not acceptable. If fix is not offered quickly, many customers will get Fusion, especially when Seven will be available... very soon.
     
  10. VictorB

    VictorB

    Messages:
    1
    Same problem here

    Just bought MacBook Pro and installed Parallels Desktop - same problem as reported by other users. Can't believe this stuff goes on for years and not yet solved. Some specifics:

    - Windows XP autoinstalled into Parallels;
    - Disabled applications sharing and SmartSelect;
    - Tried that alleged fix (enable SmartSelect, restore to default for all applications via applications menu, disable SmartSelect and app sharing) -- no solution;
    - Ran MS Office recovery inside Windows XP;
    - Installed Adobe Reader;
    - Reinstalled Parallels tools;
    - Removed and installed again Parallel tools;
     
  11. Gavin Lawrie

    Gavin Lawrie Bit Poster

    Messages:
    9
    I've tried modifying the .jnlp association on a vanilla XP installation, with latest java installed (java 6_16). But java web start fails during initialisation (before it gets to point of launching the jnlp application). Very annoying... Is there anything else that needs to be set to get the Windows XP java webstart to load?

    Thanks in advance for any help.
     
  12. rc2009

    rc2009

    Messages:
    2
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  13. rc2009

    rc2009

    Messages:
    2
    Same problem and still no fix! Unbelievable Parallels! 3 years with the same very visible problem! Now that is crappy customer support and software development!
     
  14. Jason Heffner

    Jason Heffner

    Messages:
    4
    This is quite a bugger if you have Wine Helper installed. Every single app, doc, and lnk is associated with a mac program and not with the XP virtual machine.
     
  15. Jason Heffner

    Jason Heffner

    Messages:
    4
    SmartSelect doesn't change file associations

    on the latest 5.0.8898 Beta and still having the same issue. I finally turned off share mac applications with Windows but using SmartSelect to change each association back to Windows Explorer doesn't update the Windows XP client, and in fact reverts to the previous selection on reboot of the client. I also updated the Parallel tools to the latest version.

    It's a bit of a bugger if you have Wine Helper installed.
     
  16. Ryan Marsh

    Ryan Marsh

    Messages:
    5
    Wow, great job guys.

    You know you have a problem when people are writing apps just to work around bugs in your software.

    I'm completely pissed about this bug and I swear if VMWare performed better I would be using it. The moment that I get a better benchmark with Fusion I'm done with you Parallels. This is a joke!

    It is not OK to completely hose all the windows file associations on a computer just to support a feature in your VM EVEN WHEN THE FEATURE IS TURNED OFF.

    Would someone at Parallels confirm or deny that:
    1) They can reproduce this issue, and it is a bug.
    2) They intend to fix it or provide a suitable work around.
     
  17. wonder_mice

    wonder_mice

    Messages:
    202
    Hello, as I understand, there are several problems, related to file associations in this thread. Lets talk about every problem separately.

    1. Wine Helper and ".lnk", ".exe", ".com" files.
    Problem: if installed, Wine Helper (or several other Mac OS X apps, like "Unarchiver") will be set to open ".lnk" (and ".exe"/".com" on more recent versions) files.
    Solution: fixed in upcoming PD4 update
    2. Lots of "xxx_auto_file"-s
    Problem: When installing Parallels Tools before installing guest applications (such as MS Office, Adobe Acrobat and others) all file extensions that can be opened in Mac OS X receive xxx_auto_file type.
    Solution: fixed in upcoming PD4 update (xxx_auto_file will be created only for file extensions that are not known to guest).
    3. Shared Mac OS X Applications in gust even if "Share Max OS X apps with Windows" is turned off in configuration.
    Problem: Associations in guest always grabbed by Mac OS X apps, even if "Shared Applications" turned off. For some reason, it was possible in PD3 and PD4.
    Solution: Fixed in upcoming PD4 update. Guest file associations not changed after installing Parallels Tools if option "Share Mac OS X applications with Windows" is disabled.

    Ryan Marsh, I hope you find out that described problems are fixed in next PD4 update. Sorry for such bugs in previous versions. You can try trial version when it will be available.
     
    Last edited: Sep 24, 2009
  18. wonder_mice

    wonder_mice

    Messages:
    202
    In the next update for PD4, described bugs will be fixed :)
     
  19. Ryan Marsh

    Ryan Marsh

    Messages:
    5
    Thanks, so when is that update coming out?
    Also, is it possible to downgrade a VM from PD5 beta to PD4 or did I just shoot myself in the foot?
     
  20. wonder_mice

    wonder_mice

    Messages:
    202
    No, shooting is not a solution :) Backup (by copying folder, not by making a snapshot) your VM and try to use it in PD4 (don't forget to update Guest Tools). It should work well. In case of some problems you will have a backup.
    And you know, I can't talk about any dates or release/update plans :)
     

Share This Page