Windows Phone 7 beta emulator

Discussion in 'Windows Virtual Machine' started by jeffyjones, Jul 24, 2010.

  1. jeffyjones

    jeffyjones Member

    Has anyone running the Windows Phone 7 beta tools been able to get the emulator to run in a Parallels VM? So far I have not, and only with vague guesses about why that is. Apparently some people have been able to get it to run in that other VM product, but I don't want to go there.
  2. bertvh

    bertvh Bit poster

  3. bertvh

    bertvh Bit poster

    Just verified that it works on vmware fusion, although very slowly.
  4. bertvh

    bertvh Bit poster

    Works on Parallels 6

    Also, with the RTM version of the Phone 7 dev tools, the emulator starts quickly.
  5. jclermont

    jclermont Bit poster

    still not working for me in v6

    I upgraded to parallels 6 and installed the RTM Windows Phone 7 tools and the emulator still just sticks at boot. Anyone else have success?
  6. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    According to specification Windows Phone 7 emulator requires 2G of RAM.
    Our tests show that it works fine in PD6 with 1G of RAM in guest and doesn't work with less than 1G of RAM.

    Please ensure you assigned to VM at least 1G of RAM.

    PS: If you have just <4G RAM on Mac - please do not assign 2G to guest - it will significantly stress your entire Mac and performance will be bad.
  7. VarunM

    VarunM Bit poster

    Andrew, can you post the configuration and repro steps with which you were successful in getting the Windows Phone Emulator to launch? Also, how do you define success?

    On my machine I get the emulator screen with the message "Windows Phone Emulator is doing a complete OS boot..." for 20-40 minutes followed by a BSOD (DRIVER_IRQL_NOT_LESS_OR_EQUAL)

    My host machine is a 2.66GHz dual-processor dual-core Mac Pro with 6GB RAM.
    The VM is running Windows 7 RTM, with 2 processors and 3 GB RAM. Parallels and Parallels Tools 6.0.11826. Windows Phone Emulator x64 version 10.0.30319.

    I launch the Windows Phone Emulator from the Start Menu.

    Thanks for your help! I'm sure if we compare setups I can figure out what I need to do to get this whole thing to work!
  8. DmitriyB

    DmitriyB Member

    We have the same problem with Windows 7 x64 (Windows Phone Emulator x64), but with Windows 7 x32 VM Windows Phone Emulator works good.

    Configuration, which worked good on our side:
    Host: iMac 11,1
    4GB of RAM
    16 CPU
    Guest: Win 7 x32
    1 VCPU
    1 GB of RAM
  9. HakanA

    HakanA Bit poster

    I'm having exactly the same issue with my bootcamp VM.
    My configuration :
    Host : Macbook Pro 5,3
    8GB RAM
    2 Core
    Guest : Win 7 x64
    4GB RAM
    2 Core

    Are you working on fix for this bug ? I really need to develop Windows Phone application within Mac OS X.
  10. alev

    alev Parallels Team

    Hello, HakanA!

    We are working on this issue.
    You could use Win 7 x32 as a workaround.
  11. strandborg

    strandborg Bit poster


    Are there any updates to this?
  12. alev

    alev Parallels Team

  13. AbbeyS

    AbbeyS Bit poster

    It seems that this issue has been resolved.
    Last edited by a moderator: Sep 23, 2018

Share This Page