"windows roots\system32\hal.dll is missing or corrupted" - can't run bootcamp direct

Discussion in 'Windows Guest OS Discussion' started by John Boyd, Oct 27, 2007.

  1. John Boyd

    John Boyd

    This thread was moved from "Parallels Workstation for Windows and Linux->Windows Guest OS Discussion".

    I am running Windows XP Home edition under parallels build 3214 on a Mac Book Pro 2ghz machine.

    OS 10.4 is running on one partition and windows is running on the other.

    I can boot into XP under parallels no problem and until today I could boot into XP using bootcamp directly.

    Today I tried to boot into XP directly through bootcamp and received an error screen telling me that windows roots\system32\hal.dll is missing or corrupted and must be reinstalled.

    I have checked for the file and it is where it should be.

    I also checked my boot.ini configuration, which is as follows:

    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)WINDOWS=Parallels configuration /fastdetect /NoExecute=OptOut
    multi(0)disk(0)partition(3)WINDOWS=Microsoft Windows XP Home Edition /noexecute=optin /fastdetect /kernel=ntkopvs_.exe /hal=halopvs_.dll

    When I click on check all boot paths in the boot.ini window I receive the following message:

    It appears that the following line in the BOOT.INI file does not refer to a valid operating system: multi(0)disk(0)partition(3)WINDOWS=Microsoft Windows XP Home Edition /noexecute=optin /fastdetect /kernel=ntkopvs_.exe /hal=halopvs_.dll Would you like to remove it from the BOOT.INI file?

    Do I need to modify the partition value to 2 instead of 3?

    I hate the thought of reinstalling windows for fear that this will just occur again.

    Any suggestions for a fix?

    Does anyone know what causes the problem in the first place?
    Last edited by a moderator: Oct 29, 2007
  2. dglock2


    The problem is you are posting in the wrong forum! This is the windows/linux forum!

  3. Alicia

    Alicia Parallels Team


    John Boyd, your problem seems to be very similar to the one in this thread. Actually, you've already posted there, so it would be more useful to continue the discussion there too.

    Best regards,
  4. onceuponamac


    Corrupt hal.dll

    I've had this problem - i tried the fix in the support page. I could not boot in safe mode. I had to use the original Windows XP cd to boot - go into repair mode and then run "chkdsk" - this fixed the problem.

Share This Page