Windows Update

Discussion in 'Windows Virtual Machine' started by GummyDancer, Dec 8, 2007.

  1. ScottinMA

    ScottinMA Member


    I did exactly that last night and installed the custom build on 5582 as per your earlier post. I'm on bridged networks and will see whether the Windows updates will now install (hopefully). Thanks for all your help.

  2. Xenos

    Xenos Parallels Team

  3. ScottinMA

    ScottinMA Member

    Finally, the solution to the Windows Update problem

    I thought I'd share this thread as it solved my Windows Update problem.

    Below is what was posted by TaurArian where s/he presented the following solution much to my gratitude! When completing this procedure (step 2) I was able to successfully installed 83 updates that hadn't installed until this point.

    1. Do you have the latest WU client, if not follow this article -
    The Windows Update Web site and the Microsoft Update Web site do not scan
    for updates when you repair a failed installation of Windows XP Service Pack
    2 or of Windows XP Service Pack 1

    If 1 above is okay, then try re-registering some files:-

    2. Click Start, select run and type the following (pressing okay after each

    net.exe stop wuauserv

    regsvr32 wuapi.dll
    regsvr32 wuaueng.dll
    regsvr32 wuaueng1.dll
    regsvr32 wucltui.dll
    regsvr32 wups.dll
    regsvr32 wups2.dll
    regsvr32 wuweb.dll
    regsvr32 MSXML3.dll

    net.exe start wuauserv

  4. rumplestiltskin

    rumplestiltskin Bit poster

    Yep; bridged mode resolved the Windows Update problem. I seem to remember this same sort of issue (albeit not being able to connect to the Internet at all!) that was resolved with this same trick.

  5. Ross Dickstein

    Ross Dickstein Bit poster


    I am new to Mac and Parallels. I am using Desktop build 5600, win xp, mac leopard, and Kaspersky. I can download 7 updates from Microsoft update, but cannot install any of them, whether using shared networking or bridged ethernet.

    Can you help?

    Thanks, Ross
  6. bradsmith74

    bradsmith74 Bit poster

    @ScottinMA- I just wanted to thank you for posting that information here- it fixed the Windows Update failures that I was having.
  7. Albert Kashinski

    Albert Kashinski Bit poster

    Switch Back from Bridged to Shared

    Switching to Bridged worked for me through updating Windows XP Pro Service Pack 3. After that things hung up until I switched back to Shared, which then worked perfectly.
  8. IcefreakM

    IcefreakM Bit poster

    Good day everyone, I'm also having the same problem,
    I'm using the parallels7 windows for mac,
    at first, the update are downloading,
    when the time that the parallels prompt up and it need to upgrade,
    that was the time when the windows 7 updates where not able to continue downloading,

    I am using windows 7 ultimate 32bit,
    and for the apple i am using Mac OS X version 10.7.4 (Lion)

    and i am using a wi-fi for internet connection,

    I already try all the advises from this forum and also at the microsoft,
    but seems nothing happen,

    please see link for reference

Share This Page