Wireless networking hotfix in Beta6

Discussion in 'Parallels Desktop for Mac' started by Andrew @ Parallels, Apr 30, 2006.

  1. jeffmurphy

    jeffmurphy Bit Poster

    It depends upon how "close" the DHCP server is to you. If you are at home, your network looks (typically) like this:

    [WAP/DHCPServer] -----802.11----- [laptop]

    Since the DHCP server is adjacent to you, and the AirPort is running in promiscous mode, it works. It will see the reply packet ("dhcpoffer") with the virtual mac address.

    If you are in a hotel, at work, at school, then the network typically looks like this:


    When the DHCP server replies with a dhcpoffer to the custom mac address,
    the packet never makes it back to you because the custom mac address
    that the DHCP is trying to reply to has not been learned by the network.
  2. MicroDev


    Which VPN are you refering to? I traced a problem with Cisco VPN to DNS resolution that was failing. This only occurred when the Mac OS host was using the VPN. In Beta 4, this worked with a bridged connection (WiFi) but in Beta 5 it stopped working. To test to see if it's the same issue, do the following:

    1) Start up the host without the VPN and open the guest OS (XP in this test).
    2) Run nslookup from a command prompt in the guest.
    3) Enter the remote VPN host name. It should return an IP address.
    4) Try pinging the host name from the host and guest - it should work.
    5) Now go back to the host and establish a VPN session from there.
    6) Ping the VPN host from the host OS (OS X). It should work.
    7) Go back to the guest and try the lookup again - it should now fail.
    8) Try a ping from the guest - it should now fail.

    If this performs in the same way, it means that since beta 5 we can no longer have both the host and guest on independent TCP VPNs. If it doesn't work at all, ensure that both of the Parallels loopback adapters are disabled (removed) from the host network configuration. When these are enabled (in beta 4 on), it prevents the guest from establishing any VPN session.

    I have yet to try Beta 6 but will report back when I do.
  3. alkalifly

    alkalifly Kilo Poster

    Hi MicroDev, thanks for your reply.

    I am using the Cisco VPN client (version 4.9.000 for Macintosh). You are correct, the problem is only when the host is connected to the VPN client; the guest can connect to it just fine without affecting the host, but when the host connects, the guest loses its connection.

    I tested the steps you laid out, and it behaved exactly like you suggested it would, so at least now I know I am not the only one with this problem. I thought I had tried all of this with beta 4 as well, and that it didn't work back then either, but perhaps I did not really give it a full try until I was using beta 5.

    Any word from the Parallels folks on this? Not to disparage at all the GREAT job they have been doing keeping the betas improving and providing us with an extremely functional piece of software. However, the resolution of this issue will make PW function perfectly for me.
  4. nchaurdia


    yeah great software, but again if i can't connect at hotels...kinda pointless for me

    i know, its in beta, so i'll try it again at a later time. just wish there was some sort of work around

    Edit: Okay, it worked at the hotel now. I had to change it from host to en1 and now it works.
    Last edited: May 2, 2006
  5. alkalifly

    alkalifly Kilo Poster

    Could you possibly expand on that? What exactly was the "it" you changed? The more details you could provide, the more potentially helpful it could be for those of us still stuck.

    Thanks :)
  6. nchaurdia


    These are similiar, but DIFFERENT instructions:

    Make sure you have Airport connected to OS X.

    1. Turn on "host-only networking".
    2. Boot XP
    3. It will get a DHCP address from Parallels.
    4. Write down the address that it gets as well as the subnet mask.
    5. Open Control Panel -> Network Settings and double click on
    the Local Connection
    6. Click Properties
    7. Double click TCP/IP
    8. Change to "use the following IP address" and enter the address
    you wrote down, the subnet mask.
    To find the gateway address, open Terminal in OS X and type: 'ipconfig getoption en1 router' and your gateway address will be displayed

    en1 refers to Airport

    9. For your DNS type 'ipconfig getpacket en1' in Terminal in OS X and look for the line that says and look for the line domain_name_server. Those will be your two DNS servers.
    10. In OSX, Open the system preferences and click "Sharing"
    11. Click "Internet"
    12. Turn on sharing "from" "Airport" and "to" "built in ethernet"
    13. Close all your windows in Parallells XP, and then shut down. Now change your network settings from host-only to bridge, and select en1(Airport).

    Let me know how it goes. Thanks to Jeff for the earlier tips, without him I wouldn't have gotten mine working either. I'm no OS X expert at all, I just bought my first Mac less then a month ago) (Macbook Pro).

    Edit: Well, good news. I just bought Parallels :)
    Last edited: May 2, 2006
  7. daddygadgetdude


    Still no WiFi after Beta 6 Patch

    I installed the patch...still no WiFi...then even re-installed XP Professional (deleted original VM) and still no WiFi.

    I am using a MacBook Pro with 10.4.6 and am trying to connect to a hidden/encrypted network in my home off of an Apple Airport Extreme base station.

    I have gone through the network setup wizard a couple times with no success.

    Any additional suggestions?
  8. SFrawley


    Internet but no network

    I can get internet access via wireless, but no luck on any local machines on my workgroup or printers. No shared folders either

    Win 2k SP4 WinBook 2.0Ghz 2G RAM OSX 10.4.6 PW Beta 6

    I had network and shared printer access thru beta 5, albeit with driver warnings and problems with tools installation.

    I can send files to host under host only networking but no access to printers or any other part of net. I had to completely uninstall PW Beta 6 to even enable host only networking, which was completely disabled by the Beta 6 installation.

    I like the product a lot but Beta work can sure be tedious!:rolleyes:
  9. bmoody


    no activity on network connection

    I have te latest beeta 6 version on a 20inch imac. I am running XP sp1 and i'am having trouble with the network. I get a network card with a connection but it is not receiving anything. I have the wireless set as the bridged adapter. I am using dhcp. any help would be appreciated.
  10. Amos


    Wireless bridge not working for me even after hotfix

    Hello. I'm currently running the 1812.7 build of Parallels Workstation 2.1 Beta 6 for Mac OS X on a MacBook Pro with OS X 10.4.6. The guest OS is Windows XP Pro SP2 with all updates. I have reinstalled the Parallels Tools after upgrading from the original Beta6.

    Bridged networking over Airport used to work under the original Beta6 (first version I have ever used) but now Windows states that the network is connected but that it cannot obtain an IP address. This happened after resuming a suspended VM and persists even after rebooting the guest and host.

    I have a pair of networks that I move between. One consists of an Airport Extreme base station with WPA2 encryption turned on. The DHCP server is a seperate server on the switched Gb network that the airport LAN port is plugged into (bridged). The other is an Airport Extreme/Express WDS network that is not encrypted and the DHCP comes from the Extreme.

    I am currently experiencing the problem on the first network. I have not yet tried moving back to the second one.

    I have seen the host-networking workarounds and may give that a try. I just wanted to post and let the Parallels team know that the hotfix didn't work for me. I would be happy to try to help troubleshoot this for them if contacted directly by the team.
  11. Amos


    Hmm... here is a bit of debug info for you.

    After shutting down the guest OS, quitting Parallels, and then going home, I tried starting it all up again to see if the network configuration made a difference. At home (the non-encrypted wireless network that uses WDS and that gets it's DHCP from a base station) the bridge networking works.

    Does this have something to do with where the DHCP lives (on the BS vs on a server)? Maybe is has to do with the encryption (none vs WPA2)?

    I hope that helps you to figure out what is happening.
  12. ehall


    Can't find a hotfix - only the entire beta 6 dmg

    I must be blind 'cause when I follow that link, I don't see the hotfix. I only see the link to download the full beta 6. I went ahead and dloaded it and ran the installer and didn't seem to fix dhcp over wireless. I see the request and the offer from the server though they guest os doesn't take it.

    Am I missing something?

  13. joem


    Yes. There is no separate hot fix. Download the latest Parallels version and install it on top of the old one. Reboot, and it should work. At least it did for me.
  14. ehall


    Ooops, that worked joem, thanks! I am a new Mac user thinking that my rebooting-for-every-install-days are over. Forget that the dhcp kernel dirver of Parallels probably needs a reboot. I rebooted and all is well with DHCP over wireless now.
  15. levis


    Removing Ethernet Adaptor (en2)

    Hi all!!
    Can anyone please tell me how to remove the Ethernet Adaptor (en2) en the Sharing File internet options? I highlited it and clicked "Remove", the screen does a refresh, but this option doesn't desapear... I rebooted OS X, did everything again but nothing happened... I uninstalled Parallels Desktop and tryed to remove it, but the same thing happens... NOTHING!

    Can anybody help please?


Share This Page