With the latest 2X RDP Client, NLA is not working properly

Discussion in 'Parallels Client for Android' started by AndY5, Sep 23, 2015.

  1. AndY5

    AndY5 Bit poster

    I have the latest client (14.1.3379) 2X RDP client for Android installed on my Samsung Galaxy Note1. With the previous version of the client, I could connect to my computer, with Win8.1 installed and NLA (Network Level Authentication) required by the Group Policy, so I can't deactivate it.

    But with the latest version I can't, even though I have NLA enabled in Advanced Settings:


    I'm getting this error:

    Does anyone have any idea what could be wrong?

    Thank you for your replies!
  2. PaulChristopher@Parallels

    PaulChristopher@Parallels Product Expert Staff Member

    Hi AndY, are you using Windows 8.1? If so you can set the same configuration via Group Policies:1. Open gpedit.msc applet.2. Navigate to Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Security.3. Enable the Require use of specific security layer for remote (RDP) connections and select RDP as Security Layer.4. Disable Require user authentication for remote connections by using Network Level Authentication policy.

Share This Page