"would like to access files in your Documents folder."

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by EricG22, Aug 19, 2022.

  1. EricG22

    EricG22 Bit poster

    Messages:
    2
    Whenever I launch a windows app running under Windows 11 ARM Preview Edition, I get this message multiple times.
    I enabled Full Disk Access for Parallels on the Mac as well as enabling all folders (including Documents) under Security and Privacy on the Mac
    Any guidance?
     
    MatthewR20 likes this.
  2. Nazeemabanu@P

    Nazeemabanu@P Moderator

    Messages:
    196
    Hello @EricG22, Could you please uninstall the Parallels Desktop > Restart the Mac > install the Parallels Desktop for Mac > provide all the permissions again as mentioned in this link and check? Thanks.
     
  3. RonC9

    RonC9 Bit poster

    Messages:
    2
    I am having the same problem. I uninstalled/restarted/reinstalled/reprovided permissions as suggested, but every time I start Quicken from the Dock when a Windows 11 virtual machine is paused or shut down, I receive this message four times before the app will finally open. Any other ideas? This never happened with any previous edition of Parallels, though admittedly I just upgraded to Windows 11 from 10 and am now using an M1 Mac.
     
  4. RonC9

    RonC9 Bit poster

    Messages:
    2
    Upon further investigation, this only occurs when the Parallels Desktop app is not already running. In addition, if Parallels is launched even a split second BEFORE Quicken, there is no issue, but I can no longer simply tap Quicken in the Dock to launch the whole thing without those messages. This did not occur with my previous Intel Mac with Parallels 16 and Windows 10; regardless of whether virtual machines were paused or shut down, when Parallels Desktop was not active I could launch Quicken from the Dock, and everything would seamlessly "launch through" to Quicken being open.
     
  5. MikeD7

    MikeD7 Bit poster

    Messages:
    4
    I have this exact error. And it only appears with Windows 11 ARM on my Mac MBA M1 -- it does not appear with Windows 10 Intel on my Mac Mini 2018.
     
  6. JaredD2

    JaredD2 Bit poster

    Messages:
    1
    I'm also seeing this on my MBP M1. Uninstall and reinstall of Parallels along with the VM OS hasn't changed anything. Parallels team, this has to be an easy fix right?? Nearly every time I start a fresh boot session on my VM, I'm twice prompted to allow MacOS access My Documents. Saying OK does not stick and the next VM bootup prompts the same.
     
  7. BernardH

    BernardH Junior Member

    Messages:
    18
    I have the same problem on my M1 MacBook Air with Windows 11 ARM. Parallells Version 18.3.1 (53614)
     
  8. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    Messages:
    551
    Hello,
    As a possible solution, kindly follow the below steps:
    To grant Parallels Desktop full disk access and accessibility , you can follow these steps:
    1. Click on the Apple menu in the top-left corner of the screen and select "System Settings."
    2. In the System Preferences window, click on "Security & Privacy."
    3. Scroll down in the right sidebar and click on "Full Disk Access."
    4. Click on the lock icon in the bottom-left corner of the window and enter your administrator password to make changes.
    5. To add Parallels Desktop to the list, click the "+" (plus) button below the list of apps.
    6. In the file browser, navigate to the Parallels Desktop application. By default, it should be located in the Applications folder.
    7. Select "Parallels Desktop" and click "Open."
    8. Parallels Desktop will now be added to the list with full disk access.
    9. Scroll down in the right sidebar and click on "Accessibility."
    10. Click on the lock icon in the bottom-left corner of the window and enter your administrator password to make changes.
    11. To add Parallels Desktop to the list, click the "+" (plus) button below the list of apps.
    12. In the file browser, navigate to the Parallels Desktop application (located in the Applications folder).
    13. Select "Parallels Desktop" and click "Open."
    14. Parallels Desktop will now be added to the list with accessibility access.
    15. Close the System Settings window.
    16. Start your Windows virtual machine and Click Actions > Reinstall Parallels Tools. Once the process is completed, restart your virtual machine to apply changes.
      If the issue still persists, kindly reproduce the issue and collect a technical report (right-click Parallels icon in Dock > Help > Send technical data > check "Attach screenshots..." > press Send Report) and provide us with the report's 9-digit ID in reply to this post.(provide screenshot of error message as well)
    Thank you.
     
  9. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    Messages:
    551
    Hello,
    As a possible solution, kindly follow the below steps:
    To grant Parallels Desktop full disk access and accessibility , you can follow these steps:
    1. Click on the Apple menu in the top-left corner of the screen and select "System Settings."
    2. In the System Preferences window, click on "Security & Privacy."
    3. Scroll down in the right sidebar and click on "Full Disk Access."
    4. Click on the lock icon in the bottom-left corner of the window and enter your administrator password to make changes.
    5. To add Parallels Desktop to the list, click the "+" (plus) button below the list of apps.
    6. In the file browser, navigate to the Parallels Desktop application. By default, it should be located in the Applications folder.
    7. Select "Parallels Desktop" and click "Open."
    8. Parallels Desktop will now be added to the list with full disk access.
    9. Scroll down in the right sidebar and click on "Accessibility."
    10. Click on the lock icon in the bottom-left corner of the window and enter your administrator password to make changes.
    11. To add Parallels Desktop to the list, click the "+" (plus) button below the list of apps.
    12. In the file browser, navigate to the Parallels Desktop application (located in the Applications folder).
    13. Select "Parallels Desktop" and click "Open."
    14. Parallels Desktop will now be added to the list with accessibility access.
    15. Close the System Settings window.
    16. Start your Windows virtual machine and Click Actions > Reinstall Parallels Tools. Once the process is completed, restart your virtual machine to apply changes.
      If the issue still persists, kindly reproduce the issue and collect a technical report (right-click Parallels icon in Dock > Help > Send technical data > check "Attach screenshots..." > press Send Report) and provide us with the report's 9-digit ID in reply to this post.(provide screenshot of error message as well)
    Thank you.
     
  10. BernardH

    BernardH Junior Member

    Messages:
    18
    Unfortunately your solution did not help. Here is my technical report ID:
    429465530
     
  11. MarkF22

    MarkF22

    Messages:
    1
    This solution also did not help on Parallels 19 - submitted technical report ID: 435949575
    Terribly annoying every day but 2 clicks are not terrible.
     
    BernardH likes this.
  12. GraceG

    GraceG Bit poster

    Messages:
    2
    OS Sonoma 14.0
    This worked for me, modified:
    1. Click on the Apple menu in the top-left corner of the screen and select "System Settings."
    2. Click on "Privacy & Security" on left side.
    3. Scroll down in the right sidebar and click on "Full Disk Access."
    4. Toggle on "Parallels Desktop". (I also toggled on "Parallels Access", "Parallels Toolbox")
    5. Restart.
    *If you don't see "Parallels Desktop" in "Full Disk Access."
    1. Click on the lock icon in the bottom-left corner of the window and enter your administrator password to make changes.
    2. To add Parallels Desktop to the list, click the "+" (plus) button below the list of apps.
    3. In the file browser, navigate to the Parallels Desktop application. By default, it should be located in the Applications folder.
    4. Select "Parallels Desktop" and click "Open."
    5. Parallels Desktop will now be added to the list with full disk access.
    6. Restart.
     
  13. BernardH

    BernardH Junior Member

    Messages:
    18
    This did not work for me.
     
  14. GraceG

    GraceG Bit poster

    Messages:
    2
    Update: The above no longer works for me. I'm back to getting this message:
    "would like to access files in your Documents folder."
     
  15. RexG

    RexG

    Messages:
    1
    I also have this issue on Sonoma 14.2.1 I have tried all of the above - toggled this, toggled that, re-installed. No dice. What did work for me was RonC9's suggestion. I used to have a Windows 11 shortcut in the dock that, obviously, lunches Parallels, then Windows 11. Now I have set Windows 11 to automatically launch on Parallels launch. I now have a Parallels shortcut in the dock and I no longer get the annoyance but launch straight into Windows 11.
     

Share This Page