Writing curly brackets on Norwegian keyboard with parallels

Discussion in 'Installation and Configuration of Parallels Desktop' started by Milzit, Jan 29, 2012.

  1. Milzit

    Milzit Bit poster

    I have started to evaluate parallels with Windows 7, and I try to use Visual Studio,.. I have selected "Norwegian (Apple) parallels" as keyboard input in Windows. If I press ALT-SHIFT-8 in Lion I get "{" but I get nothing in parallels.
    Should I not get the same with this keyboard setting? Or should I use use some other settings? (The same apply to other special characters)
  2. Bekkalizer

    Bekkalizer Bit poster

    I had the same problem in parallels in windows 8, and made a support query. An engeneer called me and figured it out using the onscreen keyboard inside win 8 virtual machine: I have to use the right Alt key(AltGR in win)+Shift+8 and 9.

    It was not intuitive, as the left alt is working for curly brackets in native mac applications, i have to use the right alt key in windows.
  3. mrpotet

    mrpotet Bit poster

    I got the same issue, and have now re-mapped the left alt-key in windows to AltGr instead (the right key), but this has given me other issues, so looking for other work-arounds.
    But this hasn't been an issues for me until recently, after the latest Parallels update all my keybindings (have re-mapped keys in parallels to mirror OSX, curly etc.) got messed up :(
  4. BobR3

    BobR3 Bit poster

    I personally use ALT-GR+7 = "{" and ALT-GR+0 = "}" on a Norwegian keyboard.
  5. EdwardH15

    EdwardH15 Bit poster

    I just discovered that holding down Right-CMD + Right-option makes the number keys 8 and 9 return brackets! Thinking this key combination unlocks more.
    Of course, you need Shift to you get curly brackets, so touch-typing is out except for the supremely dexterous.

Share This Page