Wrong key assigned to the Alt key for the ERGO K860 keyboard

Discussion in 'Windows Virtual Machine' started by CarlosA29, Mar 6, 2023.

  1. CarlosA29

    CarlosA29 Bit poster

    I'm using the Logitech ERGO K860 keyboard, which has the keys "opt|start" and "cmd|alt". The keys work correctly on the Mac, but they are incorrect on the Windows guest. On Windows, the "opt|start" key has become the Alt key and the "cmd|alt" key has become the Start key. To try to solve this issue, I opened the Windows settings and deleted the default keyboard (that ends with "(Apple) - Parallels") and added the "US - QWERTY" keyboard. However, this didn't solve my problem. Any ideas?
  2. Maxim Rasulov

    Maxim Rasulov Staff Member

    This is likely related to the way keys get translated between systems.
    The keyboard has 2 modes, which are detected when you connect it to the respective system, or switch it using Logitech software.

    If you are using your keyboard in macOS and Windows virtual machine simultaneously, then the keyboard is in macOS mode, and "option" translates to "Alt" and "Cmd" translates to "Start" as it would with the Apple keyboard.

    You can try several approaches to resolve your issue:
    1. Switch the keyboard mode when switching systems. Then keys should swap their functions. However, this approach might also affect macOS side.

    2. Similar to previous approach, if you connect your keyboard to the virtual machine exclusively, it should identify the keyboard mode correctly, but would be unavailable from macOS side. If it does not, you may have to switch keyboard mode manually as mentioned in point 1.

    In the top menu bar of the running virtual machine -> Devices -> USB & Bluetooh -> "name of the wireless keyboard adapter".

    3. If you are always using the keyboard with your macOS\Windows, you can swap "Alt" and "Cmd" keys in Parallels Desktop shortcuts, and it should have the desired effect.
    However, please note, that if you stop using that keyboard and switch to an Apple keyboard, you will have to disable those shortcuts.

    1. Click on the Parallels Desktop icon in the Mac menu bar -> select "Preferences".

    2. Select "Shortcuts" tab -> select your virtual machine in the list on the left.

    3. Create a shortcut by pressing "+".

    4. In the opened Window, in the field "From" select the combination you would like to use, in this case "Cmd".

    5. In the field "To", select the combination you wish to trigger, in this case "Alt".

    6. Create a second shortcut "+" -> in the filed "From" select "Option" key.

    7. In the field "To" -> select "Win" key.

    8. Click "Ok" and close "Preferences".

    9. Check if your keys have now work.

    Let us know if we can assist you further.

    Have a nice day!
  3. CarlosA29

    CarlosA29 Bit poster

    Thank you for the detailed instructions. They worked for the most part, except that Alt+Tab doesn't work in Windows. It tries to switch my macOS applications, not my Windows applications. I added a new shortcut from Cmd+Tab (in macOS) to Alt+Tab (in Windows), but it still doesn't work. Any tips on this?

Share This Page