XP SP3 problem with Parallels 3 build 5638

Discussion in 'Windows Guest OS Discussion' started by RonJ, Jul 1, 2009.

  1. RonJ

    RonJ

    Messages:
    2
    I installed Service Pack 3 for XP this morning and now after the XP logo screen all I get is a black screen. The icons on the bottom of the Parallels window seem to indicate activity on the virtual hard drive and network port so I'm guessing something is up with how it's trying to display the video. A manual check of Parallels reported no updates waiting for it.

    The Mac is a G5 running the latest patch of Tiger. I'm running XP from an image file, not Boot Camp.

    What do I need to do?
     
  2. desgael

    desgael

    Messages:
    345
    Did you try loading Windows into safe mode? (Press F8 key during the boot-up process and choose Safe Mode from the list).

    If you would ber able to, you can try reinstalling Parallels tools the way it is described in the following article:
    http://kb.parallels.com/en/4848
    Since Parallels tools are managing Windows drivers for the devices, this can help with displaying the video.
     
  3. RonJ

    RonJ

    Messages:
    2
    Sorry for the delay responding.
    Booting into safe mode gets me as far as loading the AGP440.sys driver. I know this was an extremely common problem with SP3 on real PCs because of a mistaken assumption Microsoft made about graphics cards. And I know how to fix this problem on a PC (hopefully the same fix will work on a Parallels VM). At this point what I need to know is how to get the VM to boot from a CD or to at least recognize one as it's booting up.

    How do I do that?
     
  4. desgael

    desgael

    Messages:
    345
    I am not sure which version of Parallels do you have, but in Parallels 4.0 you would need to change the booting order in Configure -> Boot Order and in Parallels 3.0 this change can be made, as far as I remember, in Configuration Editor -> Options -> Boot order tab (to access Configuration Editor you would need to launch Parallels from Applications -> Parallels -> Parallels Desktop). In both cases virtual machine should be stopped to make the changes.
     

Share This Page