XP volumes not mounting in host MacOS

Discussion in 'Windows Guest OS Discussion' started by AlanN, Mar 27, 2011.

  1. AlanN

    AlanN

    Messages:
    4
    I successfully imported a physical XP SP3 machine into Parallels 6 on a brand-new Mac yesterday. I used the latest version of Parallels Transporter to do the import, over my home Ethernet network. So far everything seems to be working except that the XP virtual drives are not mounting, and are not even manually mountable, in MacOS.

    See attached screen shot for confirmation that the VM is configured appropriately.

    The physical XP machine had 2 physical hard disks, which were both successfully replicated in my VM.

    When I manually use Parallels Mounter to open the virtual disks from within Finder (while the XP VM is running), Parallels Mounter responds with:
    "Unable to get write access to the virtual hard disk. Do you want to open it in the read-only mode?"
    When I click "OK" I get the 2nd error message:
    "Parallels Mounter is unable to open the virtual hard disk.
    Either the hard disk has no volumes or its file system is not supported or contains errors. ..."

    When I try the same thing but while the XP VM is suspended (and I choose "Open to View"), or while it is paused, or while it is off (shut down completely) I get the same error message as the 2nd one quoted above.

    Within the XP VM I ran CHKDSK on both XP disks (with rebooting the VM), which found no errors on either virtual disk, and I still get the same errors from Parallels Mounter.

    The XP disks are NTFS and otherwise meet all these requirements:
    http://download.parallels.com/desktop/v4/docs/en/Parallels_Explorer_Users_Guide/23619.htm
     

    Attached Files:

    Last edited: Mar 29, 2011
  2. AlanN

    AlanN

    Messages:
    4
    Parallels on Snow Leopard needs MacFuse 2.19

    After much time spent with Parallels tech support, and then researching about MacFUSE, I mostly resolved this issue by installing MacFUSE version 2.1.9.

    The basic issue, as Parallels tech support admitted, is the alarmingly not-advertised fact that Parallels 6 as shipped does not actually run correctly on Snow Leopard (insofar as VM disks are not in fact mountable in the host OS), because Snow Leopard is a 64-bit operating system, and the version of MacFUSE shipped with even the latest Parallels 6 is an old version that does not support 64-bit OSes.
     
    Last edited: Apr 18, 2011
  3. BillG1075

    BillG1075

    Messages:
    1
    The 64bit Snow Leopard compatible version of MacFUSE is not available through the project website or other "official" channels. This fellow has kindly patched and packaged a working version of it:

    http://www.offthehill.org/articles/2010/12/31/macfuse-for-64-bit-snow-leopard/

    I tried it and it works perfectly. As noted previously, it's disappointing that Parallels is currently selling a product that is broken on the current version of OS X. I'd count the ability to mount Windows disks on the Mac desktop as a piece of core functionality.
     

Share This Page