XP won't run .exe file from a network drive

Discussion in 'Windows Guest OS Discussion' started by pop-pop, Feb 16, 2009.

  1. pop-pop

    pop-pop Bit poster

    I'm running Parallels 2.2 on Gentoo Linux with Windows XP SP3 guest.

    My setup includes a second VFAT partition accessed as D: with native XP boot. With XP as a Parallels guest, I defined a shared folder for that VFAT partition (which is mounted as /mnt/XP_Appls) and mapped it as a network D: drive.

    Everything is OK save for applications on the D: drive won't launch from a desktop shortcut. The disk activity light flicks a time or two then nothing happens.

    As a test, I was able to start SeaMonkey from it's folder on the D: drive but it was terribly slow. At least this should prove there is not a permission missing.

    For several years I had accessed this disk via SAMBA and all worked OK. Then Samba started to crap out intermittently so I tried the shared folder route and ran into this difficulty.

    I have Googled extensively and searched the Parallels forums and have not found any hints.

    Is there some subtle permission that Windows XP needs to execute from a network drive?
  2. AndreK

    AndreK Bit poster


    had the same issue with starting prgs from networkshares.. BUT you have to configure your windows sharing slightly better.. For me there is still a problem with networkspeed, but wil try to activate hypervisor support an reinstall ptools as read here in the forum.. Back to topic...

    - remove all shares! - There are some things to be done first off...
    - deaktivate "Simple file sharing", listed in the options of (file)explorer
    - Create the same user on all Windows-Hosts WITH (same) password
    - Give this user full rights to the folder u want to share - U can give better permissions later..
    - Open the file-sharing for desired folder an add this user with full rights to it
    - Map the networkdrive on the "guest" and use this user with password to connect to the share, even if it is the same user actually mapping the drive(!!)
    - For testing purpose deaktivate win-firewall. All should be fine now! First then it is time to restrict the access if needed.

    IF NOT:
    Reset the firewall to its defaults and try from step1. Maybe its a good idea to do this right from start(!?) just to be shure...

  3. pop-pop

    pop-pop Bit poster

    I fixed the problem shortly after I posted this problem last Feb but don't remember exactly what I did. Seems like I might have redefined the drives.

    Anyway, I'm weaning myself from Parallels since an update don't seem to be ever likely to happen and I did't like being stuck at a 2.6.24 kernel. I purchased Parallels primarily to run Quicken from my Gentoo Linux installation and have since found that Wine does the job adequately and is much much faster. A few other apps that I run via Wine are DeltaCad, Cutlist, and (don't laugh) calendar.exe from Winduhs 3.1.

Share This Page