You can migrate the selected volume(s) as data volume(s)

Discussion in 'Parallels Transporter' started by jabyuk, Apr 12, 2007.

  1. jabyuk

    jabyuk Bit poster

    Please, I hope somebody can help me! I am pulling my hair out with Transporter. I need to move over my Windows XP boot disc on my PC over to a Parallels virtual machine to work on my new Mac Pro.

    I installed the Transporter Agent (1080) on my PC and my Mac is running the latest Parallels Desktop (3188) with the built in Transporter (1080).

    I tried the express method of migrating the disc. After selecting the machine to migrate from, but before the screen with the list of drives, it threw up a message saying "You have not selected the active volume. You will be able to use the resulting image as data disk only". I clicked OK, thinking "that was odd, it didn't give me an opportunity to select the disc yet". I selected the C drive on the next screen. And it started. It took about 5 hours to complete on a 40GB disc. I thought it was very slow, but I didn't think too much of it. However, the speed was not the big issue.

    I realised it had created a .hdd file in my Mac's /~user/Documents/Parallels/Migrated Disks folder. But that was it. It hadn't made hardware changes to allow me to run it in Parallels Desktop for Mac. I didn't have the elusive additional Virtual Machine file. And I couldn't make changes to it using the Image Tool or in Desktop for Mac itself - it said "Applying hardware changes to the operating system Microsoft Windows XP is not supported".

    So I thought about doing it again. This time using Advanced mode. It gave me the list of drives with no error messages, but once I clicked Next it threw up the following message:
    "Applying hardware changes to the operating system Microsoft Windows XP is not supported. You can migrate the selected volume(s) as data volume(s). Do you really want to continue?"

    To which the answer of course is "no". I have also tried installing the full Transporter program on the PC itself in order to create the virtual disc file there. But the same error comes up at the same point.

    Causing me to think there must be something wrong with my install of XP. Does anyone have any ideas? It is not an OEM version. It is Microsoft Windows XP Version 5.1 (Build 2600: Service Pack 2).

    Any ideas or help will be very gratefully received!
    Last edited: Apr 12, 2007
  2. babelfishka

    babelfishka Junior Member

    jabyuk, -- you and I have apparently the same problem. I'm hoping that someone from the Parallels team can help. My assumption is that (for me), it's because my Windows System Folder is named "BFISHXP2" instead of "WINDOWS" or "WINNT" and the Transporter Agent doesn't recognize it as the bootable volume. (see my msg here from yesterday)
  3. jabyuk

    jabyuk Bit poster

    Hi babelfishka, thanks for your reply. I think you're right about your problem. It seems Transporter has a problem with anything that isn't named WINDOWS or WINXP.

    I don't have that problem myself - my version of XP is installed into C:\WINDOWS

    My current tack is that I'm trying VMware's free Converter application. It doesn't seem to have a problem making an image of my XP install. Parallels should be able to convert it to a Parallels VM. I'll post back soon and let you know if Parallels can convert it...
    Last edited: Apr 12, 2007
  4. jabyuk

    jabyuk Bit poster

    Well, the VMware image got one small step further in the Parallels Transporter wizard. It spent three hours doing something, then it went on to the screen I was expecting - do you want to boot from this, or use this as a data disc. Then it scanned it and said there was no operating system on that virtual drive.

    This Transporter software seems to be a pile of pap. I am trying VMware Fusion Beta at the moment, but I really want to get to the bottom of this.

    Please, if anyone has any advice, please post!
  5. jabyuk

    jabyuk Bit poster

    Well, I gave up earlier today. I thought "I'm not going to get to the bottom of this" so decided to create a blank XP install, and start afresh.

    Parallels Transporter allowing you to easily migrate your existing system to any Parallels enabled computer. clearly not a true representative statement to be making, Parallels!

    At one point I installed AVG anti-virus (which didn't require a reboot) and Cisco VPN (which did require a reboot). After I had rebooted, my Windows XP virtual machine now hangs on the startup screen "Windows is starting up". I've left it like that for a good 15 minutes, and it doesn't go anywhere. I'm guessing it's the Cisco VPN stuff that's messed it up.

    This is hardly the easy migration I was expecting!
  6. Swift2001

    Swift2001 Member

    Install the system

    Then migrate the data and programs.
  7. Rachel Faith

    Rachel Faith Hunter

    Seems that several people have made these same posts and NO ONE from Parallels has replied to any of them. Please PT help us out and make some clear way for us to use this tool.
  8. Jaws

    Jaws Bit poster

    Will pay for help! Credit card, cash, pay-pal, name it!

    I just got the software and got the same result. I read your post and decided not to waste time and pay them to tell me. That was the biggest waste of all. I paid for the support. Spent 20 minutes on the phone with a guy who didn't even understand the problem, then he finnaly says: "Well they guy that helps with Transporter isn't really here today".

    I am willing to PAY someone, ANYONE, who can walk me through this.

    (waving credit card over my head) or pay-pal, whatever you prefer.
  9. lsnover

    lsnover Junior Member

    I'm having the same problem. My directory is WINDOWS so that is not the issue. I've been in touch with support and have not received an answer. I would also be willing to pay for a "support" incident to get a resolution to this issue.

  10. jabyuk

    jabyuk Bit poster

    It seems our comments are falling on deaf ears.

    I'm afraid you are going to have to resign yourselves, like I did, to the fact that Transporter just doesn't work as it's supposed to. I had to rebuild my install of XP from scratch which, although was a hassle, was worth it in the end. The reality is that you just don't need everything you had on the PC, because there are many equal, if not better, applications that do the same thing under OS X. So you could try to look at it in a positive light like I did, and think "well it's time for a clean out".

    I imagine it's not what you want to hear - it wouldn't have been what I wanted to hear a few weeks back. I'm sorry I can't be of any more help!
  11. lsnover

    lsnover Junior Member


    It's not your problem. Parallels should be dealing with this. I need the things on my PC, and would prefer not to have to start over. It takes me many days to get a new OS just the way I want.


  12. Kit

    Kit Bit poster

    Well, reading all this with no input from Parallels is hugely discouraging, and makes me think it may not be worth the trouble to try the program at all. But here's my question to the last person who actually did respond: How do you rebuild an install of XP on Mac from scratch?

    I'm sure it's a long detailed process, but just some general tips on where to look to begin the process would be welcomed.
  13. sparker

    sparker Member

    I'm having a similar problem with the Transporter. Funny history, though. I started in parallels, and moved my XP to VMWare using VMWare's equivalent of the transporter which worked GREAT (once I figured out how to shrink my drive down to a reasonable size). Now I'm trying to migrate back to Parallels, and the transporter doesn't acknowledge that it's a bootable drive.


    Even more disheartening is that not one time has anybody from Parallels responded to this thread with any tips, hints or suggestions. Talk about bad PR. I think we should all post to every BLOG that we know that 1) Parallels is not a bad product and can do some really cool things, and 2) That there is no known way of getting ANY support on anything to do with Parallels. It appears there may not be a support division of Parallels at all...

    After all, look at how many threads on this forum say exactly the same thing... "Hello, anybody there...."

  14. Mike@Parallels

    Mike@Parallels Hunter


    Start Parallels Transporter – Click Next – Advanced – From Virtual Computer – Entire Virtual Computer – set path to your VMware image – migration begins.

    If you see error: Parallels won’t be able to make it bootable – click OK.

    After migration Start Parallels Transporter – Click Next – Advanced – From Virtual Computer – Single virtual disk - set path to .hdd (parallels hard drive) you get from previous migration.

    Note: Always use last version of Transporter please
  15. stuffing

    stuffing Bit poster


    That doesn't work either. I have just spent a couple of hours trying this three times with a VMWare volume. Every time I get the error "There is no operating system on the selected disk image, or Parallels Transporter is unable to make it bootable." Hmmmm. I wonder which one it is? Seeing as the volume boots perfectly in VMWare.

    I am not converting to Parallels, I just wanted to see if this really worked, as everything else about Parallels doesn't. I'm sticking with VMWare and would advise anyone else to do so also.
    Last edited: Sep 21, 2007
  16. ronaldo5285

    ronaldo5285 Bit poster

    I got the same problem and I've just realized that because my i386 folder is not located in Windows\driver cache but in C:
    So I just use Parallels Transporter to make the .hdd file then later, import the disk and choose the I386 folder( which is copied to my Mac)
    Seem like it worked
  17. ronmolenda

    ronmolenda Bit poster

    This method basically did work for me, thanks. I migrated a Virtual PC 6 Windows 98SE image and ignored the warnings. I was unable to import the disk in Parallels, but I created a new Win98 virtual machine and assigned the migrated hard drive in place of the default one. Bingo!

    Booted into safe mode, removed the VPC client software that was causing an fshare32 error, and restarted. Everything has been perfect since then.

    Now if only I could get shared folder/networking going...

    Thanks again.
  18. jbh001

    jbh001 Member

    Shared Folder isn't supported under Windows 98SE by Parallels.

    I've given up on trying to get Windows 98SE trying to recognize my USB flash drive.

    If you don't want to copy the contents of your flash drive to a folder within your home directory on the Mac (which is what I originally did), there is a way to hack the Mac OS to let Windows see the USB flash drive attached to your Mac.

    But a simpler solution is to use the freeware program SharePoints to do this hacking for you.

    With SharePoints, you give your flash drive a unique name, and then enable SMB so that Windows can see it. From Windows, you should then be able to read and write to the flash drive just as though it were any other drive on the Windows network. I thought the process was rather intuitive, but if you need more detail to make it work, let me know.

    In my case, after sharing the flash drive on the Mac via SharePoints, I can point Windows to my Mac (e.g. \\jbhmacmini\) then click on the now-visible flash drive, and even drag a shortcut for it to my Windows desktop for easier navigation.

    I now have two network links from my within my Parallels VM back to my Mac:

    PS: On the Mac I have enabled both Personal File Sharing and Windows Sharing on the Mac's System Preferences.
  19. JoseG

    JoseG Bit poster

    Same problem here

    I'm experiencing the same problems. Can only migrate the volumes of a Windows XP Pro SP2 computer as data volumes.

    I have not been able to make my boot disk bootable in any way.

    Please, any help appreciated.

    Thank you.
  20. JoseG

    JoseG Bit poster



    I have discovered that user manual says that IDE hard disk controllers are a requirement in the computer being migrated. My boot disk has SATA interface.

    So I guess that my problem is that Transporter can't apply hardware changes to my boot disk because it does not know how to deal with SATA.

    Am I correct? If this is the case, what possible workarounds can I follow?

    Thank you.

Share This Page