"You do not have access rights... See your administrator for access to this folder."

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by AudreyW, Feb 9, 2022.

  1. AudreyW

    AudreyW

    Messages:
    1
    My problem is that I cannot save any files to my Mac through the Parallels desktop. I downloaded Revit on the Parallels desktop, but when I try to save a file, it pops up with a message: "You do not have access rights to \\Mac\Home\Documents\REVIT\Project1.rvt. See your administrator for access to this folder." The thing is, on my Mac's end I already gave Parallels full disk access, and on the Parallels Windows "Configuration" menu I also selected Full Disk Access. I restarted Parallels and my Mac computer several times and nothing is working. What could be the problem here? Does anyone know how to fix it?
     
    DanushR, BrandonK5 and user 01 like this.
  2. user 01

    user 01 Bit Poster

    Messages:
    1
    I join the question. I have the same problem.
    I hope for an ambulance from the manufacturer.
     

    Attached Files:

    BrandonK5 likes this.
  3. BrandonK5

    BrandonK5 Bit Poster

    Messages:
    2
    Hi AudrewW & user 01,

    I found a temporary solution is in Parallels Taskbar icon (on Mac side) > Configure > Options > Sharing > Share Mac

    Uncheck the sharing privelages and set the "Share folders" option to "none".

    That will allow you save the project file to a location inside the Windows Virtual machine. I still don't know how to fix it to where I can have the folders shared and save a project file to the deskop while in the Windows virtual machine.

    Can someone answer our question of how to save files to the desktop while "Share Mac" options are enabled?
     
  4. BrandonK5

    BrandonK5 Bit Poster

    Messages:
    2
    Hi AudreyW & user01,

    I was able to get it fixed. There was another thread where someone solved essentially the same thing, saving files from Microsoft and other applications to shared folders.

    https://kb.parallels.com/en/128833

    Directions:
    Follow the directions in that thread
    2. Change Sharing privaleges in Parallels configuration screen to full disk access
    3. In my case I was not seeing files that I saved to the Windows side desktop and had hidden items visible. I turned of viewing hidden items, and it started working for me.

    I hope this helps you two with your file saving problems. Thanks for posting about the problem. Please see the text of the other thread below.


    When running Microsoft Office in Windows ARM on a Mac computer with Apple M1 Chip, you may encounter difficulties saving files. It can either be an error, or a destination folder resetting to "Network Shortcuts".

    [​IMG]
    [​IMG]
    Similar behavior may also occur in some other applications.

    Solution
    To fix this situation, please perform the following steps:

    1. In Windows, download this archive.

    [​IMG]
    2. Unpack prl_np.dll inside it.

    [​IMG]
    3. Go to C:\windows\system32\ and locate a prl_np.dll file already located in this folder.

    [​IMG]
    4. Rename prl_np.dll to something else (e.g., "prl_np.d").

    [​IMG]
    [​IMG]
    5. Then move the prl_np.dll file downloaded earlier into C:\windows\system32\

    [​IMG]
    6. Restart the respective Microsoft Office application.



    Note. Reinstalling Parallels Tools will revert this workaround, and the behavior will reoccur. A permanent fix will be included in an upcoming Parallels Desktop update.
     

    Attached Files:

Share This Page