you do not have enough rights to use this virtual machine

Discussion in 'Installation and Configuration of Parallels Desktop' started by jesaf00, Nov 11, 2008.

  1. utopia

    utopia Junior Member

    Hi John, thanks but I'm not quite sure what you mean and how to do it.
  2. John@Parallels

    John@Parallels Forum Maven

    Files are on Mac OS side, please put file to c:
    and check situation
  3. macfreq

    macfreq Bit poster

    Single user problem also

    I'm installing Parallels 4.0 on a networked Mac. It is an Open Directory network with Tiger server. I'm logging in with a network account and trying to create a windows XP VM for the first time. I'm not sharing this VM.
    As soon as I finish entering the XP license code to start the installation I get the "You do not have enough rights to use this virtual machine".
    I checked the permissions for the Windows XP.pvm and the user owns it and has read/write permissions. So I'm stumped at why this is not working.

    I just finished doing a similar Parallels 4.0 and XP install for another network user and didn't have any problems.

  4. Olivier

    Olivier Forum Maven

    I have seen this behaviour in the past. When the problem occurs, check the /tmp directory on the mac. You should see some file with a name like "{some-hex-values}" (looks like a GUID). Also open the Console application from the Utilities and look for the Parallels.log, you should quickly identify some errors about that file close to the end of the parallels.log file.

    The cure was to logon with a local user and disconnect that computer from the domain. Start Parallels, no issue. Reconnect the machine to the domain, it didn't happened again since.

    From reliefs I have kept it looks like the file which was the culprit was created by one parallels process running with user privileges with a group name of "DOMAIN\Domain Users" and that same file could not be opened by some other parallels process running with other privileges in the background.

    Your specific case might be different, but there seem to be similarities. I'd test disconnecting from the domain and reconnecting it to see if it fixes it too.
  5. Pariahware

    Pariahware Junior Member

    I just had this happen today. I had to change the permissions of the config file from 644 to 744.
  6. wad11656

    wad11656 Bit poster

    Pariahware, it seems you have finally solved the issue today. But how exactly do you change the permissions of the "config file"? And how do I access the "config" file? Do I need to obtain a separate application in order to access and modify this file? Thank you.
  7. sandro

    sandro Parallels Developers

    Please take a look on This article contains instructions on VM files permissions modification.
  8. wad11656

    wad11656 Bit poster

    Thank you very much!

    Worked perfectly!
  9. beta_willray

    beta_willray Bit poster

    I finally got the permissions situated thanks to the 5733 article. and i can access the vm in multiple user accounts.

    But, now each time I open the vm it states the mac address is different and i have to choose to use same one or new one . ive done both and each time a new vm (1) is created corrupting the original. so, although the new one works i have to deal with a corrupted old one each time a new user opens the vm.

  10. sandro

    sandro Parallels Developers

    during VM registration there is a question whether you moved or copied this VM. In order to safe old MAC-address please answer always "Moved" during registration under other user.

Share This Page